Bug 450741 - ATI Rage IIc video card can't handle firstboot's choice of 24-bit color
ATI Rage IIc video card can't handle firstboot's choice of 24-bit color
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 15:06 EDT by Andre Robatino
Modified: 2008-11-23 08:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 15:22:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2008-06-10 15:06:49 EDT
Description of problem:
I have an eMachines 333cs with a Trigem Delhi III motherboard with a 4 MB ATI
Rage IIc video card.  This card is known to have trouble with more than 16-bit
color when set at a decent resolution.  During initial installation, the video
is fine.  But during and after firstboot, the video is corrupted, indicating
that the video is now in a barely usable 24-bit mode with massive video
corruption.  At this point, I half-blindly stumble through firstboot and into
initial login, where I go to system-config-display to set the color depth from
"millions of colors" down to "thousands of colors" where the display looks
normal again after restarting X.  Anaconda recognizes both my monitor and video
card.  It would be nice if firstboot could set the color depth to 16 bits
automatically (an alternative would be to make the resolution sufficiently low,
but I think that for most people a good resolution is more important than the
tiny difference between 16- and 24-bit color).

Version-Release number of selected component (if applicable):
firstboot-1.97-1.fc9.i386

How reproducible:
always

Additional info:
This problem has existed for years, I just haven't gotten around to reporting it
until now.  My father has a machine with the same motherboard and problem and
it's difficult for me to walk him through installation over the phone when he
can't even read the display.
Comment 1 Chris Lumens 2008-06-10 15:22:09 EDT
This is fixed in rawhide, where we are no longer setting up our own special X
environment but instead are using X to set itself up.  If you continue to see
problems there, we'll need to file a bug against X because it's detecting things
wrong.
Comment 2 Andre Robatino 2008-06-10 15:45:43 EDT
I will probably wait until F10 before attempting another install.  If the
problem persists, should the component I report it under be xorg-x11?  And is
the video mode in initial install now set using the same method as used during
firstboot and after (so the video would either be corrupted all the way through,
or never)?
Comment 3 Chris Lumens 2008-06-10 15:51:25 EDT
You can install the rawhide firstboot without dragging in the rest of rawhide to
test that out.

The new plan for anaconda and firstboot is that we are entirely using X, and
don't require any config file.  So whatever X detects and sets up in anaconda
will be the same as firstboot which will be the same as the running system.  So
yes it should either work everywhere or nowhere, but xorg-x11 would be the
component to file against if it doesn't work anywhere.
Comment 4 Andre Robatino 2008-11-23 08:33:16 EST
I just attempted install using an early copy of the Fedora 10 i386 DVD (sha1sum 086fd570518ac58d3966c43c1b6d146e38919d8d).  Unfortunately, the video is screwed up from the beginning now, so I can't install at all.  Filed bug #472687 against xorg-x11 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.