Bug 472687 - ATI Rage IIc video card can't handle Fedora 10's choice of video mode during install
ATI Rage IIc video card can't handle Fedora 10's choice of video mode during ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mach64 (Show other bugs)
11
i386 Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-23 08:30 EST by Andre Robatino
Modified: 2009-07-15 15:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 15:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (688 bytes, text/plain)
2008-11-25 05:13 EST, Andre Robatino
no flags Details
/var/log/Xorg.0.log (33.46 KB, text/plain)
2008-11-25 05:15 EST, Andre Robatino
no flags Details
/var/log/anaconda.log (25.58 KB, text/plain)
2008-11-25 05:15 EST, Andre Robatino
no flags Details
/var/log/anaconda.syslog (26.83 KB, text/plain)
2008-11-25 05:16 EST, Andre Robatino
no flags Details
/var/log/Xorg.0.log after moving xorg.conf to xorg.conf.old - distorted video again (36.21 KB, text/plain)
2008-11-25 05:36 EST, Andre Robatino
no flags Details
/var/log/Xorg.0.log after replacing mach64 with vesa (40.15 KB, text/plain)
2009-02-20 18:48 EST, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2008-11-23 08:30:47 EST
Description of problem:
Attempted install of early leaked version of Fedora 10 i386 DVD (sha1sum 086fd570518ac58d3966c43c1b6d146e38919d8d) on an eMachines 333cs with ATI Rage IIc video.  This hardware is known to not be able to handle 24-bit color when set to a decent resolution, making it necessary to use 16-bit.  In Fedora 9 and earlier, the video was fine during the initial install, but was screwed up in firstboot.  It was possible to stumble through and finally reset the video to a usable mode.  In Fedora 10, the video is screwed up from the beginning, making it impossible to install at all (it's probably possible with a kickstart file, but I don't know how to do that).

Version-Release number of selected component (if applicable):
not sure

How reproducible:
always

Additional info:
Earlier filed related bug #450741.
Comment 1 Matěj Cepl 2008-11-24 06:16:29 EST
1) You can always install in text mode (put "linux text" on the install command line instead of just "linux").

2) You can also put xdriver=vesa there, so instead of just "linux" it would be "linux xdriver=vesa"

Does it help?

If you are able to install, could you please attach your X server config (/etc/X11/xorg.conf), X server log (/var/log/Xorg.*.log), and /var/log/anaconda.xlog files to this bug report as individual uncompressed file attachments using the bugzilla file attachment link below?

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Andre Robatino 2008-11-25 05:13:32 EST
Created attachment 324575 [details]
/etc/X11/xorg.conf
Comment 3 Andre Robatino 2008-11-25 05:15:00 EST
Created attachment 324576 [details]
/var/log/Xorg.0.log
Comment 4 Andre Robatino 2008-11-25 05:15:47 EST
Created attachment 324577 [details]
/var/log/anaconda.log
Comment 5 Andre Robatino 2008-11-25 05:16:25 EST
Created attachment 324578 [details]
/var/log/anaconda.syslog
Comment 6 Andre Robatino 2008-11-25 05:22:27 EST
I finished a text-based install.  Unfortunately, the text-based version of firstboot didn't ask me to create an ordinary user account, and dropped me to a text login prompt.  So, as root, I ran "startx" to log in graphically, did "yum install system-config-display" after finding that it was not installed by default, then used it to change "millions of colors" to "thousands of colors".  Then since I could now see what I was doing, I created an ordinary user account, changed the default runlevel in /etc/inittab from 3 to 5, and was in business.

I will now try to run without xorg.conf and then attach /var/log/Xorg.0.log from that below.
Comment 7 Andre Robatino 2008-11-25 05:36:44 EST
Created attachment 324584 [details]
/var/log/Xorg.0.log after moving xorg.conf to xorg.conf.old - distorted video again
Comment 8 Bug Zapper 2008-11-26 00:49:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 François Cami 2009-02-20 17:33:33 EST
Andre,

Does booting the installer with "linux xdriver=vesa" help ?

Thank you.
Comment 10 Andre Robatino 2009-02-20 17:59:24 EST
Yes, it does.  When I add xdriver=vesa to the options, what I get is a smaller but properly drawn version of the install screen, a little left of center and taking up roughly half the area of the screen, surrounded by black.  I'm not going to attempt an actual install, but at least at the beginning the installer is now usable.
Comment 11 François Cami 2009-02-20 18:17:07 EST
Thank you Andre.

Could you try using the vesa driver in xorg.conf and post /var/log/Xorg.0.log of that attempt as well ?

Switching component to xorg-x11-drv-mach64 .
Setting severity to low as there is a workaround.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Andre Robatino 2009-02-20 18:48:06 EST
Created attachment 332779 [details]
/var/log/Xorg.0.log after replacing mach64 with vesa

After editing xorg.conf and replacing "mach64" with "vesa", and restarting X, the display is shifted about an inch to the left but otherwise normal.
Comment 13 Andre Robatino 2009-06-06 20:58:53 EDT
I finished an install of F11 Final (A.K.A RC4) and using xdriver=vesa allowed me to get through the install and firstboot without trouble.  However, shortly after logging into X, the X server appeared to crash and I was back at the login prompt.  It was necessary to delete xorg.conf to switch back to the mach64 driver, which allowed me to log in without X crashing, but with the video corruption.  Using system-config-display, I fixed the display settings and now everything is normal.  So xdriver=vesa is not a perfect workaround.
Comment 14 Adam Jackson 2009-07-15 15:37:50 EDT
Flipped the mach64 default depth to 16 in rawhide.
Comment 15 Andre Robatino 2009-07-15 15:42:58 EDT
Unfortunately, my box is i686 but not PAE which means that it will probably not meet F12's hardware requirements (and the same is probably true for almost all affected hardware).  Can this change be pushed to an F11 update so one of Fedora Unity's updated images would be usable for an install?

Note You need to log in before you can comment on or make changes to this bug.