Bug 450770 - ext3: potential data corruption on log replay
ext3: potential data corruption on log replay
Status: CLOSED DUPLICATE of bug 447742
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Eric Sandeen
Martin Jenner
Depends On:
Blocks: 450772
  Show dependency treegraph
Reported: 2008-06-10 17:05 EDT by Eric Sandeen
Modified: 2008-06-12 10:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-12 10:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-06-10 17:05:02 EDT
This is very rare but also obvious enough I think it's worth fixing up.

From: Duane Griffin <duaneg@dghda.com>
Date: Thu, 20 Mar 2008 00:00:53 +0000 (-0700)
Subject: jbd: correctly unescape journal data blocks
X-Git-Tag: v2.6.25-rc7~82

jbd: correctly unescape journal data blocks

Fix a long-standing typo (predating git) that will cause data corruption if a
journal data block needs unescaping.  At the moment the wrong buffer head's
data is being unescaped.

To test this case mount a filesystem with data=journal, start creating and
deleting a bunch of files containing only JFS_MAGIC_NUMBER (0xc03b3998), then
pull the plug on the device.  Without this patch the files will contain zeros
instead of the correct data after recovery.

Signed-off-by: Duane Griffin <duaneg@dghda.com>
Acked-by: Jan Kara <jack@suse.cz>
Cc: <linux-ext4@vger.kernel.org>
Cc: <stable@kernel.org>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 1 RHEL Product and Program Management 2008-06-10 17:10:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 3 Eric Sandeen 2008-06-12 10:29:45 EDT
oops, Josef already sent this!

*** This bug has been marked as a duplicate of 447742 ***

Note You need to log in before you can comment on or make changes to this bug.