Bug 450772 - ext3: potential data corruption on log replay
ext3: potential data corruption on log replay
Status: CLOSED DUPLICATE of bug 447741
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
All Linux
low Severity low
: rc
: ---
Assigned To: Eric Sandeen
Martin Jenner
:
Depends On: 450770
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 17:06 EDT by Eric Sandeen
Modified: 2008-06-12 10:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 10:28:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-06-10 17:06:36 EDT
+++ This bug was initially created as a clone of Bug #450770 +++

This is very rare but also obvious enough I think it's worth fixing up.

From: Duane Griffin <duaneg@dghda.com>
Date: Thu, 20 Mar 2008 00:00:53 +0000 (-0700)
Subject: jbd: correctly unescape journal data blocks
X-Git-Tag: v2.6.25-rc7~82
X-Git-Url:
http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=439aeec639d7c57f3561054a6d315c40fd24bb74

jbd: correctly unescape journal data blocks

Fix a long-standing typo (predating git) that will cause data corruption if a
journal data block needs unescaping.  At the moment the wrong buffer head's
data is being unescaped.

To test this case mount a filesystem with data=journal, start creating and
deleting a bunch of files containing only JFS_MAGIC_NUMBER (0xc03b3998), then
pull the plug on the device.  Without this patch the files will contain zeros
instead of the correct data after recovery.

Signed-off-by: Duane Griffin <duaneg@dghda.com>
Acked-by: Jan Kara <jack@suse.cz>
Cc: <linux-ext4@vger.kernel.org>
Cc: <stable@kernel.org>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 1 RHEL Product and Program Management 2008-06-10 17:09:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Eric Sandeen 2008-06-12 10:28:43 EDT
Oops, Josef did this already.

*** This bug has been marked as a duplicate of 447741 ***

Note You need to log in before you can comment on or make changes to this bug.