Bug 450845 - Fujitsu-Siemens with S3 Unichrome chip detects wrong screen resolution
Fujitsu-Siemens with S3 Unichrome chip detects wrong screen resolution
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
: Reopened, Triaged
: 492527 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-06-11 06:35 EDT by Valent Turkovic
Modified: 2010-05-05 03:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-05-05 03:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gdm screen (76.96 KB, image/jpeg)
2008-06-11 06:36 EDT, Valent Turkovic
no flags Details
xorg.conf (598 bytes, text/plain)
2008-06-12 09:05 EDT, Valent Turkovic
no flags Details
Xorg.0.log (52.63 KB, text/plain)
2008-06-12 09:05 EDT, Valent Turkovic
no flags Details
Xorg.0.log with openchrome-0.2.902 (52.18 KB, text/plain)
2008-10-06 14:31 EDT, Valent Turkovic
no flags Details
Xorg.0.log - openchrome-0.2.903 (52.64 KB, text/plain)
2008-10-06 17:23 EDT, Valent Turkovic
no flags Details
Patch which add panel support for K8M800 and PM800 (1.05 KB, patch)
2009-06-02 09:07 EDT, Bartosz
no flags Details | Diff

External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 353208 None None None Never

  None (edit)
Description Valent Turkovic 2008-06-11 06:35:15 EDT
Description of problem:
On GDM screen and in GNOME laptop has wrong resolution detected (see the
attachement). After setting resolution in "System /
Preferences / Hardware / Screen Resolution" then in Gnome after login I see the
correct resolution but still on each GDM I see that the correct resolution is
not detected (look at the attachement).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Valent Turkovic 2008-06-11 06:36:15 EDT
Created attachment 308916 [details]
gdm screen

gdm login with wrong resolution set.
Comment 2 Xavier Bachelot 2008-06-11 06:47:15 EDT
Rather than a screenshot, I'd like to have the xorg conf and xorg log, please.
This can probably be worked around by setting the correct resolution in the xorg
Comment 3 Valent Turkovic 2008-06-12 09:05:18 EDT
Created attachment 309066 [details]
Comment 4 Valent Turkovic 2008-06-12 09:05:50 EDT
Created attachment 309067 [details]
Comment 5 Xavier Bachelot 2008-06-12 19:25:49 EDT
As a workaround, in the Display SubSection of your xorg.conf, add the following
line :
Modes    "1024x768"

I'm afraid there's not much that can be done for this bug until some development
around the panel code happen upstream.
Comment 6 Valent Turkovic 2008-06-13 04:15:02 EDT
Sorry for my ignorance, but what do you mean by "upstream panel code"? Do you
mean that I should report this bug to upstream unichrome project? X11? Or
something else.

Comment 7 Xavier Bachelot 2008-06-13 05:06:02 EDT
Sorry for not being clear. Upstream is currently working on improving the panel
code. This code is not completely stable yet, but I hope it will be in the
coming weeks. I'm following openchrome development very closely and the new code
will be in Rawhide soon after it is in openchrome subversion repository.
Actually, there is already a pre-version of this code in Rawhide, but I can't
promise it'll work. For the time being, the only possible solution to your
problem is probably to work around it.
One other possible workaround could be to use Option "PanelSize" "1024x768" in
the Device section of xorg.conf, with or without Modes "1024x768" in  the
Display SubSection.
Comment 8 Valent Turkovic 2008-06-13 05:52:50 EDT
Oh, thank you.

I can live with this bug and if you need I can test the new openchorome driver
code if it will be pushed into Fedora 9 testing-updates repo. Just tell me if
you would find my feedback helpful or if you got everything under control :)
Comment 9 Xavier Bachelot 2008-06-30 19:26:18 EDT
Valent, can you please give the latest rawhide package a try ?
Comment 10 Valent Turkovic 2008-08-11 12:17:11 EDT
ok, I'll try it...
Comment 11 Valent Turkovic 2008-08-11 13:13:43 EDT
It is still the same. I'll upload  Xorg.0.log a bit later.
Comment 12 Valent Turkovic 2008-10-06 14:28:28 EDT
I tested xorg-x11-drv-openchrome-0.2.902-10.fc10.i386 and I still see the same issue.
Comment 13 Valent Turkovic 2008-10-06 14:31:08 EDT
Created attachment 319584 [details]
Xorg.0.log with openchrome-0.2.902

Xorg.0.log - I hope you get something out of this
Comment 14 Valent Turkovic 2008-10-06 17:23:03 EDT
Created attachment 319599 [details]
Xorg.0.log - openchrome-0.2.903

Xorg.0.log - openchrome-0.2.903
Comment 15 Valent Turkovic 2008-10-07 13:19:38 EDT
I tested this laptop with Fedora 10 beta and still no change, the screen is set to much higher resolution than it really is and I have problems even login on because I see only 1/4 of the screen :(
Comment 16 Xavier Bachelot 2008-10-08 08:22:31 EDT
Unfortunately, the new upstream panel code doesn't support the CN400 chipset, it's aimed at K8M890, P4M900 and CX700. I had a try at enabling the panel code for CN400, VM800 and P4M890, but the test wasn't fully successful on a VM800, so I reverted the change. You'll have to live with the old modesetting method (VBE) for now, sorry about that.
Comment 17 Xavier Bachelot 2009-03-27 08:09:34 EDT
*** Bug 492527 has been marked as a duplicate of this bug. ***
Comment 18 Bartosz 2009-06-02 09:07:23 EDT
Created attachment 346247 [details]
Patch which add panel support for K8M800 and PM800

Please apply this patch to the latest openchrome driver.

For ubuntu build/installation process was described at:

Is it works for you?
Please attach Xorg.0.log file.
Comment 19 Bug Zapper 2009-06-09 21:33:02 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 20 Martin Thain 2009-06-10 10:07:34 EDT
I found this problem still exists in Fedora 11.
I had to install using text mode and a just my xorg.conf file manually.
Comment 21 Bug Zapper 2009-07-14 14:26:19 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 22 Martin Thain 2009-10-06 17:27:25 EDT
 A patch has been reported as being available for this bug.
See attachment " Patch which add panel support for K8M800 and PM800   (1.05 KB, patch)
2009-06-02 09:07 EDT, Bartosz "

Any idea when a development RPM will be available?
Comment 23 Xavier Bachelot 2009-10-07 17:47:42 EDT
(In reply to comment #22)
>  A patch has been reported as being available for this bug.
> See attachment " Patch which add panel support for K8M800 and PM800   (1.05 KB,
> patch)
> 2009-06-02 09:07 EDT, Bartosz "
> Any idea when a development RPM will be available?  

Now that F12 is branched, I'll start to add more patches to the devel branch once openchrome 0.2.904 is out (should be real soon now).
Comment 24 Matěj Cepl 2009-11-05 12:11:54 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 25 Martin Thain 2009-11-07 07:45:37 EST
I just checked on Fedora 12 Beta and the bug is still present. 

Please keep this bug open. See also comments from Xavier Bachelot above.
Comment 26 Bug Zapper 2009-11-16 03:08:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
Comment 27 Bartosz 2009-11-21 02:22:38 EST
Check if the latest openchrome fixes this bug.

This bug should be fixed in svn818 :
Comment 28 Matěj Cepl 2010-02-26 07:19:23 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 29 Xavier Bachelot 2010-03-20 09:27:36 EDT
Might be fixed with xorg-x11-drv-openchrome-0.2.904-2.fc12 which will hit updates-testing shortly.
Comment 30 Jeff Raber 2010-05-05 03:12:35 EDT
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.


Fedora Bugzappers volunteer triage team

Note You need to log in before you can comment on or make changes to this bug.