Bug 452392 - File conflicts with libkdcraw/libkipi
File conflicts with libkdcraw/libkipi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: KDE41
  Show dependency treegraph
 
Reported: 2008-06-21 18:58 EDT by Bill Crawford
Modified: 2008-07-21 13:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 13:39:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2008-06-21 18:58:39 EDT
Description of problem:
File conflicts with libkipi (listed below)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
  file /usr/share/icons/hicolor/128x128/apps/kdcraw.png from install of
kdegraphics-4.0.83-1.fc10.i386 conflicts with file from package
libkdcraw-0.1.4-1.fc10.i386
  file /usr/share/icons/hicolor/32x32/apps/kdcraw.png from install of
kdegraphics-4.0.83-1.fc10.i386 conflicts with file from package
libkdcraw-0.1.4-1.fc10.i386
  file /usr/share/icons/hicolor/48x48/apps/kdcraw.png from install of
kdegraphics-4.0.83-1.fc10.i386 conflicts with file from package
libkdcraw-0.1.4-1.fc10.i386
  file /usr/share/icons/hicolor/64x64/apps/kdcraw.png from install of
kdegraphics-4.0.83-1.fc10.i386 conflicts with file from package
libkdcraw-0.1.4-1.fc10.i386
  file /usr/share/icons/hicolor/128x128/apps/kipi.png conflicts between
attempted installs of kdegraphics-4.0.83-1.fc10.i386 and libkipi-0.1.6-1.fc10.i386
  file /usr/share/icons/hicolor/16x16/apps/kipi.png conflicts between attempted
installs of kdegraphics-4.0.83-1.fc10.i386 and libkipi-0.1.6-1.fc10.i386
  file /usr/share/icons/hicolor/22x22/apps/kipi.png conflicts between attempted
installs of kdegraphics-4.0.83-1.fc10.i386 and libkipi-0.1.6-1.fc10.i386
  file /usr/share/icons/hicolor/32x32/apps/kipi.png conflicts between attempted
installs of kdegraphics-4.0.83-1.fc10.i386 and libkipi-0.1.6-1.fc10.i386
  file /usr/share/icons/hicolor/48x48/apps/kipi.png conflicts between attempted
installs of kdegraphics-4.0.83-1.fc10.i386 and libkipi-0.1.6-1.fc10.i386


Expected results:


Additional info:
Comment 1 Rex Dieter 2008-06-24 12:50:42 EDT
I'll take care of this.
Comment 2 Rex Dieter 2008-06-24 14:42:14 EDT
stage 1: fix runtime conflicts, -devel conflicts remain (%_libdir symlinks, 
pkgconfig).
Comment 3 Rex Dieter 2008-07-17 09:21:29 EDT
Re-opening, pending -devel fixes.
Comment 4 Rex Dieter 2008-07-17 09:50:00 EDT
-devel symlinks are fixable (using similar hacks such as in kdegames), but I'm 
stumped what to do with the pkgconfig files.  

Ideas?  Suggestions?
Comment 5 Kevin Kofler 2008-07-17 09:57:11 EDT
We could require setting a nonstandard PKG_CONFIG_PATH. But I wonder if it is 
really worth it in this case.
Comment 6 Rex Dieter 2008-07-17 10:12:13 EDT
Evil idea, since nothing that I know-of even uses the kde4-versions of these 
libraries, we could (temporarily?) omit their conflicting -devel parts.
Comment 7 Kevin Kofler 2008-07-17 10:17:15 EDT
But the KDE 4 Digikam will surely use them? (But will we still need the KDE 3 
versions when we'll have KDE 4 Digikam?)

Otherwise, only Gwenview (which is in kdegraphics itself, so it doesn't need a 
kdegraphics-devel), I don't think anything can use them yet.
Comment 8 Kevin Kofler 2008-07-17 10:17:54 EDT
Uh, mixed up formulations there, I mean:
Otherwise, other than Gwenview (which is in kdegraphics itself, so it doesn't 
need a kdegraphics-devel), I don't think anything can use them yet.
Comment 9 Rex Dieter 2008-07-17 10:31:52 EDT
Cool, looks like omitting the kde4-devel bits for F-9 is doable.

Moving forward with F-10+, I'm pretty sure we can drop the kde3-devel bits, and
other related apps needing kde4 upgrades will include kipi-plugins, kphotoalbum,
showimg.

Comment 10 Bill Crawford 2008-07-17 11:30:43 EDT
If the libs are very incompatible, shouldn't the .pc file get a rename to
include a version number?
Comment 11 Rex Dieter 2008-07-17 11:40:46 EDT
In a perfect world, yes, but that's only if upstream has the means and intention
to support parallel-install of said versions.
Comment 12 Rex Dieter 2008-07-21 13:39:36 EDT
alright, implemented ideas from comment #9 into kdegraphics-4.0.99-2

Note You need to log in before you can comment on or make changes to this bug.