Bug 452701 - hal-info-20080607-1.fc8 crashes hald
hal-info-20080607-1.fc8 crashes hald
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: EasyFix
: 454946 455577 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 11:16 EDT by Orion Poplawski
Modified: 2013-03-05 22:56 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 17:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full output from hald (131.39 KB, text/plain)
2008-06-24 11:16 EDT, Orion Poplawski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 456310 None None None Never

  None (edit)
Description Orion Poplawski 2008-06-24 11:16:15 EDT
Description of problem:

Installed hal 0.5.10-3.fc8.i386 and hal-info 20080607-2.fc8.noarch from
updates-testing.  hald crashes with:

16:38:39.110 [I] osspec.c:439: Done synthesizing events
*** [DIE] device_info.c:rules_match_and_merge_device():1089 : Rule is NULL on jump
16:38:39.111 [D] addon-input.c:486: An error occured, exiting cleanly
Comment 1 Orion Poplawski 2008-06-24 11:16:15 EDT
Created attachment 310156 [details]
Full output from hald
Comment 2 Kevin R. Page 2008-06-27 15:34:52 EDT
Does the newer hal-info-20080607-2.fc8 crash the previous version of the hal
package as well?

i.e. is it an addition to the fdi in hal-info triggering a previously existing,
but not triggered, bug? In which case a band aid might be to patch out that
addition...

(No crash for me; but need these updated hal/hal-info packages to unblock
another bug!)
Comment 3 Kevin R. Page 2008-07-07 12:41:14 EDT
After a bit of brute force googling through the long grass of the Debian BTS and
svn, I suspect that this is the patch you need:
http://patches.ubuntu.com/by-release/extracted/debian/h/hal/0.5.10-5/91_fix_invalid_fdi_cache_on_empty_matches.patch

The error on crash is the same, at least ;)

It's not applied to the hal-0.5.10 the F8 package pulls in, nor is it in the
package patchset.

Orion: I'm not seeing this crash in the first place - can you give the patch a try?

(I'm very keen to get this hal release working; bug #280251 has been blocking on
a hal update for a loooong time)
Comment 4 Kevin R. Page 2008-07-07 13:03:14 EDT
That patch made it into upstream hal at:
http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=75965fdc42620f57bdf9c9138f9d30f0af5b284d
Comment 5 Alex Lancaster 2008-07-09 04:18:50 EDT
I can reproduce this bug, this also unfortunately crashes hal for me when I plug
in my Treo:

Jul  9 01:04:54 delpy kernel: hub 1-0:1.0: unable to enumerate USB device on port 1
Jul  9 01:04:55 delpy kernel: usb 2-1: new full speed USB device using uhci_hcd
and address 11
Jul  9 01:04:55 delpy kernel: usb 2-1: configuration #1 chosen from 1 choice
Jul  9 01:04:55 delpy kernel: usb 2-1: New USB device found, idVendor=0830,
idProduct=0061
Jul  9 01:04:55 delpy kernel: usb 2-1: New USB device strings: Mfr=1, Product=2,
SerialNumber=5
Jul  9 01:04:55 delpy kernel: usb 2-1: Product: Palm Handheld
Jul  9 01:04:55 delpy kernel: usb 2-1: Manufacturer: Palm, Inc.
Jul  9 01:04:55 delpy kernel: usb 2-1: SerialNumber: PalmSN12345678
Jul  9 01:04:55 delpy kernel: hald[6653]: segfault at b7def000 ip 08057206 sp
bfd86ce0 error 4 in hald[8047000+54000]

I also see a number  of other hal-related messages in /var/log/messages:

Jul  9 00:52:14 delpy kernel: hal-acl-tool[4726]: segfault at 9e00000 ip
00a650c7 sp bfffb7e8 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:14 delpy kernel: hal-acl-tool[4727]: segfault at 8b00000 ip
00a650c7 sp bfa78838 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:22 delpy kernel: hal-acl-tool[4737]: segfault at 8200000 ip
00a650c7 sp bfff65a8 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:22 delpy kernel: hal-acl-tool[4738]: segfault at 9500000 ip
00a650c7 sp bfed9498 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:24 delpy kernel: hal-acl-tool[4740]: segfault at 8500000 ip
00a650c7 sp bf8bae78 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:24 delpy kernel: hal-acl-tool[4741]: segfault at 9c00000 ip
00a650c7 sp bfd3e2f8 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:33 delpy kernel: hal-acl-tool[4751]: segfault at 8f00000 ip
00a650c7 sp bffc6d78 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:33 delpy kernel: hal-acl-tool[4752]: segfault at 9600000 ip
00a650c7 sp bf966c18 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:36 delpy kernel: hal-acl-tool[4755]: segfault at 9300000 ip
00a650c7 sp bfca2a58 error 4 in libc-2.7.so[9f8000+153000]
Jul  9 00:52:36 delpy kernel: hal-acl-tool[4756]: segfault at 0 ip 00a650db sp
bfec5478 error 6 in libc-2.7.so[9f8000+153000]

Also it doesn't appear to include 10-usb-pda-palm.fdi file in the RPM, which was
removed from pilot-link because it was supposed to be included in this update:

$ rpm -ql hal-info
/usr/share/doc/hal-info-20080607
/usr/share/doc/hal-info-20080607/AUTHORS
/usr/share/doc/hal-info-20080607/COPYING
/usr/share/doc/hal-info-20080607/ChangeLog
/usr/share/hal/fdi/information/10freedesktop/10-camera-ptp.fdi
/usr/share/hal/fdi/information/10freedesktop/10-cd-dvd-burner.fdi
/usr/share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-bluetooth.fdi
/usr/share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-wlan.fdi
/usr/share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-wwan.fdi
/usr/share/hal/fdi/information/10freedesktop/10-ipw-rfkill-switch.fdi
/usr/share/hal/fdi/information/10freedesktop/10-laptop-panel-hardware.fdi
/usr/share/hal/fdi/information/10freedesktop/10-modem.fdi
/usr/share/hal/fdi/information/10freedesktop/10-recall-battery-dell.fdi
/usr/share/hal/fdi/information/10freedesktop/10-recall-battery-fujitsu.fdi
/usr/share/hal/fdi/information/10freedesktop/10-recall-battery-gateway.fdi
/usr/share/hal/fdi/information/10freedesktop/10-recall-battery-ibm.fdi
/usr/share/hal/fdi/information/10freedesktop/10-recall-battery-lenovo.fdi
/usr/share/hal/fdi/information/10freedesktop/10-recall-battery-toshiba.fdi
/usr/share/hal/fdi/information/10freedesktop/10-sony-bluetooth-switch.fdi
/usr/share/hal/fdi/information/10freedesktop/10-thinkpad-rfkill-switch-bluetooth.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-card-readers.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-pda.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-zip-drives.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usbcsr-mice.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-apple.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-asus.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-fujitsu.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-lenovo.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-misc.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-samsung.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-sony.fdi
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-toshiba.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-compaq.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-dell.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-hp.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-lenovo.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-misc.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-module-asus-laptop.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-module-sony-laptop.fdi
/usr/share/hal/fdi/information/10freedesktop/30-keymap-module-thinkpad-acpi.fdi
/usr/share/hal/fdi/preprobe/10osvendor/10-ide-drives.fdi
/usr/share/hal/fdi/preprobe/10osvendor/20-broken-usb-sticks.fdi

This means if I remove my manually created file:
/usr/share/hal/fdi/information/20thirdparty10-usb-pda-palm.fdi then pilot-link
-l -p usb: hangs.
Comment 6 Alex Lancaster 2008-07-09 04:34:06 EDT
OK, it looks like I made a mistake.  I had not also installed the matching hal,
hal-libs as well (which is why it should have been included in the same update).
 Now it appears to not crash.

I was also looking at the wrong file for pda, support it appears to have been
absorbed into:

/usr/share/hal/fdi/information/10freedesktop/10-usb-pda.fdi
Comment 7 Radek Bíba 2008-07-10 13:43:03 EDT
Seems like I'm affected by this now, too. hal, hal-info and a few other packages
were updated on my box this morning, and haldaemon service now fails to start.
That's too bad because sound stopped working, and kpowersave is unhappy, too.
And there's probably a lot of other applications that can't work w/o hal. I'm
also getting:

*** [DIE] device_info.c:rules_match_and_merge_device():1089 : Rule is NULL on jump

when I run 'hald --daemon=no --verbose=yes'.

Downgrading to the previous hal-info version and starting the haldaemon service
 makes things work again. Aargh.
Comment 8 Kevin R. Page 2008-07-10 13:59:21 EDT
Radek, does the patch in comment #4 fix it for you? (I don't get the crash in
the first place to try it).
Comment 9 Radek Bíba 2008-07-10 14:27:09 EDT
Good news, Kevin. hal built locally with that patch added + the new hal-info work! 
Comment 10 Klaus Steinberger 2008-07-11 05:38:48 EDT
Yep, I had the same crash, the patch from comment #4 fixed it.
Comment 11 James Bottomley 2008-07-11 21:38:39 EDT
I just got a ton of "my network doesn't work" on Fujitsu lifebooks here, all of
which are traceable to the latest hal no longer starting.  The root cause is
this bug.

Falling back to the previous hal-info is what I'm currently doing
Comment 12 Kevin R. Page 2008-07-15 03:04:30 EDT
Orion: the fix is a patch that's already been committed upstream - could you add
the EasyFix keyword to the bug, please?
Comment 13 Orion Poplawski 2008-07-15 19:17:08 EDT
Comment #4 patch fixes for me too.  Changing to hal.  Let's get this fixed...
Comment 14 James Bottomley 2008-08-13 11:46:45 EDT
It's getting pretty ridiculous that this still hasn't been fixed in FC8 ... nearly two months after it was reported and at least six weeks after a valid and tested upstream fix has been identified.

For people suffering here are NMU binary packages with the fix applied:

http://www.kernel.org/pub/linux/kernel/people/jejb/hal-0.5.10-3.1.fc8.i386.rpm
http://www.kernel.org/pub/linux/kernel/people/jejb/hal-libs-0.5.10-3.1.fc8.i386.rpm

And the SRPM whence they came:

http://www.kernel.org/pub/linux/kernel/people/jejb/hal-0.5.10-3.1.fc8.src.rpm

Hopefully, at version 3.1 these are above the current RH version but below the next one they will release (hence equivalent to debian NMU packages) so you can apply them and still pull in the official fix if Red Hat gets around to releasing it.
Comment 15 Mace Moneta 2008-08-13 13:23:23 EDT
Thanks James Bottomley, I've just backleveled and excluded hal* from update on all systems until a fix is released.  I had almost forgotten about this issue.
Comment 16 Adam Pribyl 2008-09-08 04:51:24 EDT
*** Bug 454946 has been marked as a duplicate of this bug. ***
Comment 17 Adam Pribyl 2008-09-08 07:58:51 EDT
*** Bug 455577 has been marked as a duplicate of this bug. ***
Comment 18 Adam Pribyl 2008-09-08 08:01:47 EDT
David, could you apply this fix also to F8 version or is there anything that prevents that?
Comment 19 Mace Moneta 2008-09-12 04:04:39 EDT
Same problem with the update that just went out: 

hal-0.5.10-4.fc8
hal-libs-0.5.10-4.fc8

It works with the updates from comment #14.
Comment 20 Ricardo Berlasso 2008-09-14 05:52:32 EDT
Yesterday (September the 13th) there was a new hal update, but it comes with the old problem and I needed to force the install of the old hal-info again.
I totally agree with the opening phrase of comment #14.
Comment 21 Mace Moneta 2008-09-16 19:06:15 EDT
Since this has been open for nearly three months, with an easyfix (upstream patch) status, a high severity, and there has been no comment from the assigned maintainer, do we need to kick in the non-responsive/AWOL maintainer process?  Is there some other issue that we need to be aware of in response to this problem, that precludes application of the upstream patch?
Comment 22 Kevin R. Page 2008-09-17 09:36:13 EDT
(In reply to comment #21)
> do we need to kick in the non-responsive/AWOL maintainer process? 

It's clear that there has been, and is, active development of hal and associated projects/replacements; and that the Fedora packagers are intricately involved with the upstream projects.

But hal is now a key component of Fedora with wide-reaching effects, and it seems that there is often a delay getting getting fixes and updates out, particularly for existing releases (as opposed to rawhide).

It would probably be more constructive for the hal packager to add co-maintainers, or have a trusted triager/bugmaster (as Matěj Cepl does for the xorg packages). That, of course, needs someone to step up to the plate as a co-maintainer (as does the nuke option of the non-responsive maintainer process). Is that an offer? ;)

(I was personally frustrated by bug #280251 having a fix but being in kept in limbo for nigh on 6 months awaiting hal bugs; also bug #244995 with patch but unreleased for 12 months, bug #435093 with patch but unreleased for 4 months, bug #431377 open 7 months with patch for 2 months but still unfixed AFAIK. So I agree there is a bit of a problem here).
Comment 23 Fedora Update System 2008-09-24 16:24:00 EDT
hal-0.5.10-5.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/hal-0.5.10-5.fc8
Comment 24 Mace Moneta 2008-09-24 16:55:29 EDT
Confirming that this bug is corrected on my Toshiba laptop (the problem was not limited to Fujitsu machines) with hal-0.5.10-5.fc8 and hal-libs-0.5.10-5.fc8.
Comment 25 Fedora Update System 2008-09-28 14:41:02 EDT
hal-0.5.10-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8433
Comment 26 Fedora Update System 2008-10-09 17:29:47 EDT
hal-0.5.10-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.