Bug 453120 - perl-openbabel not built for perl 5.10.0
perl-openbabel not built for perl 5.10.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openbabel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-06-27 08:47 EDT by Paul Howarth
Modified: 2008-07-29 17:50 EDT (History)
0 users

See Also:
Fixed In Version: 2.2.0-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-29 17:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add perl(:MODULE_COMPAT... dependency and fix some rpmlint warnings (1.79 KB, patch)
2008-06-27 08:47 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Paul Howarth 2008-06-27 08:47:30 EDT
The F-9 package of perl-openbabel has modules in "perl 5.8.8" paths,
which are not found by F-9's perl 5.10.0. The package therefore needs rebuilding
for perl 5.10.0.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0.
Comment 1 Paul Howarth 2008-06-27 08:47:30 EDT
Created attachment 310433 [details]
Patch to add perl(:MODULE_COMPAT... dependency and fix some rpmlint warnings
Comment 2 Dominik 'Rathann' Mierzejewski 2008-07-06 08:43:49 EDT
This patch does more than that. I'll add the missing perl requires, but please
explain the rest of the hunks.
Comment 3 Paul Howarth 2008-07-06 10:22:47 EDT
(In reply to comment #2)
> This patch does more than that. I'll add the missing perl requires, but please
> explain the rest of the hunks.

>>>>
-Provides: %{name}-perl
+Provides: %{name}-perl = %{version}-%{release}

-Provides: %{name}-python
+Provides: %{name}-python = %{version}-%{release}
<<<<

These make the "Provides" versioned; unversioned "provides" are bad because they
effectively mean that the package "provides" every possible version, and that
would cause problems for people doing upgrades if it was ever decided to change
the package names back to (for example) "openbabel-perl" again.

>>>>
+# Fix bogus executable permissions on source files for debuginfo
+%{__chmod} -x src/formats/{fchk,mmcif}format.cpp
+
<<<<

These source files have the execute bits set, which causes rpmlint to complain
when run on the "openbabel-debuginfo" package.

>>>>
-perl Makefile.PL INSTALLDIRS="vendor"
+%{__perl} Makefile.PL INSTALLDIRS="vendor"

-python setup.py build
+%{__python} setup.py build
<<<<

These are for consistency; the spec uses macro-ized versions of commands in most
places, so this changes the perl and python commands to the macro-ized versions too.

>>>>
-%{python_sitearch}/_openbabel.so
+%attr(755,root,root) %{python_sitearch}/_openbabel.so
<<<<

This just forces the permissions of the _openbabel.so to be 755; otherwise it
would be 775, which rpmlint considers to be "strange".
Comment 4 Fedora Update System 2008-07-06 18:06:37 EDT
openbabel-2.2.0-1.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-07-15 08:20:37 EDT
openbabel-2.2.0-1.fc9, kdeedu-4.0.5-2.fc9, gnome-chemistry-utils-0.8.7-2.fc9, gchempaint-0.8.7-3.fc9, xdrawchem-1.9.9-11.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openbabel kdeedu gnome-chemistry-utils gchempaint xdrawchem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6376
Comment 6 Dominik 'Rathann' Mierzejewski 2008-07-29 17:50:58 EDT
For some reason bodhi didn't close this after it hit stable.

Note You need to log in before you can comment on or make changes to this bug.