Bug 453266 - Bump boost libraries to 1.37
Bump boost libraries to 1.37
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Benjamin Kosnik
Fedora Extras Quality Assurance
http://www.boost.org/
: FutureFeature, Reopened
: 475463 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-28 12:30 EDT by Lorenzo Villani
Modified: 2013-08-09 01:48 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 04:38:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lorenzo Villani 2008-06-28 12:30:27 EDT
Description of problem:
Can you please bump boost to version 1.35? (released on March 29th)
Comment 1 Petr Machata 2008-06-30 04:24:31 EDT
Benjamin, do you know of a reason not to rebase, or shall I go ahead and do it?
Comment 2 Lorenzo Villani 2008-07-10 09:58:12 EDT
Any progress on that? I need boost 1.35 for development purposes, I'm doing a
local rebase of the RPM but I'd better wait for official packages.
Comment 3 Petr Machata 2008-07-10 11:14:15 EDT
Looking into spec, boost has a long history of keeping up with latest greatest,
so I guess there's no harm doing the rebase (in rawhide).  I'll proceed soonish.
Comment 4 Benjamin Kosnik 2008-07-17 14:28:59 EDT
I had thought that I'd put in a reference to
https://bugzilla.redhat.com/show_bug.cgi?id=449157

here, but I guess not. That thread is kind of confused: let's keep this one
about updating the fedora boost package to something more recent that 1.34.1.

So, like that thread, I'm gunning for a rebase 1.36.0 at the end of July 2008,
and skipping 1.35.0 entirely. 

Petr, if you want to rebase to the boost release branch and tag as 1.36.0-0.1 or
whatever, I'd be all for that. Then we could just update SVN and go to 1.36.0-1
when it is officially released. That is pretty much what I was doing for the
1.34.1 rebase.

-benjamin

Comment 5 Lorenzo Villani 2008-08-28 06:52:51 EDT
Boost 1.36-beta1 is in rawhide. I'm closing this bug.

PS: Boost 1.36 final was released a couple of week ago.
Comment 6 Petr Machata 2008-08-28 12:06:59 EDT
Unfortunately I've gotten around to update boost too late in the release cycle, and had to untag it shortly after the build.  You probably managed to sync rawhide in the meantime.

$ koji latest-pkg f10-alpha boost
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
boost-1.34.1-16.fc10                      f10-alpha             pmachata

I'll reopen the bug, and will resolve it in f11.  Sorry about that.
Comment 7 Lorenzo Villani 2008-11-12 09:53:11 EST
No problem, btw boost 1.37 is out ;-)
Comment 8 Ling Li 2008-11-21 22:52:57 EST
Do you know whether there is a package for Boost.Build and/or Boost.Jam (bjam)?
Comment 9 Ed Hill 2008-12-01 23:31:33 EST
Its a shame that Boost 1.36.0 did not make it into F10 because there are 
some very real problems with GCC 4.3.x and Boost versions earlier than 
1.36.0 such as:

  https://svn.boost.org/trac/boost/ticket/1857

Is there any chance that a Boost update could appear for F10 or are we 
stuck waiting for F11?
Comment 10 john5342 2008-12-19 20:59:18 EST
*** Bug 475463 has been marked as a duplicate of this bug. ***
Comment 11 Juan 2009-01-12 00:50:47 EST
I'm also needing urgently an update to boost 1.37.
I don't know the details on how Fedora planifies updates, but it'd be really nice if there could be an update for boost.
When is F11 planified to be released?
Comment 12 Petr Machata 2009-01-12 04:38:36 EST
(In reply to comment #9)
> Is there any chance that a Boost update could appear for F10 or are we 
> stuck waiting for F11?

Unfortunately, no.  Boost rebase is quite an invasive operation, because new boost is potentially both API and ABI incompatible with the old one.  It needs to be synchronized with clients, who always need to be rebuilt, and often ported.  It's a lot of work, and we would inevitably end up breaking parts of the distro.

(In reply to comment #11)
> I'm also needing urgently an update to boost 1.37.
> I don't know the details on how Fedora planifies updates, but it'd be really
> nice if there could be an update for boost.
> When is F11 planified to be released?

According to the schedule:
  https://fedoraproject.org/wiki/Releases/11/Schedule
F11 alpha should be out 2009-02-03.  This release will already have boost 1.37.  Final should be out 2009-05-26.

Also note that boost 1.37 is already in rawhide, even though a couple clients failed to rebuild (failures that were due to boost were fixed right away, so these clients that were left behind were failing for non-boost reasons; some of these might even be fixed by now).  So I'm closing this bug RAWHIDE.
Comment 13 Edwin ten Brink 2009-02-18 06:31:31 EST
(In reply to comment #12)

The release notes for Boost 1.38.0 which is out since Feb 8th, quite a number of serious bugfixes in several libraries are listed: http://www.boost.org/users/news/version_1_38_0

Wouldn't it be wise to rebase to 1.38.0 for F11 instead of 1.37.0 to avoid potential problems caused by these bugs?

Note You need to log in before you can comment on or make changes to this bug.