Bug 453300 - GVFSD-GPhoto2 segfaults on connecting Canon PowerShot Camera
GVFSD-GPhoto2 segfaults on connecting Canon PowerShot Camera
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-29 05:13 EDT by Gerard Fernandes
Modified: 2013-07-02 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 05:52:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message (12.55 KB, image/png)
2008-06-29 05:13 EDT, Gerard Fernandes
no flags Details

  None (edit)
Description Gerard Fernandes 2008-06-29 05:13:43 EDT
Description of problem: On connecting a Canon Powershot A700, get a DBUS timeout
error saying it's unable to mount the camera. Looking in the logs, I see:

Jun 29 10:03:30 achiles kernel: usb 1-6: new high speed USB device using
ehci_hcd and address 4
Jun 29 10:03:30 achiles kernel: usb 1-6: configuration #1 chosen from 1 choice
Jun 29 10:03:30 achiles kernel: usb 1-6: New USB device found, idVendor=04a9,
idProduct=3117
Jun 29 10:03:30 achiles kernel: usb 1-6: New USB device strings: Mfr=1,
Product=2, SerialNumber=0
Jun 29 10:03:30 achiles kernel: usb 1-6: Product: Canon Digital Camera
Jun 29 10:03:30 achiles kernel: usb 1-6: Manufacturer: Canon Inc.
Jun 29 10:03:36 achiles kernel: gvfsd-gphoto2[3364]: segfault at c ip 00a8d7a0
sp bf8211fc error 4 in libpthread-2.8.so[a86000+15000]
Jun 29 10:03:44 achiles kernel: gvfsd-gphoto2[3380]: segfault at c ip 00a8d7a0
sp bfab72fc error 4 in libpthread-2.8.so[a86000+15000]


Version-Release number of selected component (if applicable): gphoto v2.4.0
release: 10.fc9
 

How reproducible: Always


Steps to Reproduce:
1. Connect camera via USB

  
Actual results:
DBUS timeout error - unable to mount (see attached image)

Expected results:
Should mount camera and launch the image viewer application to download images
to the computer.


Additional info:
Comment 1 Gerard Fernandes 2008-06-29 05:13:43 EDT
Created attachment 310531 [details]
error message
Comment 2 Jochen Wiedmann 2008-07-14 14:26:54 EDT
Possibly a duplicate of bug 445041
Comment 3 Gerard Fernandes 2008-10-23 05:49:04 EDT
Please close - doesn't occur anymore since the last few updates.
Comment 4 Jindrich Novy 2008-10-23 05:52:53 EDT
Ok, thanks for noticing.

Note You need to log in before you can comment on or make changes to this bug.