Bug 453513 - xmlcatalog DocBook 4.4 & 4.5 references are wrong
xmlcatalog DocBook 4.4 & 4.5 references are wrong
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-01 02:20 EDT by Jeff Fearn
Modified: 2008-07-15 08:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.0-33.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 08:20:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2008-07-01 02:20:55 EDT
Description of problem:
The DocBook 4.4 entries in /usr/share/sgml/docbook/xmlcatalog points to the
DocBook 4.5 files, and the 4.5 entries are missing.

This causes the 4.5 DTD to be fetched from the net for net enabled programs and
causes programs with net access disabled (e.g. yelp) to die.

This also means that 4.4 validation is incorrect.

Version-Release number of selected component (if applicable):
xml-common-0.6.3-23.fc9.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Make a DocBook file
2. Set the DTD to 4.5
3. run xmllint over the file
  
Actual results:
The 4.5 DTD gets pulled from the web.

Expected results:
The local 4.5 DTD should be used.

Additional info:
This makes it extremely frustrating to build DocBook 4.5 documentation on
Fedora. The DTD doesn't get cached so further builds re-fetch the DTD :(

This bug probably affects F8 which also shipped with the DocBook 4.5 DTD.
Comment 1 Alex Lancaster 2008-07-10 20:52:25 EDT
I see something similar but with DocBook 4.2 DTDs (bug #454952) i.e. resolution
doesn't work and it attempts to pull from the net could this be related?
Comment 2 Ondrej Vasik 2008-07-11 04:02:22 EDT
*** Bug 454952 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Vasik 2008-07-11 04:21:48 EDT
Thanks for report. It is not problem of docbook-dtds and it is not affecting
F-8. Problem is in recent update of sgml-common (in fact xml-common) package. As
was requested in bug #453271 I marked catalogs/etc/xml/catalog and
/usr/share/sgml/docbook/xmlcatalog from xml-common package as verify(not md5
size mtime). This showed old buggy behaviour of xml-common - each update of
/usr/share/sgml/docbook/xmlcatalog file causes replacing old full xmlcatalog
file filled by Docbook DTDs locations with completely empty one. As this file is
filled by post of docbook-dtds subpackage, yum reinstall docbook-dtds solves the
issue. I fixed the issue in rawhide, so it should not happen once more time in
future (now symlinked and marked config(noreplace)), but making update of
xml-common to fix that will break everything once more time. Sorry for troubles,
closing DEFERRED because it is fixed in RAWHIDE but fix for F9 will cause
additional troubles. Please use yum reinstall docbook-dtds as workaround in F9.
I'm quiet sure that docbook 4.5 entries exists and should work properly.
Comment 4 Ondrej Vasik 2008-07-11 06:07:53 EDT
Sorry, got confused by the previous(and several rawhide reports) - this one
issue is obviously caused by typo in docbook-dtds scriplet. Will do an
docbook-dtds update which should fix both issues.
Comment 5 Fedora Update System 2008-07-11 07:02:32 EDT
docbook-dtds-1.0-33.fc8 has been submitted as an update for Fedora 8
Comment 6 Ondrej Vasik 2008-07-14 10:50:03 EDT
Changing component as previously looked as different bug caused by xml-common
subpackage. Original issue comes from docbook-dtds.
Comment 7 Fedora Update System 2008-07-15 08:20:00 EDT
docbook-dtds-1.0-33.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.