Bug 454952 - xmlcatalog can't find DTD for -//OASIS//DTD DocBook XML V4.2//EN using /etc/xml/catalog
xmlcatalog can't find DTD for -//OASIS//DTD DocBook XML V4.2//EN using /etc/x...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-10 20:45 EDT by Alex Lancaster
Modified: 2008-07-15 08:18 EDT (History)
0 users

See Also:
Fixed In Version: 1.0-37.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 08:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-07-10 20:45:23 EDT
Description of problem:
DTD can't be found for -//OASIS//DTD DocBook XML V4.2//EN using
/etc/xml/catalog, but can be found if pointing to /etc/sgml/catalog.

Version-Release number of selected component (if applicable):
docbook-dtds-1.0-35.fc9.noarch

How reproducible:
Always

Steps to Reproduce:
1. xmlcatalog /etc/xml/catalog "-//OASIS//DTD DocBook XML V4.2//EN"
2. xmlcatalog /etc/sgml/catalog "-//OASIS//DTD DocBook XML V4.2//EN"

  
Actual results:
$ xmlcatalog /etc/sgml/catalog "-//OASIS//DTD DocBook XML V4.2//EN" 
/usr/share/sgml/docbook/xml-dtd-4.2-1.0-35.fc9/docbookx.dtd

$ xmlcatalog /etc/xml/catalog "-//OASIS//DTD DocBook XML V4.2//EN" 
No entry for PUBLIC -//OASIS//DTD DocBook XML V4.2//EN

Expected results:
After step 2 using the /etc/xml/catalog file, it should find the DTD in the same
location as for the /etc/sgml/catalog file

Additional info:
This d
Comment 1 Alex Lancaster 2008-07-10 20:51:35 EDT
This may be related to bug #453513.
Comment 2 Alex Lancaster 2008-07-10 20:53:36 EDT
The effect of this lack of DTD resolution is that it attempts to download the
DTDs via the web when running xsltproc or dblatex, which is why I thought it
might be related to bug #453513.
Comment 3 Alex Lancaster 2008-07-10 21:00:11 EDT
Digging deeper, I see that

/etc/xml/catalog contains this:

<?xml version="1.0"?>
<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN"
"http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd">
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
  <delegatePublic publicIdStartString="-//OASIS//ENTITIES DocBook XML"
catalog="file:///usr/share/sgml/docbook/xmlcatalog"/>
  <delegatePublic publicIdStartString="-//OASIS//DTD DocBook XML"
catalog="file:///usr/share/sgml/docbook/xmlcatalog"/>
....
</catalog>

so it tells xmlcatalog to look for the DocBook DTDs in
/usr/share/sgml/docbook/xmlcatalog but here are the contents:

<?xml version="1.0"?>
<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN"
"http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd">
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog"/>

the file doesn't appear to contain any further information to allow xmlcatalog
to resolve the DTD location.  Did this get corrupted somehow?
Comment 4 Alex Lancaster 2008-07-10 21:07:20 EDT
OK, so a reinstallation of docbook-dtds fixed it apparently because it re-ran
the postinstall scriptlet which has all the logic to fill up
/usr/share/sgml/docbook/xmlcatalog.  

But I still don't know what was the underlying cause for this. Ff bug #453513 is
anything to go by, it may be affect more than just me. 
Comment 5 Ondrej Vasik 2008-07-11 04:02:21 EDT
Thanks for report. Yep, it's related and unfortunately no way to fix it without
breaking those catalogs once more time, will comment that in the duplicate
bugzilla preceeding that one report, closing that as duplicate of bug #453513.

*** This bug has been marked as a duplicate of 453513 ***
Comment 6 Alex Lancaster 2008-07-11 04:13:08 EDT
(In reply to comment #5)
> Thanks for report. Yep, it's related and unfortunately no way to fix it without
> breaking those catalogs once more time

Why can't this be fixed? What caused the original breakage?  Will a freshly
installed + recent upgrades box have this problem?
Comment 7 Ondrej Vasik 2008-07-11 04:32:29 EDT
I'm afraid it will. It can't be fixed simply because the rawhide fix only
prevents occurance of that behaviour in future. Design of usage in xml-common
/usr/share/sgml/docbook/xmlcatalog is bad from the beginning, as every time you
change something in that file, it will replace all registered catalogs. I will
try to find out a solution which will not break install+update boxes. This is
quiet unfortune situation as only because of cosmetic issue with rpm -V
xml-common complaints all the Docbook-dtds things got broken. Simpliest solution
might be to untag xml-common-0.6.24.fc9 from dist-f9. Another way could be to
make an update of docbook-dtds, which will require xml-common >= 0.6.24.fc9 -
which will make install+update solution working once more time. I do prefer the
second one with docbook-dtds update.
Comment 8 Fedora Update System 2008-07-11 06:55:37 EDT
docbook-dtds-1.0-37.fc9 has been submitted as an update for Fedora 9
Comment 9 Ondrej Vasik 2008-07-11 13:15:59 EDT
It turned out that the bug described in #453513 was slightly different.
Therefore removing duplicate and marking closed current release. Sorry for
troubles, xml-common catalog issue should be solved by this docbook-dtds update.
Comment 10 Alex Lancaster 2008-07-12 21:27:12 EDT
Downloaded the koji build manually. This seems to fix the empty missing entries
in /usr/share/sgml/docbook/xmlcatalog problem! Thanks!
Comment 11 Alex Lancaster 2008-07-12 21:27:57 EDT
Re-opening bug as bodhi should close this bug automatically once pushed to stable.
Comment 12 Fedora Update System 2008-07-15 08:17:59 EDT
docbook-dtds-1.0-37.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.