Bug 453759 - ocaml-cil-cilly not built for perl 5.10.0
ocaml-cil-cilly not built for perl 5.10.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ocaml-cil (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-07-02 08:54 EDT by Paul Howarth
Modified: 2008-07-30 16:11 EDT (History)
0 users

See Also:
Fixed In Version: 1.3.6-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add perl(:MODULE_COMPAT...) dependency and relocate perl modules to standard perl vendor library directory (1.71 KB, patch)
2008-07-02 08:54 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Paul Howarth 2008-07-02 08:54:21 EDT
The F-9 package of ocaml-cil-cilly has modules in "perl 5.8.8" paths,
which are not found by F-9's perl 5.10.0. The package therefore needs rebuilding
for perl 5.10.0.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0.
Comment 1 Paul Howarth 2008-07-02 08:54:21 EDT
Created attachment 310784 [details]
Patch to add perl(:MODULE_COMPAT...) dependency and relocate perl modules to standard perl vendor library directory
Comment 2 Richard W.M. Jones 2008-07-07 06:53:33 EDT
Built for F-9:
http://koji.fedoraproject.org/koji/taskinfo?taskID=699691
Comment 3 Fedora Update System 2008-07-07 06:56:58 EDT
ocaml-cil-1.3.6-5.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-07-08 22:49:41 EDT
ocaml-cil-1.3.6-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ocaml-cil'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6224
Comment 5 Fedora Update System 2008-07-30 16:11:25 EDT
ocaml-cil-1.3.6-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.