This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 453865 - Review Request: globus-proxy-utils - Globus Toolkit - Globus GSI Proxy Utility Programs
Review Request: globus-proxy-utils - Globus Toolkit - Globus GSI Proxy Utilit...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On: gpt 453848 453850 453851 453853 453854 453855 453856 453857 453858 453861 453862 467239
Blocks: globus
  Show dependency treegraph
 
Reported: 2008-07-02 18:40 EDT by Mattias Ellert
Modified: 2009-05-25 17:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.5-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 17:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
oget.fedora: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2008-07-02 18:40:15 EDT
Spec URL: http://www.grid.tsl.uu.se/repos/globus/fedora/9/info/globus-proxy-utils.spec
SRPM URL: http://www.grid.tsl.uu.se/repos/globus/fedora/9/src/SRPMS/globus-proxy-utils-0.18-0.1.fc9.src.rpm
Description :
The Globus Toolkit is an open source software toolkit used for
building Grid systems and applications. It is being developed by the
Globus Alliance and many others all over the world. A growing number
of projects and companies are using the Globus Toolkit to unlock the
potential of grids for their cause.

The globus-proxy-utils package contains:
Globus GSI Proxy Utility Programs

BuildRequires:  gpt
BuildRequires:  libtool
BuildRequires:  globus-gsi-proxy-ssl-devel >= 1
BuildRequires:  globus-gsi-credential-devel >= 1
BuildRequires:  globus-gsi-callback-devel >= 0
BuildRequires:  globus-openssl-module-devel >= 0
BuildRequires:  globus-gsi-openssl-error-devel >= 0
BuildRequires:  globus-openssl-devel >= 1
BuildRequires:  globus-gsi-proxy-core-devel >= 1
BuildRequires:  globus-core-devel >= 4
BuildRequires:  globus-gsi-cert-utils-devel >= 1
BuildRequires:  globus-common-devel >= 3
BuildRequires:  globus-gsi-sysconfig-devel >= 1
Comment 1 Mattias Ellert 2008-10-16 10:35:09 EDT
New version based on the globus toolkit 4.2.1 release:

SRPM: http://www.grid.tsl.uu.se/repos/globus/fedora/9/src/SRPMS/globus-proxy-utils-2.5-0.2.fc9.src.rpm
SPEC: http://www.grid.tsl.uu.se/repos/globus/fedora/9/info/globus-proxy-utils.spec

The new version has one additional build requirement:

BuildRequires:	globus-gss-assist-devel >= 3

So I needed to add a request for this package (#467239) in order to update this request to the latest version.
Comment 2 Mattias Ellert 2009-01-05 19:50:54 EST
This package was updated due to the renaming of the GPT package.

SRPM: http://www.grid.tsl.uu.se/repos/globus/fedora/10/src/SRPMS/globus-proxy-utils-2.5-0.3.fc10.src.rpm

SPEC: http://www.grid.tsl.uu.se/repos/globus/info/globus-proxy-utils.spec
Comment 3 Mattias Ellert 2009-03-15 20:00:46 EDT
New version
- Added s390x as 64 bit arch
- Added comment documenting source
- Adapt to changes in the globus-core package

http://www.grid.tsl.uu.se/repos/globus/fedora/10/src/SRPMS/globus-proxy-utils-2.5-0.5.fc10.src.rpm
http://www.grid.tsl.uu.se/repos/globus/info/globus-proxy-utils.spec
Comment 4 Mattias Ellert 2009-04-17 09:44:44 EDT
Package updated due to new packaging guidelines
- Change defines to globals
- Remove explicit requires on library packages

http://www.grid.tsl.uu.se/repos/globus/info/new/globus-proxy-utils-2.5-1.fc10.src.rpm
http://www.grid.tsl.uu.se/repos/globus/info/new/globus-proxy-utils.spec

Draft packaging guidelines for Globus packages are now available:
http://fedoraproject.org/wiki/PackagingDrafts/Globus
Comment 5 Orcan Ogetbil 2009-05-21 19:56:27 EDT
This one is also good out of the box.

- koji rawhide build is fine:
   http://koji.fedoraproject.org/koji/taskinfo?taskID=1369405

- rpmlint is silent.

-----------------------------------------------------
This package (globus-proxy-utils) is APPROVED by oget
-----------------------------------------------------
Comment 6 Mattias Ellert 2009-05-22 00:23:55 EDT
Thank you for the review.


New Package CVS Request
=======================
Package Name: globus-proxy-utils
Short Description: Globus Toolkit - Globus GSI Proxy Utility Programs
Owners: ellert
Branches: F-9 F-10 F-11 EL-4 EL-5
InitialCC:
Comment 7 Kevin Fenzi 2009-05-23 01:29:32 EDT
cvs done.
Comment 8 Fedora Update System 2009-05-23 05:26:16 EDT
globus-proxy-utils-2.5-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/globus-proxy-utils-2.5-1.fc10
Comment 9 Fedora Update System 2009-05-23 05:26:21 EDT
globus-proxy-utils-2.5-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/globus-proxy-utils-2.5-1.fc11
Comment 10 Fedora Update System 2009-05-23 05:26:26 EDT
globus-proxy-utils-2.5-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/globus-proxy-utils-2.5-1.fc9
Comment 11 Fedora Update System 2009-05-25 17:08:53 EDT
globus-proxy-utils-2.5-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-05-25 17:21:40 EDT
globus-proxy-utils-2.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-05-25 17:23:38 EDT
globus-proxy-utils-2.5-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.