Bug 453925 - mapserver-perl package should have perl(:MODULE_COMPAT...) dependency
mapserver-perl package should have perl(:MODULE_COMPAT...) dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mapserver (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-07-03 05:23 EDT by Paul Howarth
Modified: 2008-07-07 06:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0.3-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 02:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2008-07-03 05:23:26 EDT
The original F-9 package of mapserver-perl had modules in "perl 5.8.8" paths,
which were not found by F-9's perl 5.10.0. The 5.0.3-1.fc9 update was built
against perl 5.10.0, which resolved the immediate problem.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0. Any package that includes perl modules in the
%{perl_vendorlib} or %{perl_vendorarch} directories (which are versioned by perl
version number) should have the following "Requires" tag added so that such
dependencies are properly flagged in future:

Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Comment 1 Fedora Update System 2008-07-05 08:17:31 EDT
mapserver-5.0.3-3.fc9 has been submitted as an update for Fedora 9
Comment 2 Fedora Update System 2008-07-06 02:15:15 EDT
mapserver-5.0.3-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.