Bug 453932 - libprelude-perl should have perl(:MODULE_COMPAT...) dependency
libprelude-perl should have perl(:MODULE_COMPAT...) dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libprelude (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-07-03 07:04 EDT by Paul Howarth
Modified: 2008-07-15 08:19 EDT (History)
0 users

See Also:
Fixed In Version: 0.9.17.2-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 08:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add perl(:MODULE_COMPAT...) dependency and fix a few rpmlint complaints (2.41 KB, patch)
2008-07-03 07:04 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Paul Howarth 2008-07-03 07:04:43 EDT
The original F-9 package of libprelude-perl had modules in "perl 5.8.8" paths,
which were not found by F-9's perl 5.10.0. The 0.9.17.1-1.fc9 update was built
against perl 5.10.0, which resolved the immediate problem.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0. Any package that includes perl modules in the
%{perl_vendorlib} or %{perl_vendorarch} directories (which are versioned by perl
version number) should have the following "Requires" tag added so that such
dependencies are properly flagged in future:

Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Comment 1 Paul Howarth 2008-07-03 07:04:43 EDT
Created attachment 310909 [details]
Patch to add perl(:MODULE_COMPAT...) dependency and fix a few rpmlint complaints
Comment 2 Paul Howarth 2008-07-04 11:43:04 EDT
Slight typo in the patch from Comment #1:

%{_lib} should read: /%{_lib}
Comment 3 Steve Grubb 2008-07-04 13:03:51 EDT
Thanks for the patch. libprelude-0.9.17.2-1 was built to solve this issue.
Comment 4 Fedora Update System 2008-07-04 13:06:38 EDT
libprelude-0.9.17.2-1.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-07-06 02:16:04 EDT
libprelude-0.9.17.2-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libprelude'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6144
Comment 6 Fedora Update System 2008-07-15 08:19:33 EDT
libprelude-0.9.17.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.