Bug 453985 - NetworkManager notification icon does not show up when user switching
NetworkManager notification icon does not show up when user switching
Status: CLOSED DUPLICATE of bug 456046
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-03 13:12 EDT by Dag
Modified: 2009-01-21 19:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 19:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag 2008-07-03 13:12:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
NetworkManager notification icon is not visible as if NetworkManager was not running when having used the "user change tool" (you can open 2 sessions with 2 different users).
I opened a session as a user, I could see the NetworkManager icon, then used the "user change tool" to log in as well as another user.
The Icon was not present in the notification area of the second user.
Then I closed the first user session to use the second user session only: there was no more NetworkManager icon even after a NetworkManager restart.

only a reboot could resolve this.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1. check you have NetworkManager enabled
2. open a first Gnome session as an user: the NetworkManager icon is present
3. open a second Gnome session as a second user via the user swtiching tool: the icon is not present in the notification area
4. go back to the first session without closing the second
5. close the first session and go back to the second session
6. there is still no NM icon, even if you restart the NM service

Actual Results:
there is no NM icon in the notification area of the other opened sessions.
Only the first opened session got the NM icon.
if you close that session no other session has the icon.

Expected Results:
at least one opened session must have the icon to be able to control the network connections.

Additional info:
Comment 1 Milan Bouchet-Valat 2008-12-29 12:17:01 EST
This is a duplicate of bug 456046.
Comment 2 Martin Ebourne 2009-01-21 19:04:10 EST

*** This bug has been marked as a duplicate of bug 456046 ***

Note You need to log in before you can comment on or make changes to this bug.