Bug 456046 - NetworkManager applet doesn't work with fast user switching
NetworkManager applet doesn't work with fast user switching
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Triaged
: 372171 453985 460843 490850 508294 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-21 04:10 EDT by Avi Kivity
Modified: 2011-04-22 11:29 EDT (History)
29 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-19 17:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 284596 None None None Never

  None (edit)
Description Avi Kivity 2008-07-21 04:10:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
When multiple users are logged in, the NetworkManager applet will only work for one of them.  If one of the other users need to interact with NetworkManager, they are screwed.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.4.svn3675.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Boot system
2. Log in, nm-applet loads and connects automatically
3. Log in as another user, keeping previous user logged in
4. Look in vain for the applet.  Starting nm-applet from the command line won't work.

Actual Results:
No NetworkManager applet.

Expected Results:
NetworkManager applet in all its glory.

Additional info:
Comment 1 Andre Robatino 2008-07-22 16:33:24 EDT
This might be related to bug #449976 concerning the inability to set whether the
NetworkManager applet appears on a per-user basis.
Comment 2 Alexey Kuznetsov 2008-09-08 11:07:45 EDT
*** Bug 460843 has been marked as a duplicate of this bug. ***
Comment 3 Mitch Davis 2008-10-01 09:46:24 EDT
This bug drives me crazy.  If I leave my computer going, and the screen locks, then someone else (who logs in with their own username) can't control the wireless network.  Dialog boxes pop up in the person who first logged in.  Please please fix!
Comment 4 Mitch Davis 2008-10-19 18:12:23 EDT
Has this bug been fixed for Fedora 10?  Would really really love to see it fixed.
Comment 5 Charles-Henri d'Adhémar 2009-01-10 09:23:05 EST
Hello,

This bug still apply to Fedora 10 unfortunatly.
I also suffer from this bug ...

Thank you very much for your help !
Comment 6 Mitch Davis 2009-01-10 17:45:22 EST
This one's a royal pain, eh?

I want to tell you about how I have worked around this bug.  It is a workaround, not a fix.

 - Create a script called /usr/local/bin/grab-network

  #! /bin/bash

  sudo killall -1 nm-applet
  sleep 1
  nohup nm-applet < /dev/null > /dev/null 2>&1 &
  sleep 1

 - chmod a+x /usr/local/bin/grab-network

 - Run visudo, and add these lines:

    Cmnd_Alias GRAB_NETWORK = /usr/bin/killall -1 nm-applet

  and

    # Allows people in grab_network group to restart wireless.
    %grab_network ALL = NOPASSWD: GRAB_NETWORK

 - Create a new group in /etc/group called "grab_network".

 - Add users who you want to be able to grab the network, to this group.

 - On the desktop for each of these users, create a launcher to /usr/local/bin/grab-network.

As I said, a workaround, not a fix.
Comment 7 Charles-Henri d'Adhémar 2009-01-11 06:29:22 EST
Hi !

thanks for the workaround.

In fact this bug is not very annoying as long as the user who logged first is still logged. But when this user log out other users cannot use the network any more unless they log out and in again.

Still, should a bug zapper or the maintener mark this bug as belonging to F10 so that it is still valid when F9 will be end of life ? Thanks !

Cheers,
Ch
Comment 8 Magnus Glantz 2009-01-13 08:07:42 EST
This bug may be solved..

I did experience it earlier, but now using:

Fedora 10 on 2.6.27.9-159.fc10.x86_64 #1 SMP

..with..

NetworkManager-0.7.0-1.git20090102.fc10.x86_64
NetworkManager-gnome-0.7.0-1.git20090102.fc10.x86_64
NetworkManager-glib-0.7.0-1.git20090102.fc10.x86_64

I do not longer get this problem. NetworkManager icon appears whatever user I switch to.

Can someone else verify this?
Comment 9 Alexey Kuznetsov 2009-01-13 08:30:11 EST
still persist for x86

[axet@axet-laptop ~]$ rpm -qa|grep Network
NetworkManager-glib-0.7.0-1.git20090102.fc10.i386
NetworkManager-gnome-0.7.0-1.git20090102.fc10.i386
NetworkManager-0.7.0-1.git20090102.fc10.i386
Comment 10 Charles-Henri d'Adhémar 2009-01-13 08:48:52 EST
Same for me on x86 it still persists with the latest NetworkManager packages
Comment 11 Magnus Glantz 2009-01-13 11:31:02 EST
I thought perhaps me running Compiz-Fusion was the thing.. not sure if that was correct..

I turned off Compiz-Fusion (via the Desktop Effects control in the System menu) and the problem did returned.. though, once I turn on Desktop Effects again.. the problem stayed.

So now I again have the same problem. I can not reproduce this, even after reboot. I keep getting the missing NetworkManager icon all the time now.

My "Compiz Fusion" installation includes

compiz-fusion-extras-gnome-0.7.8-2.fc10.x86_64
compiz-0.7.8-4.fc10.x86_64
compiz-fusion-gnome-0.7.8-2.fc10.x86_64
compiz-fusion-0.7.8-2.fc10.x86_64
compiz-gnome-0.7.8-4.fc10.x86_64
libcompizconfig-0.7.8-1.fc10.x86_64
compizconfig-python-0.7.8-1.fc10.x86_64
compiz-fusion-extras-0.7.8-2.fc10.x86_64

ccsm-0.7.8-1.fc10.noarch

emerald-0.7.6-2.fc10.x86_64
emerald-themes-0.5.2-2.fc8.noarch

When I didn't have the problem I got a notification about connected established to my Wireless network.
Comment 12 Martin Ebourne 2009-01-21 19:04:10 EST
*** Bug 453985 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2009-02-04 19:06:51 EST
*** Bug 372171 has been marked as a duplicate of this bug. ***
Comment 14 Dan Williams 2009-03-23 17:52:22 EDT
*** Bug 490850 has been marked as a duplicate of this bug. ***
Comment 15 Niels Haase 2009-04-09 16:11:09 EDT
same in rawhide with:

NetworkManager-glib-0.7.0.100-1.fc11.x86_64
NetworkManager-gnome-0.7.0.100-1.fc11.x86_64
NetworkManager-0.7.0.100-1.fc11.x86_64

try to run nm-applet while another user is logged in result in:

** (nm-applet:5442): WARNING **: <WARN>  applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken.  Return: 3

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Sebastian Krämer 2009-06-19 11:39:56 EDT
(In reply to comment #15)
> same in rawhide with:
> 
> NetworkManager-glib-0.7.0.100-1.fc11.x86_64
> NetworkManager-gnome-0.7.0.100-1.fc11.x86_64
> NetworkManager-0.7.0.100-1.fc11.x86_64
> 
> try to run nm-applet while another user is logged in result in:
> 
> ** (nm-applet:5442): WARNING **: <WARN>  applet_dbus_manager_start_service():
> Could not acquire the NetworkManagerUserSettings service as it is already
> taken.  Return: 3

Maybe it's another bug but I too get this error message (only single user, no locked screen etc) whenever I want to start nm-applet.

I'm running f11 (fresh install) and version NM 0.7.1-4.git20090414.fc11. In f10, everything was fine.
Comment 17 Christian Nolte 2009-06-23 03:56:27 EDT
A remark regarding authorization: 

If a connection has been made and the user chooses to fast-user-switch to another account, this other account should not be able to tamper with already established connections, only if he has the appropriate rights to do so (via policykit).
Comment 18 Tomasz Sałaciński 2009-06-26 10:37:15 EDT
*** Bug 508294 has been marked as a duplicate of this bug. ***
Comment 19 Andre Robatino 2009-09-28 23:12:11 EDT
Bug #508294 was reported against F11, so this bug should have its Version bumped to 11 (certainly before F10 goes EOL).
Comment 20 Martin Ebourne 2009-09-29 03:12:55 EDT
I see this in F11 too.
Comment 21 Alexey Kuznetsov 2009-09-29 04:26:51 EDT
f12 - the same
Comment 22 Need Real Name 2009-10-25 10:06:03 EDT
Definitely still in F11. I did something similar to comment #5 some months ago but forgot to check for the existence of the bug.  It is absolutely related to fast user switch, specifically the nm-applet can only be executed once, but must be owned by the currently active user.
Comment 24 Bug Zapper 2009-11-16 03:09:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 25 Martin Ebourne 2010-03-21 22:33:19 EDT
This is still broken in F13 alpha, and has been forever.

Running from the command line for the second user gets:
% nm-applet
An instance of nm-applet is already running.
%

Of course the other instance is for the first user so no help at all.

Is there any plan to address this since it's a gaping hole in fast-user-switching support (which otherwise works excellently these days)?
Comment 26 JD 2010-06-06 16:48:31 EDT
Still broken in F13 release, any updates?
Comment 27 Jirka Klimes 2010-06-07 07:35:09 EDT
The feature is not implemented yet.
Nevertheless, the subject is currently being discussed on the networkmanager-list:
http://markmail.org/message/pue7dnf3j3irhqzl
Comment 28 Martin Ebourne 2011-01-27 21:08:50 EST
This is to be addressed in NM 0.9 I think? Hopefully that will be in F15 but as of F14 this is still broken,
Comment 29 Dan Williams 2011-04-19 17:48:05 EDT
Correct, this is addressed in 0.9 and Fedora 15 and later.  It works there, but it won't ever work in NM 0.8 and earlier (f14/f13).  Given that, I'm going to mark as fixed since it's been working in F15 for a few months already.  A large part of NM 0.9 was rearchitecting to make stuff like FUS possible.
Comment 30 Max Romanov 2011-04-22 11:29:06 EDT
another workaround: http://sourceforge.net/projects/nm-applet-guard/

Note You need to log in before you can comment on or make changes to this bug.