Bug 454075 - JSDoc not built for perl 5.10.0
JSDoc not built for perl 5.10.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: JSDoc (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Matěj Cepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-07-04 08:47 EDT by Paul Howarth
Modified: 2018-04-11 04:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 05:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add perl(:MODULE_COMPAT...) dependency and fix license tag for GPL (any version) (957 bytes, patch)
2008-07-04 08:47 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Paul Howarth 2008-07-04 08:47:54 EDT
The F-9 package of JSDoc has modules in "perl 5.8.8" paths,
which are not found by F-9's perl 5.10.0. The package therefore needs rebuilding
for perl 5.10.0.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0.
Comment 1 Paul Howarth 2008-07-04 08:47:54 EDT
Created attachment 311038 [details]
Patch to add perl(:MODULE_COMPAT...) dependency and fix license tag for GPL (any version)
Comment 2 Fedora Update System 2008-09-08 12:20:43 EDT
JSDoc-1.10.2-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/JSDoc-1.10.2-5.fc9
Comment 3 Fedora Update System 2008-09-11 12:57:14 EDT
JSDoc-1.10.2-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update JSDoc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7800
Comment 4 Fedora Update System 2008-10-07 05:45:51 EDT
JSDoc-1.10.2-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.