Bug 454080 - hamlib-perl not built for perl 5.10.0
hamlib-perl not built for perl 5.10.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hamlib (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-07-04 09:14 EDT by Paul Howarth
Modified: 2008-07-08 22:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.2.7-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 22:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add perl(:MODULE_COMPAT...) dependency and fix most rpmlint complaints except the "invalid-soname" ones, which would require more invasive changes (1.58 KB, patch)
2008-07-04 09:14 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Paul Howarth 2008-07-04 09:14:28 EDT
The F-9 package of hamlib-perl has modules in "perl 5.8.8" paths,
which are not found by F-9's perl 5.10.0. The package therefore needs rebuilding
for perl 5.10.0.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0.
Comment 1 Paul Howarth 2008-07-04 09:14:28 EDT
Created attachment 311040 [details]
Patch to add perl(:MODULE_COMPAT...) dependency and fix most rpmlint complaints except the "invalid-soname" ones, which would require more invasive changes
Comment 2 Steve Conklin 2008-07-07 13:47:04 EDT
I'll apply the patch and build - thanks!
Comment 3 Fedora Update System 2008-07-07 14:23:32 EDT
hamlib-1.2.7-3.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-07-08 22:54:21 EDT
hamlib-1.2.7-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.