Bug 454253 - geoqo not built for perl 5.10.0
geoqo not built for perl 5.10.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: geoqo (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Wes Hardaker
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-07-07 05:34 EDT by Paul Howarth
Modified: 2008-09-10 02:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 02:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2008-07-07 05:34:56 EDT
The F-9 package of geoqo has modules in "perl 5.8.8" paths,
which are not found by F-9's perl 5.10.0. The package therefore needs rebuilding
for perl 5.10.0.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0. To avoid a repeat of this problem in the future, I suggest
adding the following dependency to the package (virtually all Fedora perl
packages have this):

Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

P.S. I'm a little confused about the license tag: almost every file in the
package that specifies a license says "GPLv2"; the only exception I can see is
GeoDB/Export.pm, which contains both GPLv2 and (GPL or Artistic) code, which
makes the result also GPLv2. So why isn't the overall package simply GPLv2?
Comment 1 Fedora Update System 2008-07-18 18:22:21 EDT
geoqo-0.97-3.fc9 has been submitted as an update for Fedora 9
Comment 2 Fedora Update System 2008-07-19 05:43:28 EDT
geoqo-0.97-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geoqo'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6540
Comment 3 Fedora Update System 2008-09-10 02:48:30 EDT
geoqo-0.97-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.