Bug 454854 - timed get on local queue doesn't actually timeout
timed get on local queue doesn't actually timeout
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity high
: 1.0.1
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On:
Blocks: 459260
  Show dependency treegraph
 
Reported: 2008-07-10 04:23 EDT by Gordon Sim
Modified: 2011-08-12 12:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 15:08:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-07-10 04:23:20 EDT
The underlying BlockingQueue::pop() keeps spinning on the empty check.
Comment 1 Gordon Sim 2008-07-10 04:40:11 EDT
Fix committed to qpid trunk as r675477.
Comment 2 Gordon Sim 2008-07-10 04:48:56 EDT
Target is provisionally 1.0.1, but the timed wait was intorduced since the GA
release so if that enhancement is not included in 1.0.1, this bug need not be
either.
Comment 3 Gordon Sim 2008-07-10 10:45:03 EDT
merged to qpid.0-10 branch as r675598
Comment 6 Frantisek Reznicek 2008-09-17 03:39:44 EDT
RHTS test MRG_Messaging/qpid_localqueue_timeout_bz453599 results prove that bug has been fixed. (->VERIFIED)
Comment 8 errata-xmlrpc 2008-10-06 15:08:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0640.html

Note You need to log in before you can comment on or make changes to this bug.