This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 455277 - le fichier /usr/share/man/fr/man8/rpm.8.gz de l'installation de rpm-4.5.90-0.git8426.7.x86_64 entre en conflit avec le fichier du paquetage man-pages-fr-2.80.0-2.fc10.noarch
le fichier /usr/share/man/fr/man8/rpm.8.gz de l'installation de rpm-4.5.90-0....
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man-pages-fr (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Alain Portal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-07-14 12:27 EDT by Nicolas Mailhot
Modified: 2008-09-15 14:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 07:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for spec file to fix this bug and another one (1.06 KB, patch)
2008-09-06 09:46 EDT, Alain Portal
no flags Details | Diff

  None (edit)
Description Nicolas Mailhot 2008-07-14 12:27:25 EDT
Résumé de la transaction
=============================================================================
Installation      5 Paquetage(s)         
Mise à jour      21 Package(s)         
Suppression       1 Package(s)         

Taille totale des téléchargement : 38 M
Téléchargement des paquetages :
(1/26): perl-ExtUtils-CBuilder-0.21-36.fc10.x86_64.rpm                         
                                                               |  32 kB    
00:00     
(2/26): xmlto-0.0.21-2.fc10.x86_64.rpm                                         
                                                               |  33 kB    
00:00     
(3/26): perl-Module-ScanDeps-0.84-1.fc10.noarch.rpm                            
                                                               |  39 kB    
00:00     
(4/26): rpm-python-4.5.90-0.git8426.7.x86_64.rpm                               
                                                               |  43 kB    
00:00     
(5/26): byacc-1.9.20070509-4.fc10.x86_64.rpm                                   
                                                               |  50 kB    
00:00     
(6/26): httpd-tools-2.2.9-4.x86_64.rpm                                         
                                                               |  69 kB    
00:00     
(7/26): libmtp-0.2.6.1-3.fc10.x86_64.rpm                                       
                                                               |  87 kB    
00:00     
(8/26): mod_ssl-2.2.9-4.x86_64.rpm                                             
                                                               |  88 kB    
00:00     
(9/26): rpm-build-4.5.90-0.git8426.7.x86_64.rpm                                
                                                               | 116 kB    
00:01     
(10/26): jsch-0.1.39-1.1.fc10.noarch.rpm                                       
                                                               | 194 kB    
00:01     
(11/26): perl-Module-Build-0.2808-36.fc10.x86_64.rpm                           
                                                               | 210 kB    
00:01     
(12/26): php-common-5.2.6-3.x86_64.rpm                                         
                                                               | 230 kB    
00:01     
(13/26): lua-5.1.3-6.fc10.x86_64.rpm                                           
                                                               | 231 kB    
00:01     
(14/26): rpm-libs-4.5.90-0.git8426.7.x86_64.rpm                                
                                                               | 348 kB    
00:01     
(15/26): totem-pl-parser-2.23.3-1.fc10.x86_64.rpm                              
                                                               | 642 kB    
00:02     
(16/26): kernel-headers-2.6.26-137.fc10.x86_64.rpm                             
                                                               | 675 kB    
00:02     
(17/26): net-snmp-5.4.1-20.fc10.x86_64.rpm                                     
                                                               | 695 kB    
00:02     
(18/26): php-mbstring-5.2.6-3.x86_64.rpm                                       
                                                               | 1.1 MB    
00:03     
(19/26): httpd-2.2.9-4.x86_64.rpm                                              
                                                               | 1.1 MB    
00:03     
(20/26): rpm-4.5.90-0.git8426.7.x86_64.rpm                                     
                                                               | 1.1 MB    
00:03     
(21/26): net-snmp-libs-5.4.1-20.fc10.x86_64.rpm                                
                                                               | 1.2 MB    
00:04     
(22/26): php-5.2.6-3.x86_64.rpm                                                
                                                               | 1.2 MB    
00:03     
(23/26): gdb-6.8-17.fc10.x86_64.rpm                                            
                                                               | 2.0 MB    
00:07     
(24/26): php-cli-5.2.6-3.x86_64.rpm                                            
                                                               | 2.3 MB    
00:07     
(25/26): rhythmbox-0.11.6-1.fc10.x86_64.rpm                                    
                                                               | 5.6 MB    
00:16     
(26/26): kernel-2.6.26-137.fc10.x86_64.rpm                                     
                                                               |  19 MB    
00:55     
Lancement de rpm_check_debug
Lancement de la transaction de test
Transaction de test terminée


Erreur du contrôle de transaction :
  le fichier /usr/share/man/fr/man8/rpm.8.gz de l'installation de
rpm-4.5.90-0.git8426.7.x86_64 entre en conflit avec le fichier du paquetage
man-pages-fr-2.80.0-2.fc10.noarch

so close…
Comment 1 Alain Portal 2008-08-04 12:33:12 EDT
(In reply to comment #0)

> so close…

Mon anglais n'étant pas particulièrement brillant, ça veut dire quoi ?

Remarque 1 : tu aurais pu te dispenser d'indiquer tous les paquets que tu mettais à jour, ce n'était pas utile pour le signalement du bogue.

Remarque 2 : j'ai été évidemment très étonné de voir ce rapport de bogue, mais après vérification, le mainteneur de rpm a apparemment décidé d'intégrer une traduction de la page de manuel rpm.8 (qui date de Mathusalem...) et la page fournie (qui date du fils de Mathusalem) par Gérard Delafond (http://www.delafond.org/traducmanfr/man/man8/rpm.8.html) est plus récente que celle fournie par le mainteneur de rpm.
Alors, on fait quoi ?
Sachant qu'en plus je n'ai vraiment plus l'intention de maintenir ce paquet.
En effet, n'ayant pu obtenir d'aide, de la part de la communauté francophone de Fedora (http://forums.fedora-fr.org/viewtopic.php?id=32578) sur des problèmes importants qui devaient me permettre d'avancer sur l'évolution du projet de la traduction française des pages de manuel, je ne vois pas pourquoi je continuerais à me casser le cul pour cette communauté.
J'ai alerté le FESCO il y a plus d'un mois à ce propos (en disant que j'allais libérer TOUS les paquets dont je m'occupe), ça n'a pas l'air de les inquiéter plus que ça.
Très bien, j'en prends acte.

Tout ça pour dire qu'il y a fort peu de chance que je corrige ce bogue, sauf peut être si je décide de corriger aussi celui-là (https://bugzilla.redhat.com/show_bug.cgi?id=457663)
Dans ce cas, je ne ferais que corriger, en aucun cas mettre à jour.

Merci aux trous du cul de la communauté fedora-fr.org (Qui se sent morveux se mouche...) qui ont peut être réussis à me faire changer de distribution...
On verra à la rentrée.

Ah ! pour info, aussi pour te faire plaisir avec quelques mois de retard, ma page d'accueil a été mise à jour. Il n'y a du coup plus aucune référence à la mainteneuse Fedora du paquet, ni à Fedora d'ailleurs.
Et pour faire simple, la news du 18 juillet m'a procuré un certain plaisir :
http://manpagesfr.free.fr/news.html

Au moins, il n'y aura pas de conflit (de dépôt).
Comment 2 Brian Pepple 2008-08-26 21:15:32 EDT
Alain, could you please work with the rpm maintainer to determine which rpm man page we should use before the F10-beta release?  If you need any help or assistance in this, don't hesitate to contact me or any other member of FESCo.  Thanks.

BTW, sorry about not replying in your native language, but unfortunately I know about zero french. :(
Comment 3 Didier G 2008-08-28 18:30:07 EDT
Both rpm-4.5.90-0.git8426.9.i386.rpm and man-pages-fr-2.80.0-2.fc10.noarch.rpm in ISO of Fedora 10 Alpha contain file /usr/share/man/fr/man8/rpm.8.gz

This file /usr/share/man/fr/man8/rpm.8.gz provides man page rpm.8

Comparing both versions of rpm.8 provided by these two rpms, it seems page in man-pages-fr-2.80.0-2.fc10.noarch.rpm in more recent than page in rpm-4.5.90-0.git8426.9.i386.rpm

Page in rpm-4.5.90-0.git8426.9.i386.rpm
======================================================================
.\" Traduction 06/08/2000 par Frédéric Delanoy (fdelanoy@info.fundp.ac.be)
.\"
.\" rpm - Gestionnaire de Paquetages Red Hat
.TH RPM 8 "6 Août 2000" "Red Hat" "Manuel de l'administrateur Linux"
======================================================================

Page in man-pages-fr-2.80.0-2.fc10.noarch.rpm
======================================================================
.\" Traduction 06/08/2000 par Frédéric Delanoy (delanoy_f@yahoo.com)
.\" Mise à jour 06/09/2002 (rpm v4.0.4)
.\"
.\" This manpage has been automatically generated by docbook2man
.\" from a DocBook document.  This tool can be found at:
.\" <http://shell.ipoline.com/~elmert/comp/docbook2X/>
.\" Please send any bug reports, improvements, comments, patches,
.\" etc. to Steve Cheng <steve@ggi-project.org>.
.\"
.TH "RPM" "8" "06 juin 2001" "Red Hat, Inc." "Red Hat Linux"
======================================================================
Comment 4 Alain Portal 2008-09-02 09:27:57 EDT
(In reply to comment #2)
> Alain, could you please work with the rpm maintainer to determine which rpm man
> page we should use before the F10-beta release?

As a general rule, the better place for man-pages translations is the upstream program tarball.
As the version in rpm is older than the one in man-pages-fr, I just sent the "newer" to Panu who will update it in rpm.

So, I'll remove rpm.8 from man-pages-fr as soon I'll be able to connect to cvs :-(

>  If you need any help or
> assistance in this, don't hesitate to contact me or any other member of FESCo. 
> Thanks.
> 
> BTW, sorry about not replying in your native language, but unfortunately I know
> about zero french. :(

No problem. If I spoke french, this is because reporter is french and because my english is too poor to be angry.

I just said that I intend to orphan soonly man-pages-fr, and probably all the packages I maintain.
Comment 5 Alain Portal 2008-09-06 09:44:19 EDT
I get still troubles with cvs that I don't know how to fix:
Permission denied (publickey).
cvs [checkout aborted]: end of file from server (consult above messages if any)

Here is a patch to fix this bug.
Comment 6 Alain Portal 2008-09-06 09:46:25 EDT
Created attachment 315952 [details]
Patch for spec file to fix this bug and another one
Comment 7 Johan Cwiklinski 2008-09-06 13:15:28 EDT
(In reply to comment #5)
> I get still troubles with cvs that I don't know how to fix:
> Permission denied (publickey).
> cvs [checkout aborted]: end of file from server (consult above messages if any)

Have you updated your ssh key on your FAS account after recent infrastructure issues ?
If not, I think that explains the above error.
Comment 8 Alain Portal 2008-09-06 19:00:11 EDT
(In reply to comment #7)

 
> Have you updated your ssh key on your FAS account after recent infrastructure
> issues ?
> If not, I think that explains the above error.

Je vais sans doute passer pour un con, mais tant pis....

Je te trouve particulièrement glonflé de venir oser me proposer ton aide alors que tu m'as banni à la fois d'IRC [1] et des forums fedora-fr...

Si tu crois que j'ai la mémoire courte et que je suis capable de pardonner, tu te fourres le doigt dans l'oeil jusqu'au coude...
Le seul conseil que j'ai à te donner est que si jamais on doit se croiser dans la rue, crois-moi, change de trottoir !
Parce que je ne te raterais pas... (Ce n'est pas une parole en l'air)

Tu te crois fort parce que tu as le pouvoir de m'empécher de parler sur certains canaux de discussions.
Mais c'est justement là que tu montres ta faiblesse : tu n'es pas capable de me contredire dans la discussion, tu n'es pas capable de discuter, donc ta solution est de m'interdire de parler...
Si ce n'est pas du fascisme, çà lui ressemble fortement...

Au moins, sur bugzilla, tu ne peux pas m'interdire, ni supprimer le message....

Tu pourras te glorifier du fait d'avoir réussi à exclure un contributeur de la distribution. Car aujourd'hui, je jète l'éponge, je n'ai pas réussi à obtenir un minimum de soutien du FESCO (ie, pas de réponse...) alors que je considérais y avoir droit.

Fedora continuera sans moins moi, ce n'est pas un problème.
Je suis juste effaré qu'elle puisse continuer avec des cons (trous du cul) comme toi.
Le pire étant que tu es certain d'avoir raison...
Contre cette betise, je ne peux lutter, je laisse tomber.

PS : je n'arrête pas de relire ce que je viens d'écrire avant de l'envoyer.
Je vais passer pour un con, tant pis...

[1] 4 months later, I'm still banned from #fedora-fr and #fedora-devel-fr because what I think and what I say about the french fedora team
Comment 9 Kevin Fenzi 2008-09-07 12:24:30 EDT
Greetings Alain.

First, for your key/cert issues, please see the steps listed in this post: 
http://www.redhat.com/archives/fedora-devel-announce/2008-August/msg00008.html
That should get you back on track there if you follow those steps. 

As to your issues with #fedora-fr and #fedora-devel-fr and the fedora-fr forums, I don't think FESCo has any control over those. I would be happy to try and mediate between you and them, but I don't speak french. :( 
Feel free to find me on #fedora-devel (nick: nirik).
Comment 10 Kevin Kofler 2008-09-07 13:13:16 EDT
I could try mediating (as French is one of the languages I speak and I am not involved in the fedora-fr efforts), but I'm the kind of person who gets angry really quickly, so maybe someone with a cooler head could be a better mediator. ;-)
Comment 11 Alain Portal 2008-09-15 07:17:01 EDT
Kevin (Fenzi),
Could you please build also F8 and F9 packages?
Thanks
Comment 12 Kevin Kofler 2008-09-15 10:27:06 EDT
Why should he? RPM 4.6 isn't going to be pushed to F8 and F9 any time soon (I don't think it ever will, frankly.), so the conflict doesn't exist in F8 nor F9.
Comment 13 Alain Portal 2008-09-15 10:41:53 EDT
Because there is another conflict
https://bugzilla.redhat.com/show_bug.cgi?id=457663
The fixes I made on the spec files are different in devel than in F8/F9, I don't remove rpm.8 man pages in F8/F9.
Comment 14 Kevin Fenzi 2008-09-15 13:44:06 EDT
Yes, I will do so now.
Comment 15 Alain Portal 2008-09-15 14:21:27 EDT
Thanks!
Comment 16 Alain Portal 2008-09-15 14:49:14 EDT
Kevin (Kofler),
as you speak french, perhaps you could take man-pages-fr ownership?

Note You need to log in before you can comment on or make changes to this bug.