Bug 455670 - Mirror to mirror upconvert is broken (especially wrt cluster mirrors)
Mirror to mirror upconvert is broken (especially wrt cluster mirrors)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 17:43 EDT by Jonathan Earl Brassow
Modified: 2010-01-11 22:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:46:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2008-07-16 17:43:39 EDT
When going from 2-way mirrors to 3-way mirrors, the 3-way mirror is activated
(resumed in device-mapper) before the 2-way mirror is deactivated
(suspended/removed in device-mapper).

I assume that the way this is happening is that when a new mirror gets stacked
on the first to form the 3-way, there is a point in time when the old 2-way gets
activated twice.
Comment 2 Jonathan Earl Brassow 2008-07-16 18:06:03 EDT
... and patches existed in February, but for some reason, didn't make it into
CVS or rhel...

https://www.redhat.com/archives/lvm-devel/2008-February/msg00007.html
Comment 3 Alasdair Kergon 2008-07-16 21:14:05 EDT
There was discussion at the time concluding that an in-kernel enhancement with
interface extension was the correct long-term solution.

Those patches were not acceptable as presented because they just replaced one
problem with a different problem without justification.

We can only do that if a judgement can be made that, out in the real world,
having the new problem is somehow "less bad" than having the existing problem. 
No such case was made, so I retained the status quo.
Comment 4 Corey Marthaler 2008-09-22 16:46:24 EDT
Upconvert is still broken with the latest code.

2.6.18-116.el5

lvm2-2.02.40-2.el5    BUILT: Fri Sep 19 09:46:26 CDT 2008
lvm2-cluster-2.02.40-2.el5    BUILT: Fri Sep 19 09:49:59 CDT 2008
device-mapper-1.02.28-2.el5    BUILT: Fri Sep 19 02:50:32 CDT 2008
cmirror-1.1.25-1.el5    BUILT: Fri Sep 19 16:27:46 CDT 2008
kmod-cmirror-0.1.17-1.el5    BUILT: Fri Sep 19 16:27:33 CDT 2008

[root@taft-03 ~]# lvconvert -m 2 taft/mirror
[hang]

Sep 22 15:40:22 taft-03 kernel: device-mapper: dm-log-clustered: [rFuXj1gF] Request timed g
device-mapper: dm-log-clustered: [rFuXj1gF] Request timed out: [DM_CLOG_POSTSUSPEND/3491] g
Sep 22 15:40:37 taft-03 kernel: device-mapper: dm-log-clustered: [rFuXj1gF] Request timed g
device-mapper: dm-log-clustered: [rFuXj1gF] Request timed out: [DM_CLOG_POSTSUSPEND/3492] g
Comment 6 Kiersten (Kerri) Anderson 2008-10-20 10:17:26 EDT
Turns out this is related to bug 460156 which is a blocker for 5.3.  Changing flags to 5.3 request and blocker status.
Comment 8 Milan Broz 2008-10-24 08:32:17 EDT
Patch in
lvm2-2.02.40-6.el5.src.rpm
lvm2-cluster-2.02.40-6.el5.src.rpm
Comment 11 errata-xmlrpc 2009-01-20 16:46:03 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0179.html

Note You need to log in before you can comment on or make changes to this bug.