Bug 460156 - RHEL5 cmirror tracker: clogd ERROR:: Additional resume issued before suspend
RHEL5 cmirror tracker: clogd ERROR:: Additional resume issued before suspend
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cmirror (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 10:51 EDT by Corey Marthaler
Modified: 2010-01-11 21:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:25:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-08-26 10:51:59 EDT
Description of problem:
I've seen this issue every so often when doing mirror creates.

Aug 25 17:05:45 hayes-02 qarshd[3438]: Running cmdline: lvcreate -m 1 -n hayes-02.19867 -L 500M lock_stress
Aug 25 17:05:45 hayes-02 qarshd[3439]: Running cmdline: lvcreate -m 1 -n hayes-02.19884 -L 500M lock_stress
Aug 25 17:06:01 hayes-02 kernel: device-mapper: dm-log-clustered: [Ohxxqto9] Request timed out: [DM_CLOG_RESUME/2] - retrying
Aug 25 17:06:01 hayes-02 clogd[3185]: [Ohxxqto9] ERROR:: Additional resume issued before suspend
Aug 25 17:06:01 hayes-02 dmeventd[3531]: dmeventd ready for processing.
Aug 25 17:06:01 hayes-02 dmeventd[3531]: Monitoring mirror device lock_stress-hayes--03.19865 for events


Version-Release number of selected component (if applicable):
2.6.18-92.el5

lvm2-2.02.32-4.el5    BUILT: Fri Apr  4 06:15:19 CDT 2008
lvm2-cluster-2.02.32-4.el5    BUILT: Wed Apr  2 03:56:50 CDT 2008
cmirror-1.1.22-1.el5    BUILT: Thu Jul 24 15:59:03 CDT 2008
kmod-cmirror-0.1.13-2.el5    BUILT: Thu Jul 24 16:00:48 CDT 2008


How reproducible:
every so often
Comment 1 Jonathan Earl Brassow 2008-08-27 16:25:07 EDT
This looks like a know convert issue (bug 455670).  Verify that there are no mirror to mirror converts happening.  If this truly happens just by doing creates, then you will need to gather the '-vvvv' output from the lvm command.  If it is due to convert, then this is a dup.

(where's the NEEDINFO state?)
Comment 3 Corey Marthaler 2008-09-30 18:04:44 EDT
No mirror to mirror converts happening, just a simple create:

 Sep 30 16:57:06 taft-01 qarshd[7340]: Running cmdline: lvcreate -m 1 -n syncd_primary_2legs_1 -L 600M helter_skelter /dev/sdf1:0-1000 /dev/sde1:0-1000 /dev/sdg1:0-150
Sep 30 16:57:22 taft-01 kernel: device-mapper: dm-log-clustered: [Nj20tA2W] Request timed out: [DM_CLOG_RESUME/2] - retrying
Sep 30 16:57:22 taft-01 clogd[6167]: [Nj20tA2W] ERROR:: Additional resume issued before suspend
Sep 30 16:57:22 taft-01 dmeventd[7434]: dmeventd ready for processing.
Sep 30 16:57:22 taft-01 dmeventd[7434]: Monitoring mirror device helter_skelter-syncd_primary_2legs_1 for events

I'll try and grab that -vvv output for you.

2.6.18-116.el5

lvm2-2.02.40-3.el5    BUILT: Thu Sep 25 14:59:07 CDT 2008
lvm2-cluster-2.02.40-3.el5    BUILT: Thu Sep 25 15:00:54 CDT 2008
device-mapper-1.02.28-2.el5    BUILT: Fri Sep 19 02:50:32 CDT 2008
cmirror-1.1.28-1.el5    BUILT: Tue Sep 30 15:48:54 CDT 2008
kmod-cmirror-0.1.18-1.el5    BUILT: Mon Sep 29 16:20:21 CDT 2008
Comment 4 Jonathan Earl Brassow 2008-10-01 09:49:17 EDT
how often does this happen on the create?  Every time?  If so, we have a real problem.  (... and it would be an LVM/device-mapper bug)
Comment 6 Corey Marthaler 2008-10-15 17:26:08 EDT
Bumping the priority even though I don't have a reliable way to reproduce this. This may be a side effect of 464550, or at the very least, testing is blocked behind it.
Comment 9 errata-xmlrpc 2009-01-20 16:25:52 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0158.html

Note You need to log in before you can comment on or make changes to this bug.