Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 456304 - traceback running rpmlint
Summary: traceback running rpmlint
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 457989 (view as bug list)
Depends On:
Blocks: F10Blocker, F10FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2008-07-22 18:11 UTC by Jeremy Katz
Modified: 2008-09-04 03:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-04 03:04:14 UTC
Type: ---


Attachments (Terms of Use)

Description Jeremy Katz 2008-07-22 18:11:06 UTC
With rpm-4.5.90-0.git8426.8.i386

[katzj@aglarond rpm]$ rpmlint /home/katzj/src/rpm/RPMS/noarch/foo.rpm
Traceback (most recent call last):
  File "/usr/share/rpmlint/rpmlint.py", line 299, in <module>
    main()
  File "/usr/share/rpmlint/rpmlint.py", line 47, in main
    loadCheck(c)
  File "/usr/share/rpmlint/rpmlint.py", line 39, in loadCheck
    imp.load_module(name, f, pathname, description)
  File "/usr/share/rpmlint/TagsCheck.py", line 394, in <module>
    VALID_GROUPS=Config.getOption('ValidGroups', get_default_valid_rpmgroups())
  File "/usr/share/rpmlint/TagsCheck.py", line 27, in get_default_valid_rpmgroups
    filename = filter(lambda x: x.endswith('/GROUPS'), p.files().keys())[0]
IndexError: list index out of range

Comment 1 Johan Cwiklinski 2008-07-22 18:38:43 UTC
Same issue here : 

$ rpmlint eric-4.2-1.fc10.noarch.rpm
Traceback (most recent call last):
  File "/usr/share/rpmlint/rpmlint.py", line 299, in <module>
    main()
  File "/usr/share/rpmlint/rpmlint.py", line 47, in main
    loadCheck(c)
  File "/usr/share/rpmlint/rpmlint.py", line 39, in loadCheck
    imp.load_module(name, f, pathname, description)
  File "/usr/share/rpmlint/TagsCheck.py", line 394, in <module>
    VALID_GROUPS=Config.getOption('ValidGroups', get_default_valid_rpmgroups())
  File "/usr/share/rpmlint/TagsCheck.py", line 27, in get_default_valid_rpmgroups
    filename = filter(lambda x: x.endswith('/GROUPS'), p.files().keys())[0]
IndexError: list index out of range

Comment 2 Ville Skyttä 2008-07-23 17:39:26 UTC
Could you try if the change at
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1439 fixes it?

Comment 3 Ville Skyttä 2008-07-23 17:39:55 UTC
(The change should be made to /usr/share/rpmlint/Pkg.py)

Comment 4 Johan Cwiklinski 2008-07-24 05:39:40 UTC
This seems to fix it :)

Comment 5 Hans de Goede 2008-07-26 18:54:58 UTC
I'm seeing this too, and http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1439
fixes it for me too :)


Comment 6 Fedora Update System 2008-07-27 07:51:01 UTC
rpmlint-0.84-2.fc9 has been submitted as an update for Fedora 9

Comment 7 Fedora Update System 2008-07-30 20:09:33 UTC
rpmlint-0.84-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6871

Comment 8 Todd Zullinger 2008-08-06 06:04:51 UTC
*** Bug 457989 has been marked as a duplicate of this bug. ***

Comment 9 Richard W.M. Jones 2008-08-07 09:08:22 UTC
Is there going to be a fix for this in Rawhide too?  I'm seeing
the problem in Rawhide, but no updated package.

Comment 11 Fedora Update System 2008-08-07 23:54:49 UTC
rpmlint-0.84-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Jeremy Katz 2008-09-04 03:04:14 UTC
Looks good in rawhide


Note You need to log in before you can comment on or make changes to this bug.