Bug 457989 - Crashes when run against spec files on Rawhide
Crashes when run against spec files on Rawhide
Status: CLOSED DUPLICATE of bug 456304
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 20:14 EDT by Adam Huffman
Modified: 2008-08-06 02:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 02:04:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2008-08-05 20:14:36 EDT
Description of problem:
On my new Rawhide system, rpmlint is crashing when run against any spec file:

rpmlint /etc/rpmdevtools/spectemplate-python.spec
Traceback (most recent call last):
  File "/usr/share/rpmlint/rpmlint.py", line 299, in <module>
    main()
  File "/usr/share/rpmlint/rpmlint.py", line 47, in main
    loadCheck(c)
  File "/usr/share/rpmlint/rpmlint.py", line 39, in loadCheck
    imp.load_module(name, f, pathname, description)
  File "/usr/share/rpmlint/TagsCheck.py", line 394, in <module>
    VALID_GROUPS=Config.getOption('ValidGroups', get_default_valid_rpmgroups())
  File "/usr/share/rpmlint/TagsCheck.py", line 27, in get_default_valid_rpmgroups
    filename = filter(lambda x: x.endswith('/GROUPS'), p.files().keys())[0]
IndexError: list index out of range


Version-Release number of selected component (if applicable):
rpmlint-0.83-1.fc10.noarch

How reproducible:
Every time

Steps to Reproduce:
1. rpmlint <specfile>
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Todd Zullinger 2008-08-06 02:04:51 EDT
This should be fixed in rpmlint-0.84-2.fc10, which should be in the next rawhide push.  See koji for the updated package until then:

http://koji.fedoraproject.org/koji/buildinfo?buildID=58616

*** This bug has been marked as a duplicate of bug 456304 ***

Note You need to log in before you can comment on or make changes to this bug.