Bug 456393 - RFE: version of pgf in texlive is old
RFE: version of pgf in texlive is old
Status: CLOSED DUPLICATE of bug 488651
Product: Fedora
Classification: Fedora
Component: texlive-texmf (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
http://sourceforge.net/projects/pgf/
bzcl34nup
:
: 475015 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-23 06:03 EDT by Joel Uckelman
Modified: 2013-07-02 19:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 14:56:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2008-07-23 06:03:47 EDT
+++ This bug was initially created as a clone of Bug #219146 +++

Description of problem:

Version 1.10 of pgf is packaged with texlive; the current version of pgf (2.0)
is two years newer and has far more features.

Version-Release number of selected component (if applicable):

texlive-texmf-2007-22.fc9.noarch
Comment 1 Joel Uckelman 2008-12-12 08:52:25 EST
This is still a problem in Fedora 10. The version of PGF in texlive-texmf-2007-26.fc10.noarch is 1.10.

There are many, many differences between PGF 1.10 and PGF 2.0. It's frequently not possible to build documents which use PGF 2.0 with PGF 1.10, and it's nontrivial to setup PGF oneself. PGF 1.10 was released in October 2006, and PGF 2.0 is itself nearly 10 months old.

I thought that the point of moving from TeTeX to TeXLive was so that Fedora would have an actively-maintained TeX distribution. Including a two-year-old package when there has been a newer and substantially different version for nearly a year already does not square well with that.

Perhaps PGF needs to be its own package?
Comment 2 Joel Uckelman 2008-12-12 10:30:57 EST
PGF 2.00 is available in TeXLive 2008, so upgrading TeXLive would be one way to solve the immediate problem.
Comment 3 Ben Boeckel 2009-01-20 10:53:12 EST
*** Bug 475015 has been marked as a duplicate of this bug. ***
Comment 4 Andrew McNabb 2009-05-06 14:03:41 EDT
This is really a duplicate of bug 488651.  Being stuck on TeXLive 2007 is extremely frustrating.
Comment 5 Andrew McNabb 2009-10-21 14:54:15 EDT
This should really be closed and marked as a duplicate of bug #488651.
Comment 6 Jindrich Novy 2009-10-21 14:56:00 EDT
Marking as duplicate, thanks for heads-up.

*** This bug has been marked as a duplicate of bug 488651 ***

Note You need to log in before you can comment on or make changes to this bug.