This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 456559 - anaconda: i386 xen installer images creation
anaconda: i386 xen installer images creation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10_XenPvOps F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-07-24 13:21 EDT by Mark McLoughlin
Modified: 2008-09-10 06:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 06:49:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mk-images-replace-kernel-xen-with-pv_ops-kernel.patch (5.52 KB, patch)
2008-08-06 13:23 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2008-07-24 13:21:08 EDT
Now that xen guest support has been moved to kernel-PAE.i686 and kernel.x86_64,
we need to drop any remnants of code to handle kernel-xen.

Should be trivial, just filing this to remind myself
Comment 1 Jeremy Katz 2008-07-24 13:48:56 EDT
Hrmm -- the fact that it's in the PAE kernel for x86 adds a couple of wrinkles
1) We don't install the PAE kernel unless you have memory above 4 gigs.  
2) We don't ever use the PAE kernel as the installer kernel, instead using the
i586 kernel in Fedora, i686 kernel in RHEL
Comment 2 Daniel Berrange 2008-07-24 13:54:55 EDT
Fortunately the '.treeinfo' file could help us here. Currently it says:

[images-i386]
kernel = images/pxeboot/vmlinuz
initrd = images/pxeboot/initrd.img
boot.iso = images/boot.iso
[images-xen]
kernel = images/xen/vmlinuz
initrd = images/xen/initrd.img

We could have the 'images/xen' directory contain the PAE variant of 'kernel', or
have a new  images/pxeboot/vmlinux-PAE and 'images/pxeboot/initrd-PAE.img' and
make the 'images-xen' section refer to those.

Since F8 virt-install and virt-manager will both look at the $URL/.treeinfo file
when picking the kernel for guest installs.
Comment 3 Jeremy Katz 2008-07-24 14:17:40 EDT
Yeah, but we still then have to have double sets of images lying around which is
unfortunate.  And we have to switch the logic which does kernel-xen to instead
do kernel-PAE.  Which means that we don't really gain much in the way of
simplifying logic or life.
Comment 4 Bill Nottingham 2008-07-25 10:32:41 EDT
Marking as blocking the beta - whatever we decide to do should be sorted out
then for testing.
Comment 5 Mark McLoughlin 2008-08-06 13:23:46 EDT
Created attachment 313624 [details]
mk-images-replace-kernel-xen-with-pv_ops-kernel.patch

Here's a mk-images patch which I'm still testing

I've also got a bunch of small patches to kill off obsolete xen hacks in anaconda proper; I'll send those out tomorrow
Comment 6 Mark McLoughlin 2008-08-07 05:29:03 EDT
*** Bug 458164 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2008-08-07 09:31:34 EDT
Applied, thanks
Comment 8 Daniel Berrange 2008-08-12 05:31:02 EDT
*** Bug 458164 has been marked as a duplicate of this bug. ***
Comment 9 Mark McLoughlin 2008-08-12 06:18:10 EDT
Seems to be working fine on x86_64 now, but i386 doesn't have .treeinfo/[images-xen] or images/pxeboot/vmlinuz-PAE
Comment 10 Mark McLoughlin 2008-08-14 07:20:39 EDT
Looking at e.g.:

  http://kojipkgs.fedoraproject.org/mash/rawhide-20080812/logs/i386.log

  Wrote /tmp/treebuild.20080812/output/development/i386/os/images/pxeboot/efiboot.img (39159844k free)
  Building stage2.img

I'd expect to it to say "Building initrd-PAE.img" before going onto building stage2.img

I can't see anything obviously wrong with the code and because of bug #458541, I can't easily debug it either
Comment 11 Mark McLoughlin 2008-09-10 06:49:25 EDT
Don't know what's changed but:

  http://kojipkgs.fedoraproject.org/mash/rawhide-20080910/logs/i386.log

shows:

  Building initrd-PAE.img

and:

  http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/.treeinfo

contains:

  [images-xen]
  initrd = images/pxeboot/initrd-PAE.img
  kernel = images/pxeboot/vmlinuz-PAE

Note You need to log in before you can comment on or make changes to this bug.