Bug 456742 - Too many [preload] < defunct > processes.
Too many [preload] < defunct > processes.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: preload (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
: 456819 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 19:59 EDT by sangu
Modified: 2008-11-25 13:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 12:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-07-25 19:59:51 EDT
Description of problem:
$ ps ax | grep preload
[skip]
30992 ?        ZN     0:00 [preload] <defunct>
30994 ?        ZN     0:00 [preload] <defunct>
30995 ?        SN     0:00 /usr/sbin/preload --verbose 1
30999 ?        ZN     0:00 [preload] <defunct>
31002 ?        ZN     0:00 [preload] <defunct>
31003 ?        SN     0:00 /usr/sbin/preload --verbose 1
31005 ?        ZN     0:00 [preload] <defunct>
31006 ?        SN     0:00 /usr/sbin/preload --verbose 1
31008 ?        ZN     0:00 [preload] <defunct>
31012 ?        ZN     0:00 [preload] <defunct>
31015 ?        SN     0:00 /usr/sbin/preload --verbose 1
[skip]
32763 ?        ZN     0:00 [preload] <defunct>
32764 ?        ZN     0:00 [preload] <defunct>

$ ps ax | grep preload | wc -l
7877

$ sudo cat /var/log/preload.log 
[skip]
[Sat Jul 26 01:01:34 2008] failed to rename /var/lib/preload/preload.state.tmp
to /var/lib/preload/preload.state
[Sat Jul 26 01:01:35 2008] failed to rename /var/lib/preload/preload.state.tmp
to /var/lib/preload/preload.state

Version-Release number of selected component (if applicable):
0.6-1.fc10

How reproducible:
always


Steps to Reproduce:
1. Install new preload package <yum install preload>
2. rebooting
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Behdad Esfahbod 2008-07-27 04:12:54 EDT
I'm quite embarrassed by this bug.  I have a fix locally.  Travelling currently.
 I'll build a fixed package as soon as possible.
Comment 2 Tom London 2008-07-27 16:57:28 EDT
I found this too.  It was preventing me from completing gdm login.....

Removing the package "makes it work for me".

[I only found this by scripting a "ps algx" every .2 seconds.....]
Comment 3 Tom London 2008-07-27 17:02:25 EDT
*** Bug 456819 has been marked as a duplicate of this bug. ***
Comment 4 Behdad Esfahbod 2008-07-28 12:54:03 EDT
preload-0.6.1 should fix this.  Please reopen if it doesn't.
Comment 5 Dario Castellarin 2008-11-25 13:13:49 EST
Please note that preload 0.6 is now in updates-testing for F9 and behaves the same (and almost got me a heart attack)!
Comment 6 Fedora Update System 2008-11-25 13:43:24 EST
preload-0.6.3-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preload-0.6.3-2.fc9

Note You need to log in before you can comment on or make changes to this bug.