Bug 456819 - gdm login (and entire system) freezes after about 10 seconds of runlevel 5 boot
gdm login (and entire system) freezes after about 10 seconds of runlevel 5 boot
Status: CLOSED DUPLICATE of bug 456742
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 14:14 EDT by Tom London
Modified: 2015-01-14 18:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-27 17:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of screen with "oom" dump and freeze (212.43 KB, image/jpeg)
2008-07-27 14:14 EDT, Tom London
no flags Details
/var/log/gdm/:0.log (22.29 KB, text/plain)
2008-07-27 14:16 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2008-07-27 14:14:10 EDT
Description of problem:
I can no longer boot up into runlevel 5 and login.

I get gdm-greeter screen, but within about 10 seconds, system freezes (cursor no
longer moves, cntl-alt-F1 no longer works, etc.).

I can successfully boot to runlevel 3, and then successfully do 'startx' without
apparent problems.

On one occasion I managed to 'cntl-alt-F1' and root login before my 10 seconds
of grace passed. The console window quickly froze too, but I believe I did see
characters echoing (sometimes delayed greatly).  After some time (1-2 minutes?)
I got an 'oom' out of memory dump on the screen.  I attach a photo of that
screen below.

I also attach the files from /var/log/gdm from my latest attempt.

I've 'restorecon'ed' the system, booted with enforcing=0, etc. to no avail.

Need help!!

Version-Release number of selected component (if applicable):
gdm-debuginfo-2.23.1-0.2008.07.21.3.fc10.i386
gdm-2.23.1-0.2008.07.21.3.fc10.i386
gdm-user-switch-applet-2.23.1-0.2008.07.21.3.fc10.i386
[Not sure what else to list.....]

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-07-27 14:14:10 EDT
Created attachment 312740 [details]
Photo of screen with "oom" dump and freeze
Comment 2 Tom London 2008-07-27 14:16:08 EDT
/var/log/:0-greeter.log:

[tbl@localhost gdm]$ ls
:0-greeter.log  :0.log
[tbl@localhost gdm]$ cat *greeter*
** (process:2919): DEBUG: Greeter session pid=2919 display=:0
xauthority=/var/run/gdm/auth-cookie-XXK5GREU-for-gdm
gdm-simple-greeter[2919]: DEBUG(+): Enabling debugging
gdm-simple-greeter[2919]: DEBUG(+): Starting a11y registry
gdm-simple-greeter[2919]: DEBUG(+): a11y registry started
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 1: signum=4
(nil)
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 4 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 2: signum=7
(nil)
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 7 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 3:
signum=11 (nil)
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 11 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 4: signum=6
(nil)
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 6 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 5: signum=5
(nil)
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 5 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 6:
signum=15 0x8053870
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 15 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 7: signum=2
0x8053870
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 2 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 8: signum=8
0x8053870
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 8 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 9: signum=1
0x8053870
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 1 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Adding handler 10:
signum=10 0x8053870
gdm-simple-greeter[2919]: DEBUG(+): GdmSignalHandler: Registering for 10 signals
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionManager: Looking for autostart
files in: /usr/share/gdm/autostart/LoginWindow
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionManager: Looking for autostart
files in: /usr/local/share/gdm/autostart/LoginWindow
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: connecting to address:
unix:abstract=/tmp/gdm-greeter-pqVvJWyh,guid=f64f3bd5e5496eeba94f0dde488cb41c
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Calling GetDisplayId
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Creating proxy for
/org/gnome/DisplayManager/Display1
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionManager: Changing level to 8
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionManager: Stopping old clients
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionManager: Calling off notifications
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionManager: Starting new clients
gdm-simple-greeter[2919]: DEBUG(+): Skipping disabled client: Screen Magnifier
gdm-simple-greeter[2919]: DEBUG(+): Skipping disabled client: On-screen Keyboard
gdm-simple-greeter[2919]: DEBUG(+): Skipping disabled client: Screen Reader
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionClient: Starting client: Power Manager
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionClient: Started: pid=2972
command='gnome-power-manager'
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: Launching settings daemon
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: Launching metacity
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterPanel: activating default layout
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: Starting a login window
local:1
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: skipping shell /sbin/nologin
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: Found current seat:
/org/freedesktop/ConsoleKit/Seat1
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterLoginWindow: Got greeter logo
'start-here'
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterLoginWindow: banner message disabled
gdm-simple-greeter[2919]: DEBUG(+): GdmSessionClient: **** child 'Power Manager'
(pid:2972) done (status:0)
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient:
obj_path=/org/gnome/DisplayManager/GreeterServer
interface=org.gnome.DisplayManager.GreeterServer method=Ready
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Ready
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: Ready
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterLoginWindow: Resetting dialog
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a
timestamp of 0 for 0x80002e (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a
timestamp of 0 for 0x80002e (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
gdm-simple-greeter[2919]: DEBUG(+): GdmUserChooserWidget: icon theme changed
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: running 'ck-history
--frequent --seat='Seat1' --session-type='''
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: skipping user with bad
shell: nfsnobody
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: user icon changed
gdm-simple-greeter[2919]: DEBUG(+): adding monitor for '/home/tbl/.face'
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: user icon changed
gdm-simple-greeter[2919]: DEBUG(+): adding monitor for '/home/tlondon/.face'
gdm-simple-greeter[2919]: DEBUG(+): Getting list of sessions for user 502
gdm-simple-greeter[2919]: DEBUG(+): Found 0 sessions for user tlondon
gdm-simple-greeter[2919]: DEBUG(+): Getting list of sessions for user 500
gdm-simple-greeter[2919]: DEBUG(+): Found 0 sessions for user tbl
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: history output: tbl      922

gdm-simple-greeter[2919]: DEBUG(+): GdmUserChooserWidget: User login frequency
changed: tbl
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: history output: root     73

gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: excluding user 'root'
gdm-simple-greeter[2919]: DEBUG(+): GdmUserManager: history output: tlondon  1

gdm-simple-greeter[2919]: DEBUG(+): GdmUserChooserWidget: User login frequency
changed: tlondon
gdm-simple-greeter[2919]: DEBUG(+): GdmUserChooserWidget: Users loaded
gdm-simple-greeter[2919]: DEBUG(+): Login freq 1=1 2=922
gdm-simple-greeter[2919]: DEBUG(+): GdmUserChooserWidget: User added name:tbl
logged-in:0 pixbuf:0x8529c90
gdm-simple-greeter[2919]: DEBUG(+): GdmUserChooserWidget: User added
name:tlondon logged-in:0 pixbuf:0x8529c90
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Calling SelectUser
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Calling
BeginVerificationForUser
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient:
obj_path=/org/gnome/DisplayManager/GreeterServer
interface=org.gnome.DisplayManager.GreeterServer method=DefaultLanguageNameChanged
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Received
DefaultLanguageNameChanged (en_US.UTF-8)
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: default language name
changed: en_US.UTF-8
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient:
obj_path=/org/gnome/DisplayManager/GreeterServer
interface=org.gnome.DisplayManager.GreeterServer method=DefaultLayoutNameChanged
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Received
DefaultLayoutNameChanged (us)
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: default layout name
changed: us
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient:
obj_path=/org/gnome/DisplayManager/GreeterServer
interface=org.gnome.DisplayManager.GreeterServer method=DefaultSessionNameChanged
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Received
DefaultSessionNameChanged (gnome)
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: default session name
changed: gnome
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient:
obj_path=/org/gnome/DisplayManager/GreeterServer
interface=org.gnome.DisplayManager.GreeterServer method=SecretInfoQuery
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterClient: Received SecretInfoQuery
(Password: )
gdm-simple-greeter[2919]: DEBUG(+): GdmGreeterSession: Secret info query: Password: 
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a
timestamp of 0 for 0x80002e (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
[tbl@localhost gdm]$ 
Comment 3 Tom London 2008-07-27 14:16:55 EDT
Created attachment 312741 [details]
/var/log/gdm/:0.log
Comment 4 Tom London 2008-07-27 17:02:24 EDT
I tracked this down by booting into runlevel 3, starting a script that did a 'ps
algxw' every .2 seconds, and then doing a 'telinit 5'.

The last output (from the last .2 seconds before system freeze) from ps showed a
near endless number of process like:
1     0  4202  4200  35  15   9040  6104 -      RN   ?          0:00
/usr/sbin/preload --verbose 1
1     0  4203  4201  35  15   9040  6104 -      RN   ?          0:00
/usr/sbin/preload --verbose 1
1     0  4204  4202  35  15   9040  6104 -      RN   ?          0:00
/usr/sbin/preload --verbose 1

Turns out this is https://bugzilla.redhat.com/show_bug.cgi?id=456742

I "patched" this for me by removing the preload rpm.

Sorry for pointing a finger at gdm, but I was truly lost......

*** This bug has been marked as a duplicate of 456742 ***

Note You need to log in before you can comment on or make changes to this bug.