Bug 456747 - file-roller will not update files
file-roller will not update files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-26 06:57 EDT by James Ettle
Modified: 2009-11-07 14:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-07 14:08:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Demo archive (193 bytes, application/octet-stream)
2008-07-26 06:57 EDT, James Ettle
no flags Details
Demo archive 2 (194 bytes, application/octet-stream)
2008-07-26 06:58 EDT, James Ettle
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 590027 None None None Never

  None (edit)
Description James Ettle 2008-07-26 06:57:34 EDT
Description of problem:
file-roller will not update (overwrite) destination files when unpacking (at
least) a subset of an archive.

Version-Release number of selected component (if applicable):
file-roller-2.20.3-1.fc8
file-roller-2.22.4-1.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Create two archives containing some subfolders and files. arch-1.tar.bz2 and
arch-2.tar.bz2 attached are like this --- they contain

   arch-{12}/folder/file

respectively, where file contains the string "Version 1" or "Version 2".

2. Create a destination folder, e.g. "dest".
3. Open arch-1.tar.bz2 in file-roller. Navtigate into "arch-1", select "folder",
and extract it to "dest", with "Re-create folders" and "Overwrite existing" checked.
4. Check dest/folder/file reads "Version 1".
5. Repeat step 3 with arch-2.tar.bz2.
6. Check dest/folder/file. It still reads "Version 1", we'd expect "Version 2".
  
Actual results:
Files not updated.

Expected results:
Files updated.
Comment 1 James Ettle 2008-07-26 06:57:34 EDT
Created attachment 312702 [details]
Demo archive
Comment 2 James Ettle 2008-07-26 06:58:15 EDT
Created attachment 312703 [details]
Demo archive 2
Comment 3 James Ettle 2008-12-29 09:20:59 EST
Still not fixed in file-roller-2.24.2-1.fc10.x86_64.
Comment 4 James Ettle 2009-07-28 11:25:12 EDT
This is still present in file-roller-2.26.3-1.fc11.x86_64, updating release.
Comment 5 James Ettle 2009-11-07 06:05:46 EST
Still broken in Rawhide, file-roller-2.28.1-2.fc12.x86_64
Comment 6 James Ettle 2009-11-07 12:42:52 EST
Is now being worked on upstream; see GNOME Bugzilla for more.

Note You need to log in before you can comment on or make changes to this bug.