Bug 456820 - Plasma crash when installing a new Plasma Theme
Plasma crash when installing a new Plasma Theme
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks: KDE41
  Show dependency treegraph
 
Reported: 2008-07-27 14:50 EDT by Colin J Thomson
Modified: 2008-09-10 03:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.0.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-27 16:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash backtrace (4.96 KB, application/octet-stream)
2008-07-27 15:58 EDT, Colin J Thomson
no flags Details

  None (edit)
Description Colin J Thomson 2008-07-27 14:50:12 EDT
Description of problem:
Plasma crash when installing a new Plasma Theme

Version-Release number of selected component (if applicable):
KDE4.1.00 (KDE 4.0.99 (4.1 RC1+)) kdebase-* (4.0.99) from updates-testing

How reproducible:
always

Steps to Reproduce:
1. Desktop Settings > Install new Theme
2. Download and install (apply) a new Theme, Plasma will crash
  
Actual results:
Plasma crashes

Expected results:
New Theme should install

Additional info: Rolling back to kdebase-*-4.0.99 from kde-redhat-testing fixes
the problem.
Comment 1 Kevin Kofler 2008-07-27 14:55:29 EDT
What exact versions have you rolled back to?
Comment 2 Colin J Thomson 2008-07-27 15:03:16 EDT
kdebase-libs-4.0.99-1.fc9.i386
kdebase-4.0.99-1.fc9.i386
kdebase-runtime-4.0.99-1.fc9.i386
kdebase-workspace-4.0.99-1.fc9.i386
kdebase-workspace-libs-4.0.99-1.fc9.i386
kdebase-workspace-devel-4.0.99-1.fc9.i386

These are from kde-redhat stored locally here.
Comment 3 Kevin Kofler 2008-07-27 15:12:48 EDT
What's now in updates-testing (to be replaced with 4.1.0 in the next push) is:
kdebase-4.0.99-1.fc9
kdebase-runtime-4.0.99-2.fc9
kdebase-workspace-4.0.99-3.fc9

So, unless this is a build issue (i.e. related to building against different 
packages), this leaves the following changes:

kdebase-runtime-4.0.99-2:
- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
(That can't really be it.)

kdebase-workspace-4.0.99-3:
- BR soprano-devel (optional dependency of the Plasma Engine Explorer)
(That one could possible be it, but I doubt it.)

kdebase-workspace-4.0.99-2:
- backport Plasma tooltip manager from KDE 4.2 (fixes regression from 4.0)
(I'd bet on this one. This fixes tooltips no longer being there, but it changes 
quite some Plasma code.)
Comment 4 Kevin Kofler 2008-07-27 15:20:52 EDT
There have been 2 bugfixes (and one cosmetic change) to tooltipmanager.cpp 
since I merged the patch:
http://websvn.kde.org/trunk/KDE/kdebase/workspace/libs/plasma/tooltipmanager.cpp?view=log

I can try applying those to see if those fix the crash, the null pointer check 
could be it.

Is there any chance you could reinstall kdebase-workspace-4.0.99-3.fc9 from 
updates-testing and the matching kdebase-workspace-debuginfo and obtain a 
backtrace for the crash? That would tell us where the crash happens.
Comment 5 Kevin Kofler 2008-07-27 15:36:37 EDT
I'm pretty sure this fixes it:
http://websvn.kde.org/trunk/KDE/kdebase/workspace/libs/plasma/tooltipmanager.cpp?r1=837733&r2=837827
This is code called when the theme is changed, and it has been added between 
the version of kdebase-workspace you reported working (4.0.99-1) and the one 
you reported crashing (4.0.99-3), and a NULL pointer dereference is a crash 
bug.

I'll apply this and the other fix.
Comment 6 Colin J Thomson 2008-07-27 15:58:02 EDT
Created attachment 312743 [details]
crash backtrace
Comment 7 Kevin Kofler 2008-07-27 16:04:00 EDT
Thanks. That's exactly what the updated patch fixes. I'm building fixed 
kdebase-workspace builds (4.1.0-2) now.
Comment 8 Colin J Thomson 2008-07-27 16:27:36 EDT
OK, I look forward to testing them.
Comment 9 Fedora Update System 2008-09-10 03:18:26 EDT
kdeedu-4.1.0-1.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, kdeartwork-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, PyQt4-4.4.2-2.fc9, kde-i18n-3.5.9-8.fc9, kdebase-4.1.0-1.fc9.1, sip-4.7.6-1.fc9, kdebase-workspace-4.1.0-8.fc9, automoc-1.0-0.8.rc1.fc9, kdegames-4.1.0-2.fc9, akonadi-1.0.0-2.fc9, soprano-2.1-1.fc9, konq-plugins-4.1.0-2.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.1-2.fc9, qscintilla-2.2-3.fc9, kdepimlibs-4.1.0-2.fc9, kdebindings-4.1.0-5.fc9, kdenetwork-4.1.0-2.fc9, kde-l10n-4.1.0-2.fc9, kdeplasma-addons-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, kdeutils-4.1.0-1.fc9.1, kdemultimedia-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9, kde-filesystem-4-17.fc9, kdeaccessibility-4.1.0-1.fc9, kdebase-runtime-4.1.0-3.fc9, phonon-4.2.0-4.fc9, kdegraphics-4.1.0-5.fc9, kdelibs-4.1.0-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.