Bug 456845 - [fix available] Launch oomath in terminal will generate GdkPixbuf warning
[fix available] Launch oomath in terminal will generate GdkPixbuf warning
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
i386 Linux
low Severity low
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
: 462052 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 23:18 EDT by Yolkfull Chow
Modified: 2009-09-02 05:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:08:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch to fix (1.81 KB, patch)
2008-07-28 05:14 EDT, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 81083 None None None Never

  None (edit)
Description Yolkfull Chow 2008-07-27 23:18:31 EDT
Description of problem:
Following error message will be generated when launch oomath in terminal:

#oomath &
[2] 7555
[root@dhcp-65-93 Desktop]# 
** (soffice:7565): CRITICAL **: GdkPixbuf* bitmapToPixbuf(SalBitmap*,
SalBitmap*): assertion `pBitmap->mnBitCount == 24' failed



Version-Release number of selected component (if applicable):
openoffice.org-math-2.3.0-6.7.el5

How reproducible:
Everytime

Steps to Reproduce:
1. launch oomath in terminal
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 lihuang 2008-07-28 02:28:18 EDT
reproduce with openoffice.org-math-2.3.0-6.7.el5.x86_64
Comment 2 Caolan McNamara 2008-07-28 03:17:57 EDT
Is this a regression from the version before 2.3.0-6.7.el5 ? or has it always
been there ?

Its more a warning than an error, so not too serious looking anyway.
Comment 3 Caolan McNamara 2008-07-28 05:14:13 EDT
Created attachment 312758 [details]
upstream patch to fix
Comment 4 Caolan McNamara 2008-07-28 05:15:46 EDT
Minor, but easy to pick up the fix for it during an errata
Comment 5 Caolan McNamara 2008-09-12 04:38:23 EDT
*** Bug 462052 has been marked as a duplicate of this bug. ***
Comment 6 Vivian Bian 2008-09-12 04:54:18 EDT
Sorry the version of the OpenOffice should be 2.3.0-6.8.el5.i386
Comment 7 Caolan McNamara 2009-03-12 06:06:45 EDT
committed for >= 2.3.0-6.11
Comment 11 errata-xmlrpc 2009-09-02 05:08:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1248.html

Note You need to log in before you can comment on or make changes to this bug.