Bug 456922 - gitk fails due to tk
Summary: gitk fails due to tk
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tk
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 457286 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-28 16:53 UTC by Horst H. von Brand
Modified: 2008-08-06 11:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-06 11:46:21 UTC
Type: ---


Attachments (Terms of Use)
Output of gitk (1.61 KB, text/plain)
2008-07-28 16:53 UTC, Horst H. von Brand
no flags Details

Description Horst H. von Brand 2008-07-28 16:53:08 UTC
Description of problem:
Running gitk gives the attached output, gitk doesn't work right.

Version-Release number of selected component (if applicable):
tk-8.5.3-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. gitk
2.
3.
  
Actual results:
Window opens, but can't do anything on it with the mouse

Expected results:


Additional info:

Comment 1 Horst H. von Brand 2008-07-28 16:53:08 UTC
Created attachment 312794 [details]
Output of gitk

Comment 2 Marcela Mašláňová 2008-07-29 07:38:49 UTC
Thank you for your report.

I created a ticket for upstream. Meanwhile you can test my solution, which
should hit rawhide tomorrow. The testing will be valuable, because my gitk isn't
crashing, it's only print out the same message.

Comment 3 Zdenek Kabelac 2008-08-01 13:11:20 UTC
I'll add that  tkcvs also doesn't work - and excpet for the lost 'MouseWheel'
name - strace shows quite weird access patterns - when tcl/tk application
actually tries to access nonexistant paths first prior the real installed paths


Comment 4 Marcela Mašláňová 2008-08-04 07:37:22 UTC
*** Bug 457286 has been marked as a duplicate of this bug. ***

Comment 5 Marcela Mašláňová 2008-08-04 12:02:50 UTC
This is upstream ticket: http://sourceforge.net/tracker/index.php?func=detail&aid=2010422&group_id=12997&atid=112997

It looks like the way of using GenericEvents was changed in the latest xorg. All versions of tk will be affected. I'm testing the patches from upstream and try to update asap.

Comment 6 Marcela Mašláňová 2008-08-06 11:46:21 UTC
Fixed by upstream in the latest version.


Note You need to log in before you can comment on or make changes to this bug.