Bug 457286 - amsn hangs when starting
amsn hangs when starting
Status: CLOSED DUPLICATE of bug 456922
Product: Fedora
Classification: Fedora
Component: tk (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Reopened
: 457658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 13:08 EDT by Franck Collins
Modified: 2008-08-04 03:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 03:37:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Franck Collins 2008-07-30 13:08:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); fr; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Description of problem:
When I start amsn, it doesn't launch. A part of error message :

Application initialization failed: Can't find a usable tk.tcl in the following directories: 
    /usr/share/tk8.5 /usr/share/tcl8.5/tk8.5 /usr/lib64/tcl8.5/tk8.5 /usr/lib64/tk8.5/tk8.5 /usr/lib/tcl8.5/tk8.5 /usr/lib/tk8.5/tk8.5 /usr/lib/tk8.5 /lib/tk8.5 /usr/library

/usr/share/tk8.5/tk.tcl: no event type or button # or keysym
no event type or button # or keysym                         
    while executing                                         
"bind Listbox <MouseWheel> {                                
        %W yview scroll [expr {- (%D / 120) * 4}] units     
    }"                                                      
    invoked from within                                     
"if {[tk windowingsystem] eq "aqua"} {                      
    bind Listbox <MouseWheel> {                             
        %W yview scroll [expr {- (%D)}] units               
    }                                                       
    bind Listbox <Option-Mou..."                                                                                                                                                                               
    (file "/usr/share/tk8.5/listbox.tcl" line 182)                                                                                                                                                             
    invoked from within                                                                                                                                                                                        
"source /usr/share/tk8.5/listbox.tcl"                                                                                                                                                                          
    (in namespace eval "::" script line 1)                                                                                                                                                                     
    invoked from within                                                                                                                                                                                        
"namespace eval :: [list source [file join $::tk_library $file.tcl]]"                                                                                                                                          
    (procedure "SourceLibFile" line 2)                                                                                                                                                                         
    invoked from within                                                                                                                                                                                        
"SourceLibFile listbox"                                                                                                                                                                                        
    (in namespace eval "::tk" script line 4)                                                                                                                                                                   
    invoked from within                                                                                                                                                                                        
"namespace eval ::tk {                                                                                                                                                                                         
        SourceLibFile button                                                                                                                                                                                   
        SourceLibFile entry                                                                                                                                                                                    
        SourceLibFile listbox                                                                                                                                                                                  
        SourceLibFile menu                                                                                                                                                                                     
        SourceLibFile panedwindow                                                                                                                                                                              
        SourceLibFile ..."                                                                                                                                                                                     
    invoked from within                                                                                                                                                                                        
"if {$::tk_library ne ""} {                                                                                                                                                                                    
    proc ::tk::SourceLibFile {file} {                                                                                                                                                                          
        namespace eval :: [list source [file join $::tk_library $file.tcl]]                                                                                                                                    
    }                                                                                                                                                                                                          
   ..."                                                                                                                                                                                                        
    (file "/usr/share/tk8.5/tk.tcl" line 404)                                                                                                                                                                  
    invoked from within
"source /usr/share/tk8.5/tk.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $file]"


This probably means that tk wasn't installed properly.

Version-Release number of selected component (if applicable):
amsn-0.97-4.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Just launch amsn

Actual Results:
nothing...

Expected Results:
amsn OK

Additional info:
Comment 1 Sander Hoentjen 2008-07-31 15:26:26 EDT
can you do:
rpm -q tcl tk and give me the output?
Also a 'll /usr/share/tk8.5/tk.tcl' would be nice.
Comment 2 Sander Hoentjen 2008-08-03 04:58:04 EDT
*** Bug 457658 has been marked as a duplicate of this bug. ***
Comment 3 David Nielsen 2008-08-03 05:03:37 EDT
tcl-8.5.3-1.fc10.x86_64
tk-8.5.3-2.fc10.x86_64
Comment 4 Sander Hoentjen 2008-08-03 05:13:23 EDT
trying to start wish gives the same as starting amsn, so it is a tk bug, nut an amsn one:

$ wish
Application initialization failed: Can't find a usable tk.tcl in the following directories: 
    /usr/share/tk8.5 /usr/share/tcl8.5/tk8.5 /usr/lib64/tcl8.5/tk8.5 /usr/lib64/tk8.5/tk8.5 /usr/lib/tcl8.5/tk8.5 /usr/lib/tk8.5/tk8.5 /usr/lib/tk8.5 /lib/tk8.5 /usr/library

/usr/share/tk8.5/tk.tcl: no event type or button # or keysym
no event type or button # or keysym
    while executing
"bind Listbox <MouseWheel> {
        %W yview scroll [expr {- (%D / 120) * 4}] units
    }"
    invoked from within
"if {[tk windowingsystem] eq "aqua"} {
    bind Listbox <MouseWheel> {
        %W yview scroll [expr {- (%D)}] units
    }
    bind Listbox <Option-Mou..."
    (file "/usr/share/tk8.5/listbox.tcl" line 182)
    invoked from within
"source /usr/share/tk8.5/listbox.tcl"
    (in namespace eval "::" script line 1)
    invoked from within
"namespace eval :: [list source [file join $::tk_library $file.tcl]]"
    (procedure "SourceLibFile" line 2)
    invoked from within
"SourceLibFile listbox"
    (in namespace eval "::tk" script line 4)
    invoked from within
"namespace eval ::tk {
	SourceLibFile button
	SourceLibFile entry
	SourceLibFile listbox
	SourceLibFile menu
	SourceLibFile panedwindow
	SourceLibFile ..."
    invoked from within
"if {$::tk_library ne ""} {
    proc ::tk::SourceLibFile {file} {
        namespace eval :: [list source [file join $::tk_library $file.tcl]]
    }
   ..."
    (file "/usr/share/tk8.5/tk.tcl" line 404)
    invoked from within
"source /usr/share/tk8.5/tk.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $file]"


This probably means that tk wasn't installed properly.
Comment 5 Marcela Mašláňová 2008-08-04 03:11:55 EDT

*** This bug has been marked as a duplicate of bug 457505 ***
Comment 6 Marcela Mašláňová 2008-08-04 03:37:22 EDT
Hups, new bugzilla. It's obviously duplicate of problems with tcl.tk #456922

*** This bug has been marked as a duplicate of bug 456922 ***

Note You need to log in before you can comment on or make changes to this bug.