This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 456928 - sabayon/ please update shebangs to point to /usr/bin/python
sabayon/ please update shebangs to point to /usr/bin/python
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sabayon (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
: Patch
: 521332 (view as bug list)
Depends On: 456696
Blocks: 521940
  Show dependency treegraph
 
Reported: 2008-07-28 13:47 EDT by ritz
Modified: 2015-03-03 17:33 EST (History)
6 users (show)

See Also:
Fixed In Version: sabayon-2.12.4-7.el5
Doc Type: Bug Fix
Doc Text:
Cause: Sabayon uses env to locate python on system Consequence: This may lead to unexpected troubles when user sets search paths to his own copy of python, which is not fully compatible with required python version for Sabayon. Fix: Sabayon scripts were made to use /usr/bin/python Result: Proper functionality is guaranteed this way using system python interpreter.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-11 03:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch (1.31 KB, patch)
2008-07-28 13:47 EDT, ritz
no flags Details | Diff
patch (1.95 KB, patch)
2008-07-29 02:38 EDT, ritz
no flags Details | Diff
Updated patch (1.88 KB, patch)
2008-10-16 20:20 EDT, Bryan Mason
no flags Details | Diff

  None (edit)
Comment 1 ritz 2008-07-28 13:47:25 EDT
Created attachment 312799 [details]
patch
Comment 2 ritz 2008-07-29 02:38:07 EDT
Created attachment 312847 [details]
patch
Comment 3 Bryan Mason 2008-10-03 14:25:34 EDT
Yikes!  Flags were never set.  Fixing that now...
Comment 4 Bryan Mason 2008-10-16 20:20:47 EDT
Created attachment 320622 [details]
Updated patch

Applies to recently released sabayon-2.12.4-6
Comment 6 RHEL Product and Program Management 2009-03-26 13:11:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 Kent Baxley 2009-09-04 17:09:37 EDT
*** Bug 521332 has been marked as a duplicate of this bug. ***
Comment 10 RHEL Product and Program Management 2010-08-09 15:22:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 16 Tomáš Bžatek 2011-03-30 11:07:14 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Sabayon uses env to locate python on system

Consequence: This may lead to unexpected troubles when user sets search paths to his own copy of python, which is not fully compatible with required python version for Sabayon.

Fix: Sabayon scripts were made to use /usr/bin/python

Result: Proper functionality is guaranteed this way using system python interpreter.
Comment 19 errata-xmlrpc 2011-05-11 03:23:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0504.html

Note You need to log in before you can comment on or make changes to this bug.