Bug 456945 - kapl font used in aplus-fsf is not available for selection in xemacs
Summary: kapl font used in aplus-fsf is not available for selection in xemacs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: aplus-fsf
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-28 20:04 UTC by Tom Szczesny
Modified: 2009-07-14 18:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 18:02:08 UTC
Type: ---


Attachments (Terms of Use)

Description Tom Szczesny 2008-07-28 20:04:22 UTC
Description of problem:
kapl font used in aplus-fsf is not available for selection in xemacs from the
dropdown box options....fonts.....
This problem occurs on both the x86_64 and i386 platforms.

Version-Release number of selected component (if applicable):
For x86_64 platform I tried it with
aplus-fsf-4.22.1-2.fc9(x86_64) and with aplus-fsf-4.22.1-3.fc9(x86_64)
xemacs-21.5.28-6.fc9(x86_64)
For the i386 platform I tried it with
aplus-fsf-4.22.1-2.fc9(i386)
xemacs-21.5.28-6.fc9(i386)

How reproducible: Start up xemacs and choose options....fonts....  


Steps to Reproduce:
1.  Start up xemacs
2.  Choose options.....
3.  Choose fonts.....
  
Actual results:     kapl font is not shown as a selectable option


Expected results:    expect to be able to choose kapl font


Additional info:

Comment 1 Jochen Schmitt 2008-07-29 15:34:08 UTC
Thank you, that you have taking the time to create this bug report. I have try
to reproduced your issue. If I'm starting xemace and going to Option / Fonts, I
will get two menu choices 'Bitstreem ...' and 'Luxi Sam..'. When I select the
first Menu, I can find the requested font as the ninth menu choice.

I will hope this explaination may help you to solve your issue.

Best Regards:

Jochen Schmitt

Comment 2 Tom Szczesny 2008-07-29 18:20:26 UTC
Hi Jochen -  Thanks for the quick response.  When I run xemacs in FC8, I get
results similar to yours.  (The 2 menu choices that I get are '...Luxi Mono...'
and '...Utopia...'.  Picking the 1st choice gives me a further menu, and Kapl is
the 11th choice.  This works on both the 686 and x86_64 platforms.

However, when I run xemacs in FC9, options..fonts... gives me a list of 23 fonts
on the x86_64 platform with no Kapl and no further menus.  On the 686 platform,
options...fonts... gives me a list of 15 fonts with no Kapl and no further menus.

Not clear why I am getting such different results than you are.  Maybe it is
because I did a fresh install of FC9 on a new partitions on both platforms
instead of an upgrade of my existing FC8 partitions to FC9.  

Best regards, Tom

Comment 3 Jochen Schmitt 2008-07-29 18:55:02 UTC
Thank you for your response. I assume I have found the reason for your issue.
Due an mistake of me, We have an broken update path betwenn F-8 and F-9 so that
the most current release of aplus-fsf was not available for F-9.

Because, I have fixed this issue, it may be nice, if you can do a 'yum update'
or 'yum update aplus-fsf' on your F-9 system and try again to reproduced your
reported issue.

Best Regards:

Jochen Schmitt

Comment 4 Tom Szczesny 2008-07-29 20:56:47 UTC
I ran the "yum update" in F-9 environments on both the x86-64 and i686 platforms
for 4 packages, re-testing xemacs after each package update:
  aplus-fsf
  aplus-fsf-devel
  xemacs-aplus-fsf
  fonts-x11-apl

The kapl font problem was fixed in the F-9 environments on both platforms after
the update of the     fonts-x11-apl    package.

However, I am now experiencing the "iota" problem noted in bug #456952 in the
F-9 environment on both platforms.  The only environment in which I do not have
the bug #456952 is in F-8 on in the x86-64 platform.  I get the error message
"token undefined" in the following environments:
     F-7  F-8  and  F-9  on i686
     F-9 on x86_64    (I currently do not have an F-7 environment on x86_64)

I will attempt to see if there is anything unique about my F-8 environment on x86-64

Thanks for your help,       Tom

Comment 5 Bug Zapper 2009-06-10 02:16:47 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Tom Szczesny 2009-06-11 02:58:22 UTC
This bug has been fixed, and should be closed.
The problem was caused by a dependency on the sort sequence.
It was fixed by adding
      export LC_ALL=POSIX
to   .bashrc

Comment 7 Bug Zapper 2009-07-14 18:02:08 UTC
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.