Bug 457005 - Firefox 3 in RHEL4 catastrophically broken
Firefox 3 in RHEL4 catastrophically broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution28-glib2 (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Matthew Barnes
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 03:04 EDT by bugreports2005
Modified: 2010-10-22 23:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-24 06:10:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bugreports2005 2008-07-29 03:04:00 EDT
Description of problem:

Automatically applied errata, probably for for RHBA-2008:0783-5, updated firefox
from 1.5.0.12-0.21.el4 to 3.0.1-3.el4. Now it won't even start.

How reproducible: Always

Steps to Reproduce:
1. Install RHEL4
2. Update to bring firefox to 3.0.1-3.el4
3. Launch firefox
  
Actual results:

/usr/lib/firefox-3.0.1/firefox-bin: error while loading shared libraries:
libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory

Expected results:

Firefox starts.

Additional info:

Some missing libraries are shipped with frysk, but running with
LD_LIBRARY_PATH=/usr/lib/frysk did not work. Cherry-picking libcairo.so.2 and
libpangocairo-1.0.so.0 shows a requester telling me that GTK 2.4 is too old and
2.10 is needed.

How was this even compiled?
Comment 1 Martin Stransky 2008-07-29 03:07:28 EDT
It runs with evolution28-* packages.
Comment 2 bugreports2005 2008-07-29 05:34:27 EDT
Hmm, so it does .. strange.

Our issue was at least partially because /usr/evolution28 and almost all
directories under it had been created with permissions 0700. I'm not yet sure
why that was.

Firefox works when installed on an RHEL4 of ours that never had it installed
before. On the other hand, re-installing firefox and the evolution28-* packages
doesn't help an affected computer, so there must be more to it. Perhaps more
broken permissions.. I'll see if I can make sense of this.
Comment 3 Matěj Cepl 2008-07-29 09:56:10 EDT
I think it is a good guess, that this should go to Cairo bugs. Reassigning.
Comment 4 Matthew Barnes 2008-07-29 11:19:36 EDT
Firefox 3 starts up fine for me on RHEL 4.  Waiting for more info...
Comment 5 bugreports2005 2008-07-30 08:08:21 EDT
I now believe that our up2date had ended up inheriting a very restrictive umask,
which had caused some newly created directories that weren't owned by any
package to became inaccessible. In particular /usr/evolution28 and most
directories underneath it and some under /usr/lib/firefox-3.0.1 were affected.

I'm not sure if it is desirable for umask to affect the permissions of
directories created by package installation, but I think this bug at least can
be closed. Thanks for the nudge in the right direction.
Comment 6 Matthew Barnes 2008-07-30 08:51:29 EDT
Thanks for the update.  Closing as requested with resolution NOTABUG.
Comment 7 ritz 2009-04-13 14:37:03 EDT
Steps to Reproduce:

1. Changed the umask of root to "0077" by adding "umask 077" in ~/.bashrc
2. If the "/usr/evolution28/" directory is present, move it to /tmp
3. RUn the command set below
  $ rpm -e  rpm -e `rpm -qa|grep evolution28` firefox
  $ up2date install firefox
4. Now run command, /usr/lib/firefox-3.0.4/firefox-bin

Additional information
the directories that should be effected by change to evolution-glib2

# ll /usr/evolution28/
/usr/evolution28:
total 40
drwx------  5 root root 4096 Mar 12 08:20 etc
drwx------  4 root root 4096 Mar 12 08:20 lib
drwx------  5 root root 4096 Mar 12 08:20 share
Comment 10 Ashish 2009-05-20 06:32:46 EDT
I have tried installing firefox 3, but after extracting the files from the bz2 file, when I tried to run the firefox script, I got the following error message - 
"error while loading shared libraries: libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory"
Comment 11 Martin Stransky 2009-05-20 06:43:11 EDT
"extracting the files from the bz2" ?? Firefox is supposed to be installed from original Red Hat rpm file. Mozilla Firefox binaries are not supported.
Comment 12 Ashish 2009-05-20 07:33:40 EDT
From which location can I download the rpm file ?

In Mozilla's website, there is no option of downloading the rpm file for their products. They give only bz2 files for download.
Comment 13 Martin Stransky 2009-05-20 07:57:08 EDT
Get your updates at http://rhn.redhat.com
Comment 16 ritz 2010-02-24 05:56:05 EST
This should probably be fixed with 
http://bugzilla.redhat.com/430504
Comment 17 Milan Crha 2010-02-24 06:10:05 EST
As I was told on IRC by ritz, this is fixed by [1], thus I'm closing this one.

[1] http://rhn.redhat.com/errata/RHBA-2009-0951.html

Note You need to log in before you can comment on or make changes to this bug.