Bug 457146 - gdm regression - unnecessary use of mouse
gdm regression - unnecessary use of mouse
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 458623 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 17:02 EDT by John Ellson
Modified: 2015-01-14 18:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-15 17:14:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2008-07-29 17:02:29 EDT
Description of problem:
Using fedora-8's gdm-2.20.5-3.fc8.x86_64 it was possible to login without
touching the mouse.   Input focus was in a username text box.

With Rawhides latest gdm its necessary to first use the mouse to select a user.

Version-Release number of selected component (if applicable):
gdm-2.23.1-0.2008.07.28.1.fc10.x86_64


How reproducible:
100%

Steps to Reproduce:
1.(gdm login screen)
2.
3.
  
Actual results:
need to use mouse

Expected results:
no need for mouse to login

Additional info:
Comment 1 Ray Strode [halfline] 2008-07-29 17:53:40 EDT
focus should be such that you can just type the username and press enter.  that
doesn't work?
Comment 2 John Ellson 2008-07-29 18:05:57 EDT
Oh, I don't know why you have to hide the input text field?
but OK, that works.
Comment 3 John Ellson 2008-07-31 17:16:21 EDT
I take that back, it doesn't always work.  In fact, it doesn't work on the first
gdm screen after a reboot.
 
    1. reboot
    (don't touch the mouse)
    2. type in a user name and enter, or just enter for the current name
    

Nothing happens.


Comment 4 Ray Strode [halfline] 2008-07-31 22:02:49 EDT
Looks like we've had some initial focus regression since f-9.  Dave mentioned
seeing it on IRC, too, so i'm adding him to the cc list.
Comment 5 Matthias Clasen 2008-08-01 13:02:33 EDT
Looking at the code, I only ever see us grab the focus to the auth-entry.
There probably needs to be some gtk_widget_grab_focus (user_chooser) at the
appropriate spot.
Comment 6 Matthias Clasen 2008-08-11 17:55:01 EDT
*** Bug 458623 has been marked as a duplicate of this bug. ***
Comment 7 jmccann 2008-08-15 17:14:24 EDT
Fixed upstream.  Will appear in the beta.

Note You need to log in before you can comment on or make changes to this bug.