Bug 457243 - tcsh do not work anymore as login shell for non interactive software
tcsh do not work anymore as login shell for non interactive software
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: setup (Show other bugs)
4.7
All Linux
low Severity high
: rc
: ---
Assigned To: Ondrej Vasik
: Regression
: 464788 464905 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 09:49 EDT by Klaus Ethgen
Modified: 2013-03-08 12:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:24:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for noninteractive shell issues for tcsh (547 bytes, patch)
2008-11-05 09:06 EST, Ondrej Vasik
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0030 normal SHIPPED_LIVE setup bug fix and enhancement update 2009-01-14 08:24:34 EST

  None (edit)
Description Klaus Ethgen 2008-07-30 09:49:45 EDT
Description of problem:
If there are using kerberos5 tools or other tools which have there commands in
other path than /usr/bin or /bin and the path is added in a file in
/etc/profile.d then that tools doesn't work anymore using it remotely or by a
icon on the desktop.

Version-Release number of selected component (if applicable):
Version 2.5.37-1.3 work well
Version 2.5.37-1.7 is buggy

How reproducible:
- Put a tool to a non standard path (Say /usr/kerberos/bin in package
  krb5-workstation)
- Try to run such a tool remotely with "ssh machine 'tool'" (For example klist)

Actual results:
command not found

Expected results:
The execution of the program.

Additional info:
This bug seems to be the reaction to #191233 and #202468. Unlike the arguing in
that bug report is wrong (see below) the fix is simply broken. You test (only
for (t)csh) if there is a prompt. But for all remotely called commands there is
NO prompt (unlike you call it with -t).

Let me comment #191233:
It IS the expected behavior that the relevant files in /etc/profile.d gets
executed as they set the correct environment for several tools. And yes, that is
the behaviour with bash (and was it within the tcsh too until you try to fix
something that is not broken).
Comment 1 Ondrej Vasik 2008-11-05 09:06:24 EST
Created attachment 322572 [details]
Fix for noninteractive shell issues for tcsh

I guess both issues could be solved together by redirecting stdout and stderr
to /dev/null for noninteractive shells ... tried following patch and it works
for me in both cases.
Comment 2 Ondrej Vasik 2008-11-05 09:09:11 EST
*** Bug 464788 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Vasik 2008-11-05 09:10:50 EST
*** Bug 464905 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2009-01-14 08:24:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0030.html

Note You need to log in before you can comment on or make changes to this bug.