Bug 464905 - Non-interactive shells do not read /etc/profile.d
Non-interactive shells do not read /etc/profile.d
Status: CLOSED DUPLICATE of bug 457243
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: setup (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 05:54 EDT by Göran Uddeborg
Modified: 2008-11-05 09:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 09:10:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2008-10-01 05:54:54 EDT
Description of problem:
In recent versions of setup the initializations in /etc/profile.d are only executed if $prompt is set.  This was done as a fix to bug 202468.

But it is the wrong fix.  Non-interactive shells, for example when doing "rsh host command", still need path and environment settings from these files.

Scripts in /etc/profile.d should not write anything in non-interactive shells.  If any of them do, it is that script that should be fixed.  We should not blindly disable all valid scripts because of some broken ones.

Version-Release number of selected component (if applicable):
setup-2.5.37-1.7

How reproducible:
Every time.

Steps to Reproduce:
1. Install krb5-workstation
2. Run any command from /usr/kerberos/bin via rsh.  (But without full path, obviously.)
  
Actual results:
The command is not found.

Expected results:
The command should be executed
Comment 1 Ondrej Vasik 2008-11-05 09:10:49 EST
Thanks for report, however duplicate of #457243 , see that bugzilla for proposed solution of both issues.

*** This bug has been marked as a duplicate of bug 457243 ***

Note You need to log in before you can comment on or make changes to this bug.