Bug 457330 - gnome-power-manager shows multiple entries for batteries
gnome-power-manager shows multiple entries for batteries
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 18:56 EDT by Andreas Dilger
Modified: 2013-03-05 22:56 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.25.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 03:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PNG image with stale battery information (8.21 KB, image/png)
2008-07-30 19:12 EDT, Andreas Dilger
no flags Details
PNG image showing item for removed battery (9.57 KB, image/png)
2008-07-30 19:13 EDT, Andreas Dilger
no flags Details

  None (edit)
Description Andreas Dilger 2008-07-30 18:56:33 EDT
Description of problem:

In the last month or so, the Power Manager applet on my toolbar reports multiple
entries for each of my batteries.  One of each of them is up-to-date for each
battery, but the others contain stale data (e.g. charge 30% when battery is
full, or charge 100% when battery is nearly dead) and it is definitely confusing
to determine what the correct battery charge is.

I also found bug 246661 which may or may not be related, but it was closed
because it was old and only on FC7.

Version-Release number of selected component (if applicable):

Laptop is Dell Latitude D630 running with 2 batteries and:

Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.25.10                         Vendor: Fedora Project
Release     : 47.fc8                        Build Date: Mon 07 Jul 2008 04:53:54
PM MDT
Install Date: Wed 16 Jul 2008 10:19:25 AM MDT      Build Host:
xenbuilder2.fedora.redhat.com
Group       : System Environment/Kernel     Source RPM:
kernel-2.6.25.10-47.fc8.src.rpm
Size        : 72912019                         License: GPLv2
Signature   : DSA/SHA1, Mon 14 Jul 2008 11:08:01 AM MDT, Key ID b44269d04f2a6fd2
Packager    : Fedora Project

Name        : gnome-power-manager          Relocations: (not relocatable)
Version     : 2.20.0                            Vendor: Fedora Project
Release     : 6.fc8                         Build Date: Tue 16 Oct 2007 03:07:20
PM MDT
Install Date: Thu 18 Oct 2007 12:34:58 PM MDT      Build Host:
xenbuilder1.fedora.redhat.com
Group       : Applications/System           Source RPM:
gnome-power-manager-2.20.0-6.fc8.src.rpm
Size        : 11221275                         License: GPLv2+ and GFDL+
Signature   : (none)
Packager    : Fedora Project

Name        : udev                         Relocations: (not relocatable)
Version     : 118                               Vendor: Fedora Project
Release     : 1.fc8                         Build Date: Thu 10 Jan 2008 09:00:07
AM MST
Install Date: Wed 16 Jan 2008 10:41:00 AM MST      Build Host:
xenbuilder4.fedora.phx.redhat.com
Group       : System Environment/Base       Source RPM: udev-118-1.fc8.src.rpm
Size        : 625558                           License: GPLv2
Signature   : DSA/SHA1, Mon 14 Jan 2008 11:41:33 AM MST, Key ID b44269d04f2a6fd2
Packager    : Fedora Project


It isn't clear that this is a bug in Power Manager, because that RPM hasn't been
updated in a long time.  It might also be the kernel, or possibly some
intermediate component like DBUS or udev.

How reproducible:

I run daily yum updates for the FC8 errata, and this started happening about a
month ago or so.  This problem is visible all the time, even right after a
reboot.  Sometimes as many as 5 or 6 entries are present. Removing one of the
batteries leaves a "dead" entry for that battery and 2 entries for the remaining
battery.  Removing both batteries leaves 2 "dead" entries.  Selecting these
entries shows "Status: Missing".  When the batteries are inserted clicking on
the batteries separately shows different information for each battery, depending
on which one is selected.  One of them is detailed (battery model, serial
number, etc) and one of them is generic only.

Note that the information in /proc/acpi appears to be correct:
# ls /proc/acpi/battery
total 0
0 BAT0/  0 BAT1/
# cat /proc/acpi/battery/BAT0/info 
present:                 yes
design capacity:         5200 mAh
last full capacity:      4359 mAh
battery technology:      rechargeable
design voltage:          11100 mV
design capacity warning: 520 mAh
design capacity low:     157 mAh
capacity granularity 1:  52 mAh
capacity granularity 2:  52 mAh
model number:            DELL KP4337
serial number:           4033
battery type:            LION
OEM info:                SMP
# cat /proc/acpi/battery/BAT1/info
present:                 yes
design capacity:         4324 mAh
last full capacity:      4021 mAh
battery technology:      rechargeable
design voltage:          11100 mV
design capacity warning: 432 mAh
design capacity low:     131 mAh
capacity granularity 1:  43 mAh
capacity granularity 2:  43 mAh
model number:            DELL 0007P8
serial number:           942
battery type:            LiP
OEM info:                Sanyo


Steps to Reproduce:
1. my laptop has 2 batteries installed (
2. click on Power Manager applet to see detailed stats (not tooltip)
3. see multiple battery entries, some with stale information
  
Actual results:

4+ batteries are reported when clicking on the power manager applet, some with
stale charge information

Expected results:

2 batteries are reported when clicking on power manager applet, both have
correct information.
Additional info:
Comment 1 Andreas Dilger 2008-07-30 19:12:46 EDT
Created attachment 313049 [details]
PNG image with stale battery information
Comment 2 Andreas Dilger 2008-07-30 19:13:26 EDT
Created attachment 313051 [details]
PNG image showing item for removed battery
Comment 3 Andreas Dilger 2008-08-01 03:34:36 EDT
After upgrading to the latest kernel yesterday this problem appears to be fixed.

Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.25.11                         Vendor: Fedora Project
Release     : 60.fc8                        Build Date: Sun 20 Jul 2008 11:55:26
PM MDT
Install Date: Mon 28 Jul 2008 09:50:54 AM MDT      Build Host: x86-7
Group       : System Environment/Kernel     Source RPM:
kernel-2.6.25.11-60.fc8.src.rpm
Size        : 72999420                         License: GPLv2
Signature   : DSA/SHA1, Thu 24 Jul 2008 03:22:50 PM MDT, Key ID b44269d04f2a6fd2
Packager    : Fedora Project

Note You need to log in before you can comment on or make changes to this bug.