Bug 457599 - INFO: possible recursive locking detected: NetworkManager/2558 is trying to acquire lock
INFO: possible recursive locking detected: NetworkManager/2558 is trying to a...
Status: CLOSED DUPLICATE of bug 457592
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 14:45 EDT by Tom London
Modified: 2008-08-12 11:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 11:39:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-08-01 14:45:39 EDT
Description of problem:

Aug  1 11:22:53 localhost NetworkManager: <WARN>  nm_signal_handler(): Caught
signal 15, shutting down normally.
Aug  1 11:22:53 localhost NetworkManager: <info>  (eth0): now unmanaged
Aug  1 11:22:53 localhost NetworkManager: <info>  (eth0): device state change: 8
-> 1
Aug  1 11:22:53 localhost NetworkManager: <info>  (eth0): deactivating device.
Aug  1 11:22:53 localhost NetworkManager: <info>  eth0: canceled DHCP
transaction, dhcp client pid 2685
Aug  1 11:22:53 localhost NetworkManager: <WARN>  check_one_route(): (eth0)
error -34 returned from rtnl_route_del(): Missing link name TLV (errno = Invalid
argument)
Aug  1 11:22:53 localhost NetworkManager: <info>  (eth0): cleaning up...
Aug  1 11:22:53 localhost NetworkManager: <info>  (eth0): taking down device.
Aug  1 11:22:53 localhost NetworkManager: <info>  (wlan0): now unmanaged
Aug  1 11:22:53 localhost NetworkManager: <info>  (wlan0): device state change:
3 -> 1
Aug  1 11:22:53 localhost NetworkManager: <info>  (wlan0): cleaning up...
Aug  1 11:22:53 localhost NetworkManager: <info>  (wlan0): taking down device.
Aug  1 11:22:53 localhost kernel:
Aug  1 11:22:53 localhost kernel: =============================================
Aug  1 11:22:53 localhost kernel: [ INFO: possible recursive locking detected ]
Aug  1 11:22:53 localhost kernel: 2.6.27-0.205.rc1.git2.fc10.i686 #1
Aug  1 11:22:53 localhost kernel: ---------------------------------------------
Aug  1 11:22:53 localhost kernel: NetworkManager/2558 is trying to acquire lock:
Aug  1 11:22:53 localhost kernel: (_xmit_IEEE80211#2){-+..}, at: [<c061e75c>]
dev_deactivate+0x57/0xfa
Aug  1 11:22:53 localhost kernel:
Aug  1 11:22:53 localhost kernel: but task is already holding lock:
Aug  1 11:22:53 localhost kernel: (_xmit_IEEE80211#2){-+..}, at: [<c061e75c>]
dev_deactivate+0x57/0xfa
Aug  1 11:22:53 localhost kernel:
Aug  1 11:22:53 localhost kernel: other info that might help us debug this:
Aug  1 11:22:53 localhost kernel: 2 locks held by NetworkManager/2558:
Aug  1 11:22:53 localhost kernel: #0:  (rtnl_mutex){--..}, at: [<c0617bef>]
rtnetlink_rcv+0x17/0x2b
Aug  1 11:22:53 localhost kernel: #1:  (_xmit_IEEE80211#2){-+..}, at:
[<c061e75c>] dev_deactivate+0x57/0xfa
Aug  1 11:22:53 localhost kernel:
Aug  1 11:22:53 localhost kernel: stack backtrace:
Aug  1 11:22:53 localhost kernel: Pid: 2558, comm: NetworkManager Not tainted
2.6.27-0.205.rc1.git2.fc10.i686 #1
Aug  1 11:22:53 localhost kernel: [<c0680579>] ? printk+0x14/0x1b
Aug  1 11:22:53 localhost kernel: [<c044b7e8>] __lock_acquire+0x6be/0x97d
Aug  1 11:22:53 localhost kernel: [<c044ac07>] ? trace_hardirqs_on+0xb/0xd
Aug  1 11:22:53 localhost kernel: [<c044bb11>] lock_acquire+0x6a/0x90
Aug  1 11:22:53 localhost kernel: [<c061e75c>] ? dev_deactivate+0x57/0xfa
Aug  1 11:22:53 localhost kernel: [<c0682947>] _spin_lock+0x21/0x4e
Aug  1 11:22:53 localhost kernel: [<c061e75c>] ? dev_deactivate+0x57/0xfa
Aug  1 11:22:53 localhost kernel: [<c061e75c>] dev_deactivate+0x57/0xfa
Aug  1 11:22:53 localhost kernel: [<c0610469>] dev_close+0x6d/0x9a
Aug  1 11:22:53 localhost kernel: [<f91ba51a>] ieee80211_stop+0x324/0x363 [mac80211]
Aug  1 11:22:53 localhost kernel: [<c0610477>] dev_close+0x7b/0x9a
Aug  1 11:22:53 localhost kernel: [<c0610176>] dev_change_flags+0xa1/0x154
Aug  1 11:22:53 localhost kernel: [<c0616f15>] ? rtnl_setlink+0x0/0xdb
Aug  1 11:22:53 localhost kernel: [<c0616e63>] do_setlink+0x26b/0x31d
Aug  1 11:22:53 localhost kernel: [<c0682788>] ? _read_unlock+0x22/0x25
Aug  1 11:22:53 localhost kernel: [<c0616f15>] ? rtnl_setlink+0x0/0xdb
Aug  1 11:22:53 localhost kernel: [<c0616fec>] rtnl_setlink+0xd7/0xdb
Aug  1 11:22:53 localhost kernel: [<c0617da0>] rtnetlink_rcv_msg+0x19d/0x1b7
Aug  1 11:22:53 localhost kernel: [<c0617c03>] ? rtnetlink_rcv_msg+0x0/0x1b7
Aug  1 11:22:53 localhost kernel: [<c0625883>] netlink_rcv_skb+0x35/0x7a
Aug  1 11:22:53 localhost kernel: [<c0617bfb>] rtnetlink_rcv+0x23/0x2b
Aug  1 11:22:53 localhost kernel: [<c062547d>] netlink_unicast+0xf6/0x14c
Aug  1 11:22:53 localhost kernel: [<c062570a>] netlink_sendmsg+0x237/0x244
Aug  1 11:22:53 localhost kernel: [<c06042bf>] __sock_sendmsg+0x4a/0x53
Aug  1 11:22:53 localhost kernel: [<c0604afa>] sock_sendmsg+0xbd/0xd3
Aug  1 11:22:53 localhost kernel: [<c043e466>] ? autoremove_wake_function+0x0/0x38
Aug  1 11:22:53 localhost kernel: [<c04087b6>] ? native_sched_clock+0xb3/0xd3
Aug  1 11:22:53 localhost kernel: [<c0408633>] ? sched_clock+0x8/0xb
Aug  1 11:22:53 localhost kernel: [<c044942d>] ? lock_release_holdtime+0x1a/0x115
Aug  1 11:22:53 localhost kernel: [<c041e1a6>] ? need_resched+0x18/0x22
Aug  1 11:22:53 localhost kernel: [<c0518b6b>] ? copy_from_user+0x3e/0x125
Aug  1 11:22:53 localhost kernel: [<c060b47e>] ? verify_iovec+0x45/0x73
Aug  1 11:22:53 localhost kernel: [<c0604c54>] sys_sendmsg+0x144/0x197
Aug  1 11:22:53 localhost kernel: [<c06057a7>] ? sys_recvmsg+0x173/0x180
Aug  1 11:22:53 localhost kernel: [<c0605494>] ? sys_sendto+0xba/0xc8
Aug  1 11:22:53 localhost kernel: [<c0496705>] ? check_valid_pointer+0x24/0x53
Aug  1 11:22:53 localhost kernel: [<c0496d72>] ? check_object+0x131/0x165
Aug  1 11:22:53 localhost kernel: [<c044abdb>] ? trace_hardirqs_on_caller+0xf9/0x11a
Aug  1 11:22:53 localhost kernel: [<c04aa7c5>] ? d_free+0x40/0x52
Aug  1 11:22:53 localhost kernel: [<c04aa7c5>] ? d_free+0x40/0x52
Aug  1 11:22:53 localhost kernel: [<c0605db7>] sys_socketcall+0x16d/0x1a6
Aug  1 11:22:53 localhost kernel: [<c040a103>] ? syscall_trace_enter+0xba/0xce
Aug  1 11:22:53 localhost kernel: [<c0403cbe>] syscall_call+0x7/0xb
Aug  1 11:22:53 localhost kernel: =======================
Aug  1 11:22:53 localhost kernel: iwl3945 0000:03:00.0: PCI INT A disabled
Aug  1 11:22:54 localhost acpid: exiting
Aug  1 11:22:55 localhost ntpd[2707]: ntpd exiting on signal 15
Aug  1 11:22:55 localhost iscsid: iscsid shutting down.
Aug  1 11:22:55 localhost nm-system-settings: disconnected from the system bus,
exiting.
Aug  1 11:22:55 localhost nm-system-settings:
nm_sysconfig_settings_remove_connection: assertion `NM_IS_SYSCONFIG_SETTINGS
(self)' failed
Aug  1 11:22:55 localhost nm-dispatcher.action: Disconnected from the system
bus, exiting.
Aug  1 11:22:55 localhost restorecond: terminated
Aug  1 11:22:56 localhost auditd[2294]: The audit daemon is exiting.


Version-Release number of selected component (if applicable):
kernel-2.6.27-0.208.rc1.git2.fc10.i686

How reproducible:
frequently on shutdown

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-08-03 11:41:56 EDT
Got another one that may be similar.

I get these on shutdown.

Aug  2 18:39:17 localhost NetworkManager: <info>  (wlan0): taking down device.
Aug  2 18:39:18 localhost kernel:
Aug  2 18:39:18 localhost kernel: =============================================
Aug  2 18:39:18 localhost kernel: [ INFO: possible recursive locking detected ]
Aug  2 18:39:18 localhost kernel: 2.6.27-0.211.rc1.git3.fc10.i686 #1
Aug  2 18:39:18 localhost kernel: ---------------------------------------------
Aug  2 18:39:18 localhost kernel: iwl3945/0/1005 is trying to acquire lock:
Aug  2 18:39:18 localhost kernel: (_xmit_IEEE80211#2){-+..}, at: [<f91c1a67>] ieee80211_scan_completed+0x115/0x279 [mac80211]
Aug  2 18:39:18 localhost kernel:
Aug  2 18:39:18 localhost kernel: but task is already holding lock:
Aug  2 18:39:18 localhost kernel: (_xmit_IEEE80211#2){-+..}, at: [<f91c1a67>] ieee80211_scan_completed+0x115/0x279 [mac80211]
Aug  2 18:39:18 localhost kernel:
Aug  2 18:39:18 localhost kernel: other info that might help us debug this:
Aug  2 18:39:18 localhost kernel: 3 locks held by iwl3945/0/1005:
Aug  2 18:39:18 localhost kernel: #0:  (iwl3945){--..}, at: [<c043b045>] run_workqueue+0x96/0x1a5
Aug  2 18:39:18 localhost kernel: #1:  (&priv->scan_completed){--..}, at: [<c043b045>] run_workqueue+0x96/0x1a5
Aug  2 18:39:18 localhost kernel: #2:  (_xmit_IEEE80211#2){-+..}, at: [<f91c1a67>] ieee80211_scan_completed+0x115/0x279 [mac80211]
Aug  2 18:39:18 localhost kernel:
Aug  2 18:39:18 localhost kernel: stack backtrace:
Aug  2 18:39:18 localhost kernel: Pid: 1005, comm: iwl3945/0 Not tainted 2.6.27-0.211.rc1.git3.fc10.i686 #1
Aug  2 18:39:18 localhost kernel: [<c06805d9>] ? printk+0x14/0x1b
Aug  2 18:39:18 localhost kernel: [<c044b7e8>] __lock_acquire+0x6be/0x97d
Aug  2 18:39:18 localhost kernel: [<c0496761>] ? check_valid_pointer+0x24/0x53
Aug  2 18:39:18 localhost kernel: [<c044abdb>] ? trace_hardirqs_on_caller+0xf9/0x11a
Aug  2 18:39:18 localhost kernel: [<c044bb11>] lock_acquire+0x6a/0x90
Aug  2 18:39:18 localhost kernel: [<f91c1a67>] ? ieee80211_scan_completed+0x115/0x279 [mac80211]
Aug  2 18:39:18 localhost kernel: [<c06829a7>] _spin_lock+0x21/0x4e
Aug  2 18:39:18 localhost kernel: [<f91c1a67>] ? ieee80211_scan_completed+0x115/0x279 [mac80211]
Aug  2 18:39:18 localhost kernel: [<f91c1a67>] ieee80211_scan_completed+0x115/0x279 [mac80211]
Aug  2 18:39:18 localhost kernel: [<c0408633>] ? sched_clock+0x8/0xb
Aug  2 18:39:18 localhost kernel: [<f925458d>] iwl3945_bg_scan_completed+0x8d/0xac [iwl3945]
Aug  2 18:39:18 localhost kernel: [<c043b086>] run_workqueue+0xd7/0x1a5
Aug  2 18:39:18 localhost kernel: [<c043b045>] ? run_workqueue+0x96/0x1a5
Aug  2 18:39:18 localhost kernel: [<f9254500>] ? iwl3945_bg_scan_completed+0x0/0xac [iwl3945]
Aug  2 18:39:18 localhost kernel: [<c043b225>] worker_thread+0xd1/0xdd
Aug  2 18:39:18 localhost kernel: [<c043e466>] ? autoremove_wake_function+0x0/0x38
Aug  2 18:39:18 localhost kernel: [<c043b154>] ? worker_thread+0x0/0xdd
Aug  2 18:39:18 localhost kernel: [<c043e1b4>] kthread+0x40/0x66
Aug  2 18:39:18 localhost kernel: [<c043e174>] ? kthread+0x0/0x66
Aug  2 18:39:18 localhost kernel: [<c0404957>] kernel_thread_helper+0x7/0x10
Aug  2 18:39:18 localhost kernel: =======================
Aug  2 18:39:18 localhost kernel: iwl3945 0000:03:00.0: PCI INT A disabled
Comment 2 John W. Linville 2008-08-12 11:39:09 EDT

*** This bug has been marked as a duplicate of bug 457592 ***

Note You need to log in before you can comment on or make changes to this bug.