Bug 457592 - recursive locking in/with prism54pci
recursive locking in/with prism54pci
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 457599 457670 457714 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 13:12 EDT by Ronald Warsow
Modified: 2008-08-12 11:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 11:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Warsow 2008-08-01 13:12:25 EDT
Description of problem:
on startup I see INFO: possible recursive locking detected

Version-Release number of selected component (if applicable):
kernel 2.6.27-0.205.rc1.git2.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Expected results:

Additional info:

message:
...
ehci_hcd 0000:00:0b.1: suspend root hub
Bridge firewalling registered
virbr0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
firmware: requesting isl3886
ADDRCONF(NETDEV_UP): wlan0: link is not ready
virbr0: starting userspace STP failed, starting kernel STP

=============================================
[ INFO: possible recursive locking detected ]
2.6.27-0.205.rc1.git2.fc10.x86_64 #1
---------------------------------------------
prism54pci/1598 is trying to acquire lock:
 (_xmit_IEEE80211#2){-...}, at: [<ffffffffa00bcc52>]
ieee80211_scan_completed+0x142/0x2e2 [mac80211]

but task is already holding lock:
 (_xmit_IEEE80211#2){-...}, at: [<ffffffffa00bcc52>]
ieee80211_scan_completed+0x142/0x2e2 [mac80211]

other info that might help us debug this:
3 locks held by prism54pci/1598:
 #0:  ((name)){--..}, at: [<ffffffff81054572>] run_workqueue+0xb6/0x207
 #1:  (&(&local->scan_work)->work){--..}, at: [<ffffffff81054572>]
run_workqueue+0xb6/0x207
 #2:  (_xmit_IEEE80211#2){-...}, at: [<ffffffffa00bcc52>]
ieee80211_scan_completed+0x142/0x2e2 [mac80211]

stack backtrace:
Pid: 1598, comm: prism54pci Not tainted 2.6.27-0.205.rc1.git2.fc10.x86_64 #1

Call Trace:
 [<ffffffff8106686d>] __lock_acquire+0x790/0xaa7
 [<ffffffffa00bcc52>] ? ieee80211_scan_completed+0x142/0x2e2 [mac80211]
 [<ffffffff81066c1a>] lock_acquire+0x96/0xc3
 [<ffffffffa00bcc52>] ? ieee80211_scan_completed+0x142/0x2e2 [mac80211]
 [<ffffffff8130c728>] _spin_lock+0x2b/0x58
 [<ffffffffa00bcc52>] ieee80211_scan_completed+0x142/0x2e2 [mac80211]
 [<ffffffffa00bd0a3>] ieee80211_sta_scan_work+0xb4/0x1ad [mac80211]
 [<ffffffff810545bc>] run_workqueue+0x100/0x207
 [<ffffffffa00bcfef>] ? ieee80211_sta_scan_work+0x0/0x1ad [mac80211]
 [<ffffffff810547c0>] worker_thread+0xfd/0x111
 [<ffffffff810584f1>] ? autoremove_wake_function+0x0/0x3d
 [<ffffffff810546c3>] ? worker_thread+0x0/0x111
 [<ffffffff81058174>] kthread+0x4e/0x7b
 [<ffffffff810118a9>] child_rip+0xa/0x11
 [<ffffffff81010bbe>] ? restore_args+0x0/0x30
 [<ffffffff81058126>] ? kthread+0x0/0x7b
 [<ffffffff8101189f>] ? child_rip+0x0/0x11

virbr0: no IPv6 routers present
eth0: no IPv6 routers present
usb usb1: usb auto-resume
ehci_hcd 0000:00:0b.1: resume root hub
hub 1-0:1.0: hub_resume
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0000
hub 1-0:1.0: hub_suspend
usb usb1: bus auto-suspend
ehci_hcd 0000:00:0b.1: suspend root hub
usb usb1: usb auto-resume
ehci_hcd 0000:00:0b.1: resume root hub
hub 1-0:1.0: hub_resume
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0000
hub 1-0:1.0: hub_suspend
usb usb1: bus auto-suspend
ehci_hcd 0000:00:0b.1: suspend root hub
usb usb1: usb auto-resume
ehci_hcd 0000:00:0b.1: resume root hub
hub 1-0:1.0: hub_resume
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0000
hub 1-0:1.0: hub_suspend
usb usb1: bus auto-suspend
ehci_hcd 0000:00:0b.1: suspend root hub
usb usb1: usb auto-resume
ehci_hcd 0000:00:0b.1: resume root hub
hub 1-0:1.0: hub_resume
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0000
hub 1-0:1.0: hub_suspend
usb usb1: bus auto-suspend
ehci_hcd 0000:00:0b.1: suspend root hub
usb usb1: usb auto-resume
ehci_hcd 0000:00:0b.1: resume root hub
hub 1-0:1.0: hub_resume
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0000
hub 1-0:1.0: hub_suspend
usb usb1: bus auto-suspend
ehci_hcd 0000:00:0b.1: suspend root hub

...

As far as I can say (short test) I ONLY see this USB-{resume,suspend}-stuff when
I have the firmware (isl3886) under /lib/firware, eg. gets loaded.
Comment 1 John W. Linville 2008-08-01 13:35:15 EDT
I think there is already a patch offered upstream for this...I'll try to get it
merged soon.
Comment 2 Ronald Warsow 2008-08-01 15:09:31 EDT
okay. thanks for quick support!
Comment 3 Ronald Warsow 2008-08-07 17:47:49 EDT
with 2.6.27-0.237.rc2.fc10.x86_64 it's gone 

Question: I am unsure if "I" am allowed to close this bug, am I ?
could save some work.
Comment 4 John W. Linville 2008-08-12 11:39:09 EDT
*** Bug 457599 has been marked as a duplicate of this bug. ***
Comment 5 John W. Linville 2008-08-12 11:39:24 EDT
*** Bug 457670 has been marked as a duplicate of this bug. ***
Comment 6 John W. Linville 2008-08-12 11:40:42 EDT
*** Bug 457714 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.