Bug 457633 - Duplicate entries in kde menu editor and others
Duplicate entries in kde menu editor and others
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
: 459557 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 20:32 EDT by john5342
Modified: 2008-09-24 20:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.1.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 20:05:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 168097 None None None Never

  None (edit)
Description john5342 2008-08-01 20:32:59 EDT
Description of problem:
When i open the kde menu editor 2 entries appear of most kde applications. No
other applications seem affected so it seems kde specific. The duplicate entries
do not show in the actually menu though.
Probably related. The exact same entries also show up twice in the Application
Manuals in the KDE Help Centre.

Version-Release number of selected component (if applicable):
Using KDE 4.0.5 and all available stable updates.
I am also fairly certain i have noticed this since the start of fedora 9 and
possibly fedora 8.
On my second computer i am using KDE 4.1.0 from updates-testing and that shows
the same results.

How reproducible:
Always.

Steps to Reproduce:
1. Install fedora.
2. Open kde menu editor.
3. Look through entries.
  
Actual results:
Most if not all kde applications have duplicate entries.

Expected results:
Each application has a single entry.

Additional info:
Comment 1 Rex Dieter 2008-08-01 23:51:08 EDT
confirmed, looks like we'll need to report this upstream to bugs.kde.org. 
Please do so (else, I'll do it... eventually).
Comment 2 Kevin Kofler 2008-08-02 00:00:15 EDT
Given that this is already broken in 4.0.x, and also considering it has only 
low impact, we will not hold up the 4.1.0 update for this issue.

> I am also fairly certain i have noticed this since the start of fedora 9 and
> possibly fedora 8.

I doubt Fedora 8 is affected by this, Fedora 8 has KDE 3, not KDE 4, and I 
don't see this bug on Fedora 8.
Comment 3 john5342 2008-08-02 07:10:47 EDT
Have reported this bug as http://bugs.kde.org/show_bug.cgi?id=168097
Comment 4 Rex Dieter 2008-08-02 07:51:31 EDT
thanks, we'll continue to track this upstream.
Comment 5 Kevin Kofler 2008-08-19 23:45:18 EDT
*** Bug 459557 has been marked as a duplicate of this bug. ***
Comment 6 Jithin Emmanuel 2008-08-19 23:53:11 EDT
Is it really upstream. I saw in ubuntu using kde 4.1 no duplicate entries.
Comment 7 Ngo Than 2008-08-20 05:56:33 EDT
I don't see this issue with a new user on my local machine. It seems the old KDE settings cause this issue.
Comment 8 john5342 2008-08-20 06:21:52 EDT
I can confirm if i do a fresh install of f9 and update everything before i log into kde (ie dont create any config) i dont get the duplicate entries either so it would indeed appear to be a relic of a past bug somewhere.

If this bug is indeed down to a past issue then are there any objections to me closing the bug upstream?
Comment 9 Jithin Emmanuel 2008-08-20 07:32:05 EDT
I installed a new user on my machine and problem is there.
Are you telling that now I have to install my fedora fresh and log into gnome do all updates and then log into kde. That sounds creepy.
Comment 10 Jithin Emmanuel 2008-08-20 07:43:15 EDT
Is there any other work arounds? other than doing a fresh install.
Comment 11 john5342 2008-08-20 07:50:00 EDT
No i said from a fresh install do all updates *before* logging into kde (i
actually did it from the terminal rather than gnome). The bug doesnt seem to
appear when that is done. I dont however know that the bug isnt caused by
something else. Only that it doesnt seem to appear under those circumstances
for me. Even though i did have the problem before.

Regardless of if it solves the problem or not i would hardly suggest that
everybody re-install fedora 9 from scratch just to (possibly) fix a miniscule
problem like this.

I was just noting that the problem appears to be caused by some past bug in
either kde or the packages and some configuration problem left over from it is
causing the duplicates even though the bug itself appears to be (possibly)
gone.

If this is a leftover of a past bug then maybe the real question is how to clean up the config problem. Ofcourse if Jithin still has the problem after creating the new user then maybe my theory is wrong anyway. Only stating my personal experiences in the hope it will help this bug along.
Comment 12 Jithin Emmanuel 2008-08-20 23:43:58 EDT
Since this bug is closed, does that mean that no one is gonna fix this.
Comment 13 Kevin Kofler 2008-08-21 04:24:12 EDT
CLOSED UPSTREAM means it has been reported upstream at bugs.kde.org and we're waiting for something to be done about it upstream.
Comment 14 Ngo Than 2008-08-22 07:30:16 EDT
strange, i don't see this issue with new user, and i don't have to install F9 new. Do you use lancelot?
Comment 15 Jithin Emmanuel 2008-08-22 07:50:50 EDT
no. what is lancelot?
Comment 16 Kevin Kofler 2008-08-28 18:40:15 EDT
Should be fixed in kdelibs-4.1.0-8 which I just committed to devel/rawhide. Builds coming soon.
Comment 17 Kevin Kofler 2008-08-29 05:43:24 EDT
Try kdelibs-4.1.0-9.fc9: http://koji.fedoraproject.org/koji/buildinfo?buildID=60797
(apidocs still building, the rest is built already).
Comment 18 john5342 2008-09-10 18:38:46 EDT
Finally got around to installing these packages from koji.

Update fixed problem for me.
Comment 19 Fedora Update System 2008-09-14 02:48:29 EDT
kdebase4-4.1.1-1.fc8, kdelibs4-4.1.1-5.fc8, kdepimlibs-4.1.1-2.fc8, kdebase-runtime-4.1.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase4 kdelibs4 kdepimlibs kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7838
Comment 20 Fedora Update System 2008-09-14 02:52:02 EDT
kdeaccessibility-4.1.1-1.fc9, kdeadmin-4.1.1-1.fc9, kdeartwork-4.1.1-1.fc9, kdebase-4.1.1-1.fc9, kdebase-runtime-4.1.1-2.fc9, kdebase-workspace-4.1.1-1.fc9, kdebindings-4.1.1-1.fc9, kdeedu-4.1.1-1.fc9, kdegames-4.1.1-1.fc9, kdegraphics-4.1.1-1.fc9, kdelibs-4.1.1-5.fc9, kdemultimedia-4.1.1-1.fc9, kdenetwork-4.1.1-1.fc9, kdeplasma-addons-4.1.1-1.fc9, kdesdk-4.1.1-1.fc9, kdetoys-4.1.1-1.fc9, kdeutils-4.1.1-1.fc9, guidance-power-manager-4.1.1-1.fc9, kiconedit-4.1.1-1.fc9, konq-plugins-4.1.1-1.fc9, kcoloredit-4.1.1-1.fc9, kdepimlibs-4.1.1-2.fc9, kde-l10n-4.1.1-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeaccessibility kdeadmin kdeartwork kdebase kdebase-runtime kdebase-workspace kdebindings kdeedu kdegames kdegraphics kdelibs kdemultimedia kdenetwork kdeplasma-addons kdesdk kdetoys kdeutils guidance-power-manager kiconedit konq-plugins kcoloredit kdepimlibs kde-l10n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7789
Comment 21 Fedora Update System 2008-09-24 20:00:56 EDT
kdepimlibs-4.1.1-2.fc8, kdebase-runtime-4.1.1-2.fc8, kdebase4-4.1.1-1.fc8, kdelibs4-4.1.1-12.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2008-09-24 20:05:00 EDT
kdeadmin-4.1.1-1.fc9, kdeartwork-4.1.1-1.fc9, kdebase-4.1.1-1.fc9, kdebase-runtime-4.1.1-2.fc9, kdebase-workspace-4.1.1-1.fc9, kdebindings-4.1.1-1.fc9, kdeedu-4.1.1-1.fc9, kdegames-4.1.1-1.fc9, kdegraphics-4.1.1-1.fc9, kdenetwork-4.1.1-1.fc9, kdeplasma-addons-4.1.1-1.fc9, kdesdk-4.1.1-1.fc9, kdetoys-4.1.1-1.fc9, kdeutils-4.1.1-1.fc9, guidance-power-manager-4.1.1-1.fc9, kiconedit-4.1.1-1.fc9, konq-plugins-4.1.1-1.fc9, kcoloredit-4.1.1-1.fc9, kdepimlibs-4.1.1-2.fc9, kdelibs-4.1.1-12.fc9, kde-l10n-4.1.1-2.fc9, kdemultimedia-4.1.1-2.fc9, kdeaccessibility-4.1.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.