This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 457657 - reproducable traceback on start
reproducable traceback on start
Status: CLOSED DUPLICATE of bug 457502
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-02 20:11 EDT by David Nielsen
Modified: 2008-08-02 20:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-02 20:59:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2008-08-02 20:11:58 EDT
Description of problem:
Deluge consistently throws a traceback on start up currently on F10. The following output can be captured on a fresh profile.

[david@harris ~]$ deluge
[INFO    ] 00:03:33 main:84 Deluge ui 0.9.04
[DEBUG   ] 00:03:33 main:85 options: {'config': None, 'logfile': None, 'ui': None}
[DEBUG   ] 00:03:33 main:86 args: []
[DEBUG   ] 00:03:33 configmanager:44 ConfigManager started..
[INFO    ] 00:03:33 main:89 Starting ui..
[DEBUG   ] 00:03:33 ui:44 UI init..
[DEBUG   ] 00:03:33 configmanager:88 Getting config 'ui.conf'
[DEBUG   ] 00:03:33 config:47 Config created with filename: ui.conf
[DEBUG   ] 00:03:33 config:48 Config defaults: {'default_ui': 'gtk'}
[INFO    ] 00:03:33 ui:60 Starting GtkUI..
[DEBUG   ] 00:03:34 client:54 CoreProxy init..
[DEBUG   ] 00:03:34 configmanager:69 get_config_dir: /home/david/.config/deluge
Traceback (most recent call last):
  File "/usr/bin/deluge", line 8, in <module>
    load_entry_point('deluge==0.9.04', 'console_scripts', 'deluge')()
  File "/usr/lib64/python2.5/site-packages/deluge/main.py", line 90, in start_ui
    UI(options, args)
  File "/usr/lib64/python2.5/site-packages/deluge/ui/ui.py", line 62, in __init__
    ui = GtkUI(args)
  File "/usr/lib64/python2.5/site-packages/deluge/ui/gtkui/gtkui.py", line 109, in __init__
    gtk.gdk.threads_init()
SystemError: error return without exception set

Version-Release number of selected component (if applicable):
deluge-0.9.04-1.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. upgrade to F10
2. install deluge
3. watch in horror as it fails on startup
  
Actual results:
less crying

Expected results:
torrenty joy

Additional info:
da_DK.UTF-8
Comment 1 Peter Gordon 2008-08-02 20:59:48 EDT
This appears to be the same pygtk issue as in bug 457502. Please re-open this bug with further details if this is not the case. 

Thanks.

*** This bug has been marked as a duplicate of bug 457502 ***

Note You need to log in before you can comment on or make changes to this bug.