Bug 457502 - gtk.gdk.threads_init() crash
gtk.gdk.threads_init() crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pygobject2 (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
: 457657 457987 458398 (view as bug list)
Depends On:
Blocks: 455555
  Show dependency treegraph
 
Reported: 2008-08-01 02:06 EDT by Mamoru TASAKA
Modified: 2008-08-23 00:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-23 00:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Workaround patch for deluge 0.9.04 gtk ui (411 bytes, patch)
2008-08-01 02:40 EDT, Mamoru TASAKA
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 546149 None None None Never

  None (edit)
Description Mamoru TASAKA 2008-08-01 02:06:48 EDT
Description of problem:
[tasaka1@localhost ~]$ deluge
[INFO    ] 14:45:38 main:84 Deluge ui 0.9.03
[DEBUG   ] 14:45:38 main:85 options: {'config': None, 'logfile': None, 'ui': None}
[DEBUG   ] 14:45:38 main:86 args: []
[DEBUG   ] 14:45:38 configmanager:44 ConfigManager started..
[INFO    ] 14:45:38 main:89 Starting ui..
[DEBUG   ] 14:45:38 ui:44 UI init..
[DEBUG   ] 14:45:38 configmanager:88 Getting config 'ui.conf'
[DEBUG   ] 14:45:38 config:47 Config created with filename: ui.conf
[DEBUG   ] 14:45:38 config:48 Config defaults: {'default_ui': 'gtk'}
[INFO    ] 14:45:38 ui:60 Starting GtkUI..
[DEBUG   ] 14:45:38 client:54 CoreProxy init..
[DEBUG   ] 14:45:39 configmanager:69 get_config_dir: /home/tasaka1/.config/deluge
Traceback (most recent call last):
  File "/usr/bin/deluge", line 8, in <module>
    load_entry_point('deluge==0.9.03', 'console_scripts', 'deluge')()
  File "/usr/lib/python2.5/site-packages/deluge/main.py", line 90, in start_ui
    UI(options, args)
  File "/usr/lib/python2.5/site-packages/deluge/ui/ui.py", line 62, in __init__
    ui = GtkUI(args)
  File "/usr/lib/python2.5/site-packages/deluge/ui/gtkui/gtkui.py", line 106, in
__init__
    gtk.gdk.threads_init()
SystemError: error return without exception set


Version-Release number of selected component (if applicable):
deluge-0.9.03-2.fc10.i386

How reproducible:
100%


Additional info:
0.9.04 won't start either.
Comment 1 Mamoru TASAKA 2008-08-01 02:40:43 EDT
Created attachment 313165 [details]
Workaround patch for deluge 0.9.04 gtk ui

While I am not sure this is a correct method, for me the attached patch can be
a workaroud.

! Note: I created this patch against 0.9.04 although I think this patch can be
  applied for 0.9.03.
Comment 2 Mamoru TASAKA 2008-08-01 11:42:35 EDT
Umm... This issue happended also on reviewing libhocr (bug 455555) such as:

$ hocr-gtk
Traceback (most recent call last):
  File "/usr/bin/hocr-gtk", line 1310, in <module>
    gtk.gdk.threads_init()
SystemError: error return without exception set

Once switching the component to pygtk2.
Comment 3 Peter Gordon 2008-08-02 20:59:49 EDT
*** Bug 457657 has been marked as a duplicate of this bug. ***
Comment 4 Michel Alexandre Salim 2008-08-03 18:10:06 EDT
Affects Miro as well. Is PyGTK2 2.12 incompatible with gtk2-2.13.x? The bug should probably be reported upstream.
Comment 5 Mamoru TASAKA 2008-08-04 06:43:43 EDT
It seems Mandriva fixed this issue 3 hours ago:

https://qa.mandriva.com/show_bug.cgi?id=42467
http://cia.vc/stats/project/Mandriva/.message/456d2e6
http://svn.mandriva.com/svn/packages/cooker/python-gobject/current/SOURCES/pygobject-fix-api-breakage.patch

I tried to apply the patch by Mandriva and for me deluge and hocr-gtk seem
to be working.

Once changing the component to pygobject2.
Comment 6 Matthew Barnes 2008-08-07 15:20:54 EDT
Fixed in pygobject2-2.15.2-2.fc10.
Comment 7 Matthew Barnes 2008-08-07 20:13:51 EDT
*** Bug 458398 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Berrange 2008-08-08 08:30:31 EDT
*** Bug 457987 has been marked as a duplicate of this bug. ***
Comment 9 Michel Alexandre Salim 2008-08-22 17:10:34 EDT
As noted in the Mandriva bug report that Mamoru linked to, 2.15.2 is still not a complete fix: Miro silently freezes in Rawhide the same way it does in Mandrake Cooker.

Also, conduit does not work against pygobject2 2.15, failing in Python/ceval.c with the following:

PyEval_EvalCodeEx: Assertion `tstate != ((void *)0)' failed

Downgrading pygobject2 to 2.14 from F9-updates fixes the conduit problem (but not a solution due to API changes: Miro no longer works).
Comment 10 Michel Alexandre Salim 2008-08-23 00:39:05 EDT
Actually fixed in pygobject2-2.15.2-3.fc10, which due to the security intrusion affecting Fedora has not been pushed to the Rawhide repository yet.

The conduit error is a different pygobject2 bug; filing separately:

https://bugzilla.redhat.com/show_bug.cgi?id=459861

Note You need to log in before you can comment on or make changes to this bug.