Bug 457666 - new version of evdev forces a us keyboard
new version of evdev forces a us keyboard
Status: CLOSED DUPLICATE of bug 436405
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 03:58 EDT by BeGe
Modified: 2008-08-03 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-03 19:35:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (18.25 KB, text/plain)
2008-08-03 04:08 EDT, BeGe
no flags Details

  None (edit)
Description BeGe 2008-08-03 03:58:21 EDT
Description of problem:
My keyboard as now a "us" layout although it is declared as "fr"


Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.0.3-1.fc10.i386


How reproducible:
It is systematic on my pc


Steps to Reproduce:
1.boot
2.start xwindow
3.
  
Actual results:
us keyboard


Expected results:
fr keyboard


Additional info:
this problem did not exist with
xorg-x11-drv-evdev-2.0.2-1.fc10.i386
my input device definition in xorg.conf is
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "fr"
	Option	    "XkbVariant" "latin9"
EndSection
Comment 1 BeGe 2008-08-03 04:08:04 EDT
Created attachment 313284 [details]
xorg log

At the end of the log files appears the us keyboard !
Comment 2 denis ivanov 2008-08-03 13:16:49 EDT
100% the same bug with:

xorg-x11-drv-evdev-2.0.2-1.fc10.i386
xorg-x11-server-common-1.4.99.906-2.fc10.i386
xorg-x11-server-Xorg-1.4.99.906-2.fc10.i386

Also after this update have a problem with keyboard speed settings. It's defined by xfce settings manager (keyboard settings) with fast key repeat speed.

But the problem, for example, my LEFT key works with usual (slow) speed, but RIGHT key is ok (fast). The same with UP/DOWN keys.

The SAME problem was happened few months ago and was connected to evdev changes.
Comment 3 Peter Hutterer 2008-08-03 19:35:00 EDT
(In reply to comment #0)
> Description of problem:
> My keyboard as now a "us" layout although it is declared as "fr"

You are seeing a conflict between evdev and keyboard. The following article explains what goes on behind the scenes that causes it.
http://who-t.blogspot.com/2008/07/input-configuration-in-nutshell.html


(In reply to comment #2)
> Also after this update have a problem with keyboard speed settings. It's
> defined by xfce settings manager (keyboard settings) with fast key repeat
> speed.
> 
> But the problem, for example, my LEFT key works with usual (slow) speed, but
> RIGHT key is ok (fast). The same with UP/DOWN keys.

please file a separate bug for this, including the log file and the xfce settings. thx.

*** This bug has been marked as a duplicate of bug 436405 ***

Note You need to log in before you can comment on or make changes to this bug.