Bug 436405 - f9 xorg no longer honors my mouse settings
f9 xorg no longer honors my mouse settings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 457666 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 18:02 EST by Josef Bacik
Modified: 2008-08-03 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 03:20:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my xorg.0.log (22.29 KB, text/plain)
2008-03-06 18:02 EST, Josef Bacik
no flags Details
my xorg.conf (1.16 KB, text/plain)
2008-03-06 18:02 EST, Josef Bacik
no flags Details

  None (edit)
Description Josef Bacik 2008-03-06 18:02:09 EST
Description of problem:
I have a logitech trackball that I have a custom xorg configuration for so I can
emulate scrolling by holding one of the special buttons and then rolling the
trackball.  I've had this configuration since fc6 and it has worked fine, now
all of a sudden its not working.  It does however do what it would do in
windows/OS x, where if i press the side buttons it will scroll the window up and
down, which is cool that the driver now recognizes that, however I like my
configuration _much_ better.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mouse-1.2.3-4.fc9.x86_64
Comment 1 Josef Bacik 2008-03-06 18:02:09 EST
Created attachment 297119 [details]
my xorg.0.log
Comment 2 Josef Bacik 2008-03-06 18:02:54 EST
Created attachment 297120 [details]
my xorg.conf
Comment 3 Josef Bacik 2008-03-06 18:10:53 EST
Hmm, I thought this might be related to evdev, so I did a 

Section "Module"
     Disable  "evdev"
EndSection

but for some reason it still loads.  If i look at my Xorg.0.log I see it say
"evdev will not be loaded", but it still loads it, and my config is still ignored.
Comment 4 Josef Bacik 2008-05-02 15:45:46 EDT
still happening.
Comment 5 Bug Zapper 2008-05-14 01:50:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Peter Hutterer 2008-07-16 03:20:36 EDT
You're seeing a conflict between hotplugged input devices and the actual
devices. These are added with the evdev driver, and default options.
Furthermore, evdev grabs the device file, so any device added through hotplug
won't feed into /dev/input/mice (i.e. all mice).

In your case, this means that your mouse is still there, but since all devices
stopped sending to /dev/input/mice it doesn't send any events.

The only option for now is to add "Option "AutoAddDevices" "off" to your
ServerLayout. This deactivates input device hotplugging and the mouse will use
the options specified in the config.

Eventually, evdev should get EmulateWheel support [1], but upstream doesn't have
it yet. See also [2]

Closing as NOTABUG, since it was caused by configuration error.

[1] http://bugs.freedesktop.org/show_bug.cgi?id=4147
[2] https://bugzilla.redhat.com/show_bug.cgi?id=446627
Comment 7 Peter Hutterer 2008-08-03 19:35:00 EDT
*** Bug 457666 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.